Merge branch 'patches/marcus/stripchart'
[debian/gnuradio] / config / grc_gr_audio_jack.m4
index 5947648f007d9921c57ec4e993c8d58e502efd19..d1853588bbabbb64e568ea5066a265654126e02b 100644 (file)
@@ -1,10 +1,10 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
 dnl 
 dnl This file is part of GNU Radio
 dnl 
 dnl GNU Radio is free software; you can redistribute it and/or modify
 dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 2, or (at your option)
+dnl the Free Software Foundation; either version 3, or (at your option)
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
 dnl any later version.
 dnl 
 dnl GNU Radio is distributed in the hope that it will be useful,
@@ -18,20 +18,29 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_JACK],[
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_JACK],[
-    GRC_ENABLE([gr-audio-jack])
+    GRC_ENABLE(gr-audio-jack)
+
+    dnl Don't do gr-audio-jack if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-jack, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-audio-jack if in 'jack' isn't installed
+        PKG_CHECK_MODULES(JACK, jack >= 0.8, [],
+            [passed=no;AC_MSG_RESULT([gr-audio-jack requires package jack, not found.])])
+    fi
 
     AC_CONFIG_FILES([ \
 
     AC_CONFIG_FILES([ \
-       gr-audio-jack/Makefile \
+        gr-audio-jack/Makefile \
+       gr-audio-jack/gnuradio-audio-jack.pc \
         gr-audio-jack/src/Makefile \
         gr-audio-jack/src/Makefile \
-       gr-audio-jack/src/run_tests \
+        gr-audio-jack/src/run_tests \
     ])
 
     ])
 
-    passed=yes
-    PKG_CHECK_MODULES(JACK, jack >= 0.8,[],
-        [passed=no;AC_MSG_RESULT([gr-audio-jack requires package jack, not found.])])
-
-    GRC_BUILD_CONDITIONAL([gr-audio-jack],[
-       AC_SUBST(JACK_LIBS)
+    GRC_BUILD_CONDITIONAL(gr-audio-jack,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_jack], [chmod +x gr-audio-jack/src/run_tests])
     ])
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_jack], [chmod +x gr-audio-jack/src/run_tests])
     ])