ao-tools: Add ao-usbtrng to dump RNG data for testing
[fw/altos] / ao-tools / ao-usbtrng / Makefile.am
diff --git a/ao-tools/ao-usbtrng/Makefile.am b/ao-tools/ao-usbtrng/Makefile.am
new file mode 100644 (file)
index 0000000..5cbab5c
--- /dev/null
@@ -0,0 +1,11 @@
+bin_PROGRAMS=ao-usbtrng
+
+AM_CFLAGS=-I$(top_srcdir)/ao-tools/lib $(LIBUSB_CFLAGS)
+
+ao_usbtrng_DEPENDENCIES = $(top_builddir)/ao-tools/lib/libao-tools.a
+
+ao_usbtrng_LDADD=$(top_builddir)/ao-tools/lib/libao-tools.a $(LIBUSB_LIBS)
+
+ao_usbtrng_SOURCES=ao-usbtrng.c
+
+man_MANS = ao-usbtrng.1