typo fix from Bob
[fw/altos] / contrib / arch-linux / PKGBUILD-git.altos
1 # Contributor: Bob Finch <w9ya@qrpqrci.net>
2 pkgname=altos-git
3 pkgver=20100507
4 pkgrel=1
5 pkgdesc="Software solutions for high powered rocketry avionics"
6 arch=('i686' 'x86_64')
7 url="http://www.altusmetrum.org/AltOS/"
8 license=('GPL')
9 depends=('openssl>=1.0.0' 'libusb-BETA' 'plplot-svn' 'sdcc' 'nickle' 'flite' 'kernel26>=2.6.33')
10 makedepends=('git')
11 optdepends=('uucp: cu is included and is a bare boned terminal to serial program'
12             'cutemon: gui-based minimal terminal to serial program'
13             'google-earth: useful for viewing the kml files of the flight path'
14             'docbook-xsl: for making an html doc file from the xsl source'
15             'fop: for making a pdf doc file from the xsl source')
16
17 _gitroot="git://git.gag.com/fw/altos"
18 _gitname="altos"
19
20 build() {
21   cd "$srcdir"
22 #  msg "Connecting to GIT server...."
23
24   if [ -d $_gitname ] ; then
25     cd $_gitname && git pull origin
26 #    msg "The local files are updated."
27   else
28     git clone $_gitroot
29   fi
30
31 #  msg "GIT checkout done or server timeout"
32 #  msg "Starting make..."
33
34   rm -rf "$srcdir/$_gitname-build"
35   git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
36   cd "$srcdir/$_gitname-build"
37
38   #
39   # BUILD HERE
40   #
41
42   ./autogen.sh
43   ./configure --prefix=/usr
44   make || return 1
45   make DESTDIR="$pkgdir/" install
46   
47   mkdir -p $startdir/pkg/usr/share/pixmaps
48   mkdir -p $startdir/pkg/usr/share/applications
49   install -m644 debian/*.xpm $startdir/pkg/usr/share/pixmaps
50   install -m644 debian/*.desktop $startdir/pkg/usr/share/applications
51   
52   #
53   # OPTIONAL DOC BUILD - *** UNCOMMENT TO INSTALL DOCUMENTATION
54   #
55   
56 #  xsltproc -o telemetrum.html /usr/share/xml/docbook/xsl-stylesheets-1.74.0/html/docbook.xsl\
57 #       doc/telemetrum.xml
58 #  xsltproc -o telemetrum.fo /usr/share/xml/docbook/xsl-stylesheets-1.74.0/fo/docbook.xsl\
59 #       doc/telemetrum.xml
60 #  fop -fo telemetrum.fo -pdf telemetrum.pdf
61 #  
62 #  mkdir -p $startdir/pkg/usr/share/altos/doc
63 #  install -m 644 *.html $startdir/pkg/usr/share/altos/doc/
64 #  install -m 644 *.pdf $startdir/pkg/usr/share/altos/doc/
65