patch from Mathieu Trudel-Lapierre that resolves problems building in
authorBdale Garbee <bdale@gag.com>
Tue, 15 Nov 2011 21:30:34 +0000 (14:30 -0700)
committerBdale Garbee <bdale@gag.com>
Tue, 15 Nov 2011 21:30:34 +0000 (14:30 -0700)
restricted chroot environments where Makefile's use of ../.. breaks

debian/changelog
debian/rules

index 1ea2d66f172333388b8542698ccb281096af8e0d..54789a4452f86a97a22f61cc8ceb9fecb79cf8b0 100644 (file)
@@ -1,3 +1,9 @@
+uapevent (1.4-2) UNRELEASED; urgency=low
+
+  * avoid errant use of ../.. by overriding dh_auto_build, closes: #648852
+
+ -- Bdale Garbee <bdale@gag.com>  Tue, 15 Nov 2011 14:30:11 -0700
+
 uapevent (1.4-1) unstable; urgency=low
 
   * Initial packaging
index b760bee7f4c367c013d228df52f8332ae6744cf2..6caad82e311a58f138339e612629f01600834296 100755 (executable)
@@ -9,5 +9,8 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+override_dh_auto_build:
+       INSTALLDIR=$(CURDIR)/debian/tmp dh_auto_build
+
 %:
        dh $@