Import upstream version 1.28
[debian/tar] / src / Makefile.in
index 0217d4611ebaec4c49849a28eac0b4e1fd68abab..6f9a59208e02ba8129716b64b34e7bae3fe8f766 100644 (file)
@@ -16,7 +16,7 @@
 
 # Makefile for GNU tar sources.
 
-# Copyright 1994-1997, 1999-2001, 2003, 2006-2007, 2009, 2013 Free
+# Copyright 1994-1997, 1999-2001, 2003, 2006-2007, 2009, 2013-2014 Free
 # Software Foundation, Inc.
 
 # This file is part of GNU tar.
@@ -99,15 +99,16 @@ POST_UNINSTALL = :
 build_triplet = @build@
 host_triplet = @host@
 bin_PROGRAMS = tar$(EXEEXT)
+@TAR_LIB_ATTR_TRUE@am__append_1 = -lattr
 subdir = src
 DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
        $(top_srcdir)/build-aux/depcomp $(noinst_HEADERS)
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
 am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
-       $(top_srcdir)/m4/acl.m4 $(top_srcdir)/m4/alloca.m4 \
-       $(top_srcdir)/m4/argp.m4 $(top_srcdir)/m4/backupfile.m4 \
-       $(top_srcdir)/m4/bison.m4 $(top_srcdir)/m4/btowc.m4 \
-       $(top_srcdir)/m4/canonicalize.m4 \
+       $(top_srcdir)/m4/absolute-header.m4 $(top_srcdir)/m4/acl.m4 \
+       $(top_srcdir)/m4/alloca.m4 $(top_srcdir)/m4/argp.m4 \
+       $(top_srcdir)/m4/backupfile.m4 $(top_srcdir)/m4/bison.m4 \
+       $(top_srcdir)/m4/btowc.m4 $(top_srcdir)/m4/canonicalize.m4 \
        $(top_srcdir)/m4/chdir-long.m4 $(top_srcdir)/m4/chown.m4 \
        $(top_srcdir)/m4/clock_time.m4 \
        $(top_srcdir)/m4/close-stream.m4 $(top_srcdir)/m4/close.m4 \
@@ -119,9 +120,10 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
        $(top_srcdir)/m4/double-slash-root.m4 $(top_srcdir)/m4/dup.m4 \
        $(top_srcdir)/m4/dup2.m4 $(top_srcdir)/m4/eealloc.m4 \
        $(top_srcdir)/m4/environ.m4 $(top_srcdir)/m4/errno_h.m4 \
-       $(top_srcdir)/m4/error.m4 $(top_srcdir)/m4/exponentd.m4 \
-       $(top_srcdir)/m4/extensions.m4 \
-       $(top_srcdir)/m4/extern-inline.m4 $(top_srcdir)/m4/fchdir.m4 \
+       $(top_srcdir)/m4/error.m4 $(top_srcdir)/m4/euidaccess.m4 \
+       $(top_srcdir)/m4/exponentd.m4 $(top_srcdir)/m4/extensions.m4 \
+       $(top_srcdir)/m4/extern-inline.m4 \
+       $(top_srcdir)/m4/faccessat.m4 $(top_srcdir)/m4/fchdir.m4 \
        $(top_srcdir)/m4/fchmodat.m4 $(top_srcdir)/m4/fchownat.m4 \
        $(top_srcdir)/m4/fcntl-o.m4 $(top_srcdir)/m4/fcntl.m4 \
        $(top_srcdir)/m4/fcntl_h.m4 $(top_srcdir)/m4/fdopendir.m4 \
@@ -133,19 +135,21 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
        $(top_srcdir)/m4/getcwd-abort-bug.m4 \
        $(top_srcdir)/m4/getcwd-path-max.m4 $(top_srcdir)/m4/getcwd.m4 \
        $(top_srcdir)/m4/getdelim.m4 $(top_srcdir)/m4/getdtablesize.m4 \
-       $(top_srcdir)/m4/getline.m4 $(top_srcdir)/m4/getopt.m4 \
-       $(top_srcdir)/m4/getpagesize.m4 $(top_srcdir)/m4/gettext.m4 \
-       $(top_srcdir)/m4/gettime.m4 $(top_srcdir)/m4/gettimeofday.m4 \
-       $(top_srcdir)/m4/glibc21.m4 $(top_srcdir)/m4/gnulib-common.m4 \
-       $(top_srcdir)/m4/gnulib-comp.m4 $(top_srcdir)/m4/human.m4 \
+       $(top_srcdir)/m4/getgroups.m4 $(top_srcdir)/m4/getline.m4 \
+       $(top_srcdir)/m4/getopt.m4 $(top_srcdir)/m4/getpagesize.m4 \
+       $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/gettime.m4 \
+       $(top_srcdir)/m4/gettimeofday.m4 $(top_srcdir)/m4/glibc21.m4 \
+       $(top_srcdir)/m4/gnulib-common.m4 \
+       $(top_srcdir)/m4/gnulib-comp.m4 \
+       $(top_srcdir)/m4/group-member.m4 $(top_srcdir)/m4/human.m4 \
        $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/include_next.m4 \
        $(top_srcdir)/m4/intlmacosx.m4 $(top_srcdir)/m4/intmax_t.m4 \
        $(top_srcdir)/m4/inttostr.m4 $(top_srcdir)/m4/inttypes-pri.m4 \
        $(top_srcdir)/m4/inttypes.m4 $(top_srcdir)/m4/inttypes_h.m4 \
-       $(top_srcdir)/m4/iswblank.m4 $(top_srcdir)/m4/langinfo_h.m4 \
-       $(top_srcdir)/m4/largefile.m4 $(top_srcdir)/m4/lchown.m4 \
-       $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
-       $(top_srcdir)/m4/lib-prefix.m4 \
+       $(top_srcdir)/m4/isatty.m4 $(top_srcdir)/m4/iswblank.m4 \
+       $(top_srcdir)/m4/langinfo_h.m4 $(top_srcdir)/m4/largefile.m4 \
+       $(top_srcdir)/m4/lchown.m4 $(top_srcdir)/m4/lib-ld.m4 \
+       $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
        $(top_srcdir)/m4/libunistring-base.m4 \
        $(top_srcdir)/m4/link-follow.m4 $(top_srcdir)/m4/link.m4 \
        $(top_srcdir)/m4/linkat.m4 $(top_srcdir)/m4/localcharset.m4 \
@@ -171,19 +175,21 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
        $(top_srcdir)/m4/open.m4 $(top_srcdir)/m4/openat.m4 \
        $(top_srcdir)/m4/opendir.m4 $(top_srcdir)/m4/parse-datetime.m4 \
        $(top_srcdir)/m4/pathmax.m4 $(top_srcdir)/m4/paxutils.m4 \
-       $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/printf.m4 \
-       $(top_srcdir)/m4/priv-set.m4 $(top_srcdir)/m4/progtest.m4 \
-       $(top_srcdir)/m4/quote.m4 $(top_srcdir)/m4/quotearg.m4 \
-       $(top_srcdir)/m4/raise.m4 $(top_srcdir)/m4/rawmemchr.m4 \
-       $(top_srcdir)/m4/read.m4 $(top_srcdir)/m4/readdir.m4 \
-       $(top_srcdir)/m4/readlink.m4 $(top_srcdir)/m4/readlinkat.m4 \
-       $(top_srcdir)/m4/realloc.m4 $(top_srcdir)/m4/regex.m4 \
-       $(top_srcdir)/m4/rename.m4 $(top_srcdir)/m4/renameat.m4 \
-       $(top_srcdir)/m4/rewinddir.m4 $(top_srcdir)/m4/rmdir.m4 \
-       $(top_srcdir)/m4/rmt.m4 $(top_srcdir)/m4/rpmatch.m4 \
-       $(top_srcdir)/m4/rtapelib.m4 $(top_srcdir)/m4/safe-read.m4 \
-       $(top_srcdir)/m4/safe-write.m4 $(top_srcdir)/m4/save-cwd.m4 \
-       $(top_srcdir)/m4/savedir.m4 $(top_srcdir)/m4/secure_getenv.m4 \
+       $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/posix_openpt.m4 \
+       $(top_srcdir)/m4/printf.m4 $(top_srcdir)/m4/priv-set.m4 \
+       $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/ptsname.m4 \
+       $(top_srcdir)/m4/ptsname_r.m4 $(top_srcdir)/m4/quote.m4 \
+       $(top_srcdir)/m4/quotearg.m4 $(top_srcdir)/m4/raise.m4 \
+       $(top_srcdir)/m4/rawmemchr.m4 $(top_srcdir)/m4/read.m4 \
+       $(top_srcdir)/m4/readdir.m4 $(top_srcdir)/m4/readlink.m4 \
+       $(top_srcdir)/m4/readlinkat.m4 $(top_srcdir)/m4/realloc.m4 \
+       $(top_srcdir)/m4/regex.m4 $(top_srcdir)/m4/rename.m4 \
+       $(top_srcdir)/m4/renameat.m4 $(top_srcdir)/m4/rewinddir.m4 \
+       $(top_srcdir)/m4/rmdir.m4 $(top_srcdir)/m4/rmt.m4 \
+       $(top_srcdir)/m4/rpmatch.m4 $(top_srcdir)/m4/rtapelib.m4 \
+       $(top_srcdir)/m4/safe-read.m4 $(top_srcdir)/m4/safe-write.m4 \
+       $(top_srcdir)/m4/save-cwd.m4 $(top_srcdir)/m4/savedir.m4 \
+       $(top_srcdir)/m4/secure_getenv.m4 \
        $(top_srcdir)/m4/selinux-context-h.m4 \
        $(top_srcdir)/m4/selinux-selinux-h.m4 \
        $(top_srcdir)/m4/setenv.m4 $(top_srcdir)/m4/signal_h.m4 \
@@ -196,20 +202,23 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/00gnulib.m4 \
        $(top_srcdir)/m4/stdio_h.m4 $(top_srcdir)/m4/stdlib_h.m4 \
        $(top_srcdir)/m4/stpcpy.m4 $(top_srcdir)/m4/strcase.m4 \
        $(top_srcdir)/m4/strchrnul.m4 $(top_srcdir)/m4/strdup.m4 \
-       $(top_srcdir)/m4/strerror.m4 $(top_srcdir)/m4/string_h.m4 \
-       $(top_srcdir)/m4/strings_h.m4 $(top_srcdir)/m4/strndup.m4 \
-       $(top_srcdir)/m4/strnlen.m4 $(top_srcdir)/m4/strtol.m4 \
-       $(top_srcdir)/m4/strtoul.m4 $(top_srcdir)/m4/strtoull.m4 \
-       $(top_srcdir)/m4/strtoumax.m4 $(top_srcdir)/m4/symlink.m4 \
-       $(top_srcdir)/m4/symlinkat.m4 $(top_srcdir)/m4/sys_socket_h.m4 \
+       $(top_srcdir)/m4/strerror.m4 $(top_srcdir)/m4/strftime.m4 \
+       $(top_srcdir)/m4/string_h.m4 $(top_srcdir)/m4/strings_h.m4 \
+       $(top_srcdir)/m4/strndup.m4 $(top_srcdir)/m4/strnlen.m4 \
+       $(top_srcdir)/m4/strtoimax.m4 $(top_srcdir)/m4/strtol.m4 \
+       $(top_srcdir)/m4/strtoll.m4 $(top_srcdir)/m4/strtoul.m4 \
+       $(top_srcdir)/m4/strtoull.m4 $(top_srcdir)/m4/strtoumax.m4 \
+       $(top_srcdir)/m4/symlink.m4 $(top_srcdir)/m4/symlinkat.m4 \
+       $(top_srcdir)/m4/sys_socket_h.m4 \
        $(top_srcdir)/m4/sys_stat_h.m4 $(top_srcdir)/m4/sys_time_h.m4 \
        $(top_srcdir)/m4/sys_types_h.m4 $(top_srcdir)/m4/sysexits.m4 \
        $(top_srcdir)/m4/system.m4 $(top_srcdir)/m4/tempname.m4 \
        $(top_srcdir)/m4/time_h.m4 $(top_srcdir)/m4/time_r.m4 \
        $(top_srcdir)/m4/timespec.m4 $(top_srcdir)/m4/tm_gmtoff.m4 \
-       $(top_srcdir)/m4/unistd-safer.m4 $(top_srcdir)/m4/unistd_h.m4 \
-       $(top_srcdir)/m4/unlink.m4 $(top_srcdir)/m4/unlinkat.m4 \
-       $(top_srcdir)/m4/unlinkdir.m4 $(top_srcdir)/m4/unlocked-io.m4 \
+       $(top_srcdir)/m4/ttyname_r.m4 $(top_srcdir)/m4/unistd-safer.m4 \
+       $(top_srcdir)/m4/unistd_h.m4 $(top_srcdir)/m4/unlink.m4 \
+       $(top_srcdir)/m4/unlinkat.m4 $(top_srcdir)/m4/unlinkdir.m4 \
+       $(top_srcdir)/m4/unlocked-io.m4 $(top_srcdir)/m4/unlockpt.m4 \
        $(top_srcdir)/m4/utimbuf.m4 $(top_srcdir)/m4/utimens.m4 \
        $(top_srcdir)/m4/utimensat.m4 $(top_srcdir)/m4/utimes.m4 \
        $(top_srcdir)/m4/vasnprintf.m4 $(top_srcdir)/m4/vasprintf.m4 \
@@ -233,17 +242,18 @@ am__installdirs = "$(DESTDIR)$(bindir)"
 PROGRAMS = $(bin_PROGRAMS)
 am_tar_OBJECTS = buffer.$(OBJEXT) checkpoint.$(OBJEXT) \
        compare.$(OBJEXT) create.$(OBJEXT) delete.$(OBJEXT) \
-       exit.$(OBJEXT) extract.$(OBJEXT) xheader.$(OBJEXT) \
-       incremen.$(OBJEXT) list.$(OBJEXT) misc.$(OBJEXT) \
-       names.$(OBJEXT) sparse.$(OBJEXT) suffix.$(OBJEXT) \
-       system.$(OBJEXT) tar.$(OBJEXT) transform.$(OBJEXT) \
-       unlink.$(OBJEXT) update.$(OBJEXT) utf8.$(OBJEXT) \
-       warning.$(OBJEXT) xattrs.$(OBJEXT)
+       exit.$(OBJEXT) exclist.$(OBJEXT) extract.$(OBJEXT) \
+       xheader.$(OBJEXT) incremen.$(OBJEXT) list.$(OBJEXT) \
+       misc.$(OBJEXT) names.$(OBJEXT) sparse.$(OBJEXT) \
+       suffix.$(OBJEXT) system.$(OBJEXT) tar.$(OBJEXT) \
+       transform.$(OBJEXT) unlink.$(OBJEXT) update.$(OBJEXT) \
+       utf8.$(OBJEXT) warning.$(OBJEXT) xattrs.$(OBJEXT)
 tar_OBJECTS = $(am_tar_OBJECTS)
 am__DEPENDENCIES_1 =
 am__DEPENDENCIES_2 = ../lib/libtar.a ../gnu/libgnu.a \
        $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
 tar_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2) \
+       $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
        $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
 AM_V_P = $(am__v_P_@AM_V@)
 am__v_P_ = $(am__v_P_@AM_DEFAULT_V@)
@@ -868,6 +878,7 @@ LIBUNISTRING_UNITYPES_H = @LIBUNISTRING_UNITYPES_H@
 LIBUNISTRING_UNIWIDTH_H = @LIBUNISTRING_UNIWIDTH_H@
 LIB_ACL = @LIB_ACL@
 LIB_CLOCK_GETTIME = @LIB_CLOCK_GETTIME@
+LIB_EACCESS = @LIB_EACCESS@
 LIB_SELINUX = @LIB_SELINUX@
 LIB_SETSOCKOPT = @LIB_SETSOCKOPT@
 LOCALCHARSET_TESTS_ENVIRONMENT = @LOCALCHARSET_TESTS_ENVIRONMENT@
@@ -983,11 +994,13 @@ REPLACE_FUTIMENS = @REPLACE_FUTIMENS@
 REPLACE_GETCWD = @REPLACE_GETCWD@
 REPLACE_GETDELIM = @REPLACE_GETDELIM@
 REPLACE_GETDOMAINNAME = @REPLACE_GETDOMAINNAME@
+REPLACE_GETDTABLESIZE = @REPLACE_GETDTABLESIZE@
 REPLACE_GETGROUPS = @REPLACE_GETGROUPS@
 REPLACE_GETLINE = @REPLACE_GETLINE@
 REPLACE_GETLOGIN_R = @REPLACE_GETLOGIN_R@
 REPLACE_GETPAGESIZE = @REPLACE_GETPAGESIZE@
 REPLACE_GETTIMEOFDAY = @REPLACE_GETTIMEOFDAY@
+REPLACE_GMTIME = @REPLACE_GMTIME@
 REPLACE_ISATTY = @REPLACE_ISATTY@
 REPLACE_ISWBLANK = @REPLACE_ISWBLANK@
 REPLACE_ISWCNTRL = @REPLACE_ISWCNTRL@
@@ -996,6 +1009,7 @@ REPLACE_LCHOWN = @REPLACE_LCHOWN@
 REPLACE_LINK = @REPLACE_LINK@
 REPLACE_LINKAT = @REPLACE_LINKAT@
 REPLACE_LOCALECONV = @REPLACE_LOCALECONV@
+REPLACE_LOCALTIME = @REPLACE_LOCALTIME@
 REPLACE_LOCALTIME_R = @REPLACE_LOCALTIME_R@
 REPLACE_LSEEK = @REPLACE_LSEEK@
 REPLACE_LSTAT = @REPLACE_LSTAT@
@@ -1062,6 +1076,7 @@ REPLACE_STRSTR = @REPLACE_STRSTR@
 REPLACE_STRTOD = @REPLACE_STRTOD@
 REPLACE_STRTOIMAX = @REPLACE_STRTOIMAX@
 REPLACE_STRTOK_R = @REPLACE_STRTOK_R@
+REPLACE_STRTOUMAX = @REPLACE_STRTOUMAX@
 REPLACE_STRUCT_LCONV = @REPLACE_STRUCT_LCONV@
 REPLACE_STRUCT_TIMEVAL = @REPLACE_STRUCT_TIMEVAL@
 REPLACE_SYMLINK = @REPLACE_SYMLINK@
@@ -1089,6 +1104,7 @@ REPLACE_WCTOMB = @REPLACE_WCTOMB@
 REPLACE_WCWIDTH = @REPLACE_WCWIDTH@
 REPLACE_WRITE = @REPLACE_WRITE@
 RSH = @RSH@
+SED = @SED@
 SELINUX_CONTEXT_H = @SELINUX_CONTEXT_H@
 SET_MAKE = @SET_MAKE@
 SHELL = @SHELL@
@@ -1126,6 +1142,7 @@ abs_builddir = @abs_builddir@
 abs_srcdir = @abs_srcdir@
 abs_top_builddir = @abs_top_builddir@
 abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
 ac_ct_CC = @ac_ct_CC@
 am__include = @am__include@
 am__leading_dot = @am__leading_dot@
@@ -1170,6 +1187,7 @@ pdfdir = @pdfdir@
 prefix = @prefix@
 program_transform_name = @program_transform_name@
 psdir = @psdir@
+runstatedir = @runstatedir@
 sbindir = @sbindir@
 sharedstatedir = @sharedstatedir@
 srcdir = @srcdir@
@@ -1186,6 +1204,7 @@ tar_SOURCES = \
  create.c\
  delete.c\
  exit.c\
+ exclist.c\
  extract.c\
  xheader.c\
  incremen.c\
@@ -1206,7 +1225,8 @@ tar_SOURCES = \
 AM_CPPFLAGS = -I$(top_srcdir)/gnu -I../ -I../gnu -I$(top_srcdir)/lib -I../lib
 AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
 LDADD = ../lib/libtar.a ../gnu/libgnu.a $(LIBINTL) $(LIBICONV)
-tar_LDADD = $(LIBS) $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS) $(LIB_SELINUX)
+tar_LDADD = $(LIBS) $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS) \
+       $(LIB_SELINUX) $(am__append_1)
 all: all-am
 
 .SUFFIXES:
@@ -1315,6 +1335,7 @@ distclean-compile:
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compare.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/create.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/delete.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/exclist.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/exit.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/extract.Po@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/incremen.Po@am__quote@