lintian cleanups
authorBdale Garbee <bdale@gag.com>
Sun, 12 Jan 2014 21:19:31 +0000 (14:19 -0700)
committerBdale Garbee <bdale@gag.com>
Sun, 12 Jan 2014 21:19:31 +0000 (14:19 -0700)
debian/control
debian/rules

index dfa8db39bf62a348a39c9c7c9a082f9f66c2ad93..dbd275fa47c8fb6684f88cc5228b6f4408974238 100644 (file)
@@ -2,14 +2,14 @@ Source: pforth
 Section: interpreters
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper (>= 4)
+Build-Depends: debhelper (>= 9)
 Standards-Version: 3.9.5
 Vcs-Git: git://git.gag.com/debian/pforth
 Vcs-Browser: http://git.gag.com/?p=debian/pforth
 
 Package: pforth
 Architecture: arm armeb armel armhf i386 m68k powerpc powerpcspe s390 sparc hurd-i386 hppa kfreebsd-i386
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Description: portable Forth interpreter
  pForth is a public domain, portable ANS Forth based on a kernel written in
  ANSI 'C'.  This makes it easy to port pForth to multiple platforms.
index 25cd8e2a9d6345378ad80368d467f0d4c9955f0c..4b1cba7a1e8d0154e123f9fd992df1b141d35cd8 100755 (executable)
@@ -2,7 +2,14 @@
 
 export DH_VERBOSE=1
 
-build: build-stamp
+CFLAGS = `dpkg-buildflags --get CFLAGS`
+CFLAGS += -Wall
+LDFLAGS += `dpkg-buildflags --get LDFLAGS`
+CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
+
+build:         build-arch build-indep
+build-arch:    build-stamp
+build-indep:   build-stamp
 build-stamp:
        dh_testdir
        mkdir objects
@@ -13,7 +20,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp install-stamp
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
        rm -fr objects
        dh_clean
 
@@ -21,7 +28,7 @@ install: install-stamp
 install-stamp: build-stamp
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        install -m0755 pforth `pwd`/debian/pforth/usr/bin/pforth