move to dh
authorBdale Garbee <bdale@gag.com>
Fri, 29 Jun 2012 13:51:13 +0000 (07:51 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 29 Jun 2012 13:51:13 +0000 (07:51 -0600)
debian/compat
debian/control
debian/ipip.examples [new file with mode: 0644]
debian/ipip.install [new file with mode: 0644]
debian/ipip.manpages [new file with mode: 0644]
debian/rules

index 7ed6ff82de6bcc2a78243fc9c54d3ef5ac14da69..45a4fb75db864000d01701c0f7a51864bd4daabf 100644 (file)
@@ -1 +1 @@
-5
+8
index 98c62db920e26dfbed45dc0323b5f2f1b301f141..3c9742c1d150dad0478506c56814bfe0f1856628 100644 (file)
@@ -2,7 +2,7 @@ Source: ipip
 Section: net
 Priority: extra
 Maintainer: Bdale Garbee <bdale@gag.com>
-Build-Depends: debhelper
+Build-Depends: debhelper (>= 8)
 Standards-Version: 3.9.3
 Vcs-Git: git://git.gag.com/debian/ipip
 Vcs-Browser: http://git.gag.com/?p=debian/ipip
diff --git a/debian/ipip.examples b/debian/ipip.examples
new file mode 100644 (file)
index 0000000..781fb73
--- /dev/null
@@ -0,0 +1 @@
+samples/*
diff --git a/debian/ipip.install b/debian/ipip.install
new file mode 100644 (file)
index 0000000..b46b936
--- /dev/null
@@ -0,0 +1,3 @@
+ipip   usr/sbin
+debian/ipip.config     etc/ipip/config
+debian/ipip.routes     etc/ipip/routes
diff --git a/debian/ipip.manpages b/debian/ipip.manpages
new file mode 100644 (file)
index 0000000..67206dc
--- /dev/null
@@ -0,0 +1 @@
+ipip.1
index 5b1a8613b34dfdf0aca32f8335a7587aec4c70bf..f88c186bc0b120f1aee3674d5f6fd2838bef39ad 100755 (executable)
@@ -1,61 +1,15 @@
 #!/usr/bin/make -f
-# rules file for the ipip package, requires debhelper
-# copyright 1998 by Bdale Garbee, distributed under the terms of the GPL
+# rules file for the ipip package, requires debhelper / dh
+# copyright 1998,2012 by Bdale Garbee, GPLv2 or later
 
 # export DH_VERBOSE=1
 
-CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
-CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
-CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
-LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+%:
+       dh $@
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
+#      cp ipip debian/ipip/usr/sbin
+#      cp debian/ipip.config debian/ipip/etc/ipip/config
+#      cp debian/ipip.routes debian/ipip/etc/ipip/routes
 
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       $(MAKE) clean
-       dh_clean
-
-# Build architecture-independent files here.
-binary-indep: build
-
-# Build architecture-dependent files here.
-binary-arch: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       cp ipip debian/ipip/usr/sbin
-       cp debian/ipip.config debian/ipip/etc/ipip/config
-       cp debian/ipip.routes debian/ipip/etc/ipip/routes
-
-       dh_installdocs
-       dh_installexamples samples/*
-       dh_installmenu
-       dh_installinit
-       dh_installcron
-       dh_installman ipip.1
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+#      dh_installexamples samples/*
+#      dh_installman ipip.1