Imported Upstream version 3.0.3
[debian/gnuradio] / usrp / firmware / src / usrp2 / Makefile.in
index 3c1b05192acd6b7a2cac5f93c4d5a80f365da3a1..e3153372415572d0c3be03e6b144340546fc3801 100644 (file)
@@ -621,21 +621,21 @@ uninstall-am: uninstall-firmware2DATA uninstall-firmware4DATA \
                -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
 
 .a51.rel:
-       test -f `basename '$<'` || ln -s '$<' .
+       test -f `basename '$<'` || $(LN_S) '$<' .
        test -f ../common/`basename '$<'` -o \
                \! -f `dirname '$<'`/../common/`basename '$<'` \
-               || ln -s `dirname '$<'`/../common/`basename '$<'` ../common/.
+               || $(LN_S) `dirname '$<'`/../common/`basename '$<'` ../common/`basename '$<'`
        $(XAS) `basename '$<'`
 
 eeprom_boot.ihx: $(EEPROM_BOOT_OBJS) $(LIBDEP)
        $(XCC) $(LINKOPTS) -o $@ $(EEPROM_BOOT_OBJS)
 
 burn-usrp2-eeprom: eeprom_boot.ihx
-       $(srcdir)/../common/build_eeprom.py -r2 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r2 eeprom_boot.ihx > $@
        chmod +x $@
 
 burn-usrp4-eeprom: eeprom_boot.ihx
-       $(srcdir)/../common/build_eeprom.py -r4 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r4 eeprom_boot.ihx > $@
        chmod +x $@
 
 blink_leds.ihx: $(BLINK_LEDS_OBJS) $(LIBDEP)
@@ -655,7 +655,7 @@ std.ihx: $(USRP_OBJS) $(LIBDEP)
 all: usrp_gpif.c
 
 usrp_gpif.c usrp_gpif_inline.h : gpif.c
-       srcdir=$(srcdir) $(srcdir)/edit-gpif $(srcdir)/gpif.c usrp_gpif.c usrp_gpif_inline.h
+       srcdir=$(srcdir) $(PYTHON) $(srcdir)/edit-gpif $(srcdir)/gpif.c usrp_gpif.c usrp_gpif_inline.h
 
 # dependencies