Imported Upstream version 3.0.3
[debian/gnuradio] / usrp / firmware / src / usrp2 / Makefile.am
index 423404a4a4c573b6c0fb40b42c3c23a1eb245764..de7164b4b0ede181e5bb36458c975060771c9d92 100644 (file)
@@ -95,10 +95,10 @@ noinst_SCRIPTS =            \
                -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
 
 .a51.rel:
-       test -f `basename '$<'` || ln -s '$<' .
+       test -f `basename '$<'` || $(LN_S) '$<' .
        test -f ../common/`basename '$<'` -o \
                \! -f `dirname '$<'`/../common/`basename '$<'` \
-               || ln -s `dirname '$<'`/../common/`basename '$<'` ../common/.
+               || $(LN_S) `dirname '$<'`/../common/`basename '$<'` ../common/`basename '$<'`
        $(XAS) `basename '$<'`
 
 
@@ -108,11 +108,11 @@ eeprom_boot.ihx: $(EEPROM_BOOT_OBJS) $(LIBDEP)
        $(XCC) $(LINKOPTS) -o $@ $(EEPROM_BOOT_OBJS)
 
 burn-usrp2-eeprom: eeprom_boot.ihx
-       $(srcdir)/../common/build_eeprom.py -r2 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r2 eeprom_boot.ihx > $@
        chmod +x $@
 
 burn-usrp4-eeprom: eeprom_boot.ihx
-       $(srcdir)/../common/build_eeprom.py -r4 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r4 eeprom_boot.ihx > $@
        chmod +x $@
 
 
@@ -159,7 +159,7 @@ DISTCLEANFILES =    \
 all: usrp_gpif.c
 
 usrp_gpif.c usrp_gpif_inline.h : gpif.c
-       srcdir=$(srcdir) $(srcdir)/edit-gpif $(srcdir)/gpif.c usrp_gpif.c usrp_gpif_inline.h
+       srcdir=$(srcdir) $(PYTHON) $(srcdir)/edit-gpif $(srcdir)/gpif.c usrp_gpif.c usrp_gpif_inline.h
 
 
 # dependencies