Imported Debian patch 3.0.3-1
[debian/gnuradio] / usrp / doc / Makefile.in
index 56c6938453c9274cfd530e59ecdf6a8e97b01b8c..21192b41e0e5b3eab52e281474c9bcc14fd5e8a2 100644 (file)
@@ -37,7 +37,7 @@
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -307,7 +307,7 @@ build_os = @build_os@
 build_vendor = @build_vendor@
 datadir = @datadir@
 datarootdir = @datarootdir@
-docdir = $(prefix)/share/doc/@PACKAGE@-@VERSION@
+docdir = $(prefix)/share/doc/@PACKAGE@-@VERSION@/usrp
 dvidir = @dvidir@
 enable_dot = @enable_dot@
 enable_html_docs = @enable_html_docs@
@@ -379,25 +379,17 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    $(FFTW3F_CFLAGS)
 
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 
 # This is a dependency for many swig operations
 GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
+# How to link in the USRP library from inside the tree
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
-
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
@@ -742,7 +734,7 @@ html/index.html:
 docbook-html: usrp_guide.html
 
 usrp_guide.html: usrp_guide.xml
-       xmlto html-nochunks $<
+       xmlto html-nochunks $(top_srcdir)/usrp/doc/usrp_guide.xml
 
 install-data-local:
        $(mkinstalldirs) $(DESTDIR)$(docdir)