changes from running bootstrap and then make maintainer-clean
[debian/gnuradio] / gruel / src / lib / Makefile.in
index 76c200a9b037473a110973ff250d1a5df31ed556..84b2bd3c21849d11feba66ff6fefc56e9f425b71 100644 (file)
@@ -16,7 +16,7 @@
 @SET_MAKE@
 
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -38,7 +38,7 @@
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2007,2008,2009 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -79,8 +79,10 @@ POST_UNINSTALL = :
 build_triplet = @build@
 host_triplet = @host@
 target_triplet = @target@
-DIST_COMMON = $(noinst_HEADERS) $(srcdir)/Makefile.am \
-       $(srcdir)/Makefile.in $(top_srcdir)/Makefile.common
+DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
+       $(top_srcdir)/Makefile.common
+TESTS = test_gruel$(EXEEXT)
+noinst_PROGRAMS = test_gruel$(EXEEXT)
 subdir = gruel/src/lib
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
 am__aclocal_m4_deps = $(top_srcdir)/config/acx_cblas.m4 \
@@ -94,36 +96,39 @@ am__aclocal_m4_deps = $(top_srcdir)/config/acx_cblas.m4 \
        $(top_srcdir)/config/gr_check_memalign.m4 \
        $(top_srcdir)/config/gr_check_shm_open.m4 \
        $(top_srcdir)/config/gr_doxygen.m4 \
-       $(top_srcdir)/config/gr_fortran.m4 \
+       $(top_srcdir)/config/gr_git.m4 \
        $(top_srcdir)/config/gr_gprof.m4 \
        $(top_srcdir)/config/gr_lib64.m4 \
        $(top_srcdir)/config/gr_libgnuradio_core_extra_ldflags.m4 \
        $(top_srcdir)/config/gr_no_undefined.m4 \
-       $(top_srcdir)/config/gr_omnithread.m4 \
        $(top_srcdir)/config/gr_pwin32.m4 \
        $(top_srcdir)/config/gr_python.m4 \
        $(top_srcdir)/config/gr_qwt.m4 \
        $(top_srcdir)/config/gr_qwtplot3d.m4 \
        $(top_srcdir)/config/gr_scripting.m4 \
        $(top_srcdir)/config/gr_set_md_cpu.m4 \
-       $(top_srcdir)/config/gr_subversion.m4 \
        $(top_srcdir)/config/gr_swig.m4 \
        $(top_srcdir)/config/gr_sysv_shm.m4 \
+       $(top_srcdir)/config/gr_version.m4 \
        $(top_srcdir)/config/grc_build.m4 \
        $(top_srcdir)/config/grc_docs.m4 \
        $(top_srcdir)/config/grc_gcell.m4 \
        $(top_srcdir)/config/grc_gnuradio_core.m4 \
        $(top_srcdir)/config/grc_gnuradio_examples.m4 \
+       $(top_srcdir)/config/grc_gr_atsc.m4 \
        $(top_srcdir)/config/grc_gr_audio_alsa.m4 \
        $(top_srcdir)/config/grc_gr_audio_jack.m4 \
        $(top_srcdir)/config/grc_gr_audio_oss.m4 \
        $(top_srcdir)/config/grc_gr_audio_osx.m4 \
        $(top_srcdir)/config/grc_gr_audio_portaudio.m4 \
        $(top_srcdir)/config/grc_gr_audio_windows.m4 \
+       $(top_srcdir)/config/grc_gr_comedi.m4 \
        $(top_srcdir)/config/grc_gr_cvsd_vocoder.m4 \
        $(top_srcdir)/config/grc_gr_gcell.m4 \
        $(top_srcdir)/config/grc_gr_gpio.m4 \
        $(top_srcdir)/config/grc_gr_gsm_fr_vocoder.m4 \
+       $(top_srcdir)/config/grc_gr_msdd6000.m4 \
+       $(top_srcdir)/config/grc_gr_noaa.m4 \
        $(top_srcdir)/config/grc_gr_pager.m4 \
        $(top_srcdir)/config/grc_gr_qtgui.m4 \
        $(top_srcdir)/config/grc_gr_radar_mono.m4 \
@@ -137,9 +142,6 @@ am__aclocal_m4_deps = $(top_srcdir)/config/acx_cblas.m4 \
        $(top_srcdir)/config/grc_gr_wxgui.m4 \
        $(top_srcdir)/config/grc_grc.m4 \
        $(top_srcdir)/config/grc_gruel.m4 \
-       $(top_srcdir)/config/grc_mblock.m4 \
-       $(top_srcdir)/config/grc_omnithread.m4 \
-       $(top_srcdir)/config/grc_pmt.m4 \
        $(top_srcdir)/config/grc_usrp.m4 \
        $(top_srcdir)/config/grc_usrp2.m4 \
        $(top_srcdir)/config/lf_cc.m4 $(top_srcdir)/config/lf_cxx.m4 \
@@ -186,13 +188,17 @@ am__base_list = \
 am__installdirs = "$(DESTDIR)$(libdir)"
 LTLIBRARIES = $(lib_LTLIBRARIES)
 am__DEPENDENCIES_1 =
-libgruel_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
-am_libgruel_la_OBJECTS = realtime.lo sys_pri.lo thread_body_wrapper.lo \
-       thread_group.lo
+libgruel_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(PMT_LIB) $(MSG_LIB)
+am_libgruel_la_OBJECTS = realtime.lo sys_pri.lo thread.lo \
+       thread_body_wrapper.lo thread_group.lo
 libgruel_la_OBJECTS = $(am_libgruel_la_OBJECTS)
 libgruel_la_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) \
        $(LIBTOOLFLAGS) --mode=link $(CXXLD) $(AM_CXXFLAGS) \
        $(CXXFLAGS) $(libgruel_la_LDFLAGS) $(LDFLAGS) -o $@
+PROGRAMS = $(noinst_PROGRAMS)
+am_test_gruel_OBJECTS = test_gruel.$(OBJEXT)
+test_gruel_OBJECTS = $(am_test_gruel_OBJECTS)
+test_gruel_DEPENDENCIES = pmt/libpmt-qa.la libgruel.la
 DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
 depcomp = $(SHELL) $(top_srcdir)/depcomp
 am__depfiles_maybe = depfiles
@@ -206,12 +212,51 @@ CXXLD = $(CXX)
 CXXLINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
        --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
        $(LDFLAGS) -o $@
-SOURCES = $(libgruel_la_SOURCES)
-DIST_SOURCES = $(libgruel_la_SOURCES)
-HEADERS = $(noinst_HEADERS)
+SOURCES = $(libgruel_la_SOURCES) $(test_gruel_SOURCES)
+DIST_SOURCES = $(libgruel_la_SOURCES) $(test_gruel_SOURCES)
+RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
+       html-recursive info-recursive install-data-recursive \
+       install-dvi-recursive install-exec-recursive \
+       install-html-recursive install-info-recursive \
+       install-pdf-recursive install-ps-recursive install-recursive \
+       installcheck-recursive installdirs-recursive pdf-recursive \
+       ps-recursive uninstall-recursive
+RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive        \
+  distclean-recursive maintainer-clean-recursive
+AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
+       $(RECURSIVE_CLEAN_TARGETS:-recursive=) tags TAGS ctags CTAGS \
+       distdir
 ETAGS = etags
 CTAGS = ctags
+am__tty_colors = \
+red=; grn=; lgn=; blu=; std=
+DIST_SUBDIRS = $(SUBDIRS)
 DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+am__relativize = \
+  dir0=`pwd`; \
+  sed_first='s,^\([^/]*\)/.*$$,\1,'; \
+  sed_rest='s,^[^/]*/*,,'; \
+  sed_last='s,^.*/\([^/]*\)$$,\1,'; \
+  sed_butlast='s,/*[^/]*$$,,'; \
+  while test -n "$$dir1"; do \
+    first=`echo "$$dir1" | sed -e "$$sed_first"`; \
+    if test "$$first" != "."; then \
+      if test "$$first" = ".."; then \
+        dir2=`echo "$$dir0" | sed -e "$$sed_last"`/"$$dir2"; \
+        dir0=`echo "$$dir0" | sed -e "$$sed_butlast"`; \
+      else \
+        first2=`echo "$$dir2" | sed -e "$$sed_first"`; \
+        if test "$$first2" = "$$first"; then \
+          dir2=`echo "$$dir2" | sed -e "$$sed_rest"`; \
+        else \
+          dir2="../$$dir2"; \
+        fi; \
+        dir0="$$dir0"/"$$first"; \
+      fi; \
+    fi; \
+    dir1=`echo "$$dir1" | sed -e "$$sed_rest"`; \
+  done; \
+  reldir="$$dir2"
 ACLOCAL = @ACLOCAL@
 ALLOCA = @ALLOCA@
 ALSA_CFLAGS = @ALSA_CFLAGS@
@@ -231,6 +276,7 @@ BOOST_DATE_TIME_LIB = @BOOST_DATE_TIME_LIB@
 BOOST_LDFLAGS = @BOOST_LDFLAGS@
 BOOST_PROGRAM_OPTIONS_LIB = @BOOST_PROGRAM_OPTIONS_LIB@
 BOOST_THREAD_LIB = @BOOST_THREAD_LIB@
+BUILD_DATE = @BUILD_DATE@
 CBLAS_LIBS = @CBLAS_LIBS@
 CC = @CC@
 CCAS = @CCAS@
@@ -238,6 +284,10 @@ CCASDEPMODE = @CCASDEPMODE@
 CCASFLAGS = @CCASFLAGS@
 CCDEPMODE = @CCDEPMODE@
 CFLAGS = @CFLAGS@
+COMEDI_CFLAGS = @COMEDI_CFLAGS@
+COMEDI_CPPFLAGS = @COMEDI_CPPFLAGS@
+COMEDI_INCLUDEDIR = @COMEDI_INCLUDEDIR@
+COMEDI_LIBS = @COMEDI_LIBS@
 CPP = @CPP@
 CPPFLAGS = @CPPFLAGS@
 CPPUNIT_CFLAGS = @CPPUNIT_CFLAGS@
@@ -256,6 +306,7 @@ DEFINES = @DEFINES@
 DEFS = @DEFS@
 DEPDIR = @DEPDIR@
 DLLTOOL = @DLLTOOL@
+DOCVER = @DOCVER@
 DOT = @DOT@
 DOXYGEN = @DOXYGEN@
 DSYMUTIL = @DSYMUTIL@
@@ -265,20 +316,23 @@ ECHO_N = @ECHO_N@
 ECHO_T = @ECHO_T@
 EGREP = @EGREP@
 EXEEXT = @EXEEXT@
-F77 = @F77@
-FFLAGS = @FFLAGS@
 FFTW3F_CFLAGS = @FFTW3F_CFLAGS@
 FFTW3F_CPPFLAGS = @FFTW3F_CPPFLAGS@
 FFTW3F_INCLUDEDIR = @FFTW3F_INCLUDEDIR@
 FFTW3F_LIBS = @FFTW3F_LIBS@
 FGREP = @FGREP@
-FLIBS = @FLIBS@
 FUSB_TECH = @FUSB_TECH@
+GIT = @GIT@
+GIT_COMMIT = @GIT_COMMIT@
+GIT_DESCRIBE = @GIT_DESCRIBE@
+GIT_SEQNO = @GIT_SEQNO@
+GIT_TAG = @GIT_TAG@
 GREP = @GREP@
 GR_ARCH_BIGENDIAN = @GR_ARCH_BIGENDIAN@
 GR_HAVE_ARPA_INET = @GR_HAVE_ARPA_INET@
 GR_HAVE_BYTESWAP = @GR_HAVE_BYTESWAP@
 GR_HAVE_NETINET_IN = @GR_HAVE_NETINET_IN@
+GR_PREFSDIR = @GR_PREFSDIR@
 GSL_CFLAGS = @GSL_CFLAGS@
 GSL_CPPFLAGS = @GSL_CPPFLAGS@
 GSL_INCLUDEDIR = @GSL_INCLUDEDIR@
@@ -301,6 +355,8 @@ LIBGNURADIO_CORE_EXTRA_LDFLAGS = @LIBGNURADIO_CORE_EXTRA_LDFLAGS@
 LIBOBJS = @LIBOBJS@
 LIBS = @LIBS@
 LIBTOOL = @LIBTOOL@
+LIBUSB_PKG_CONFIG_NAME = @LIBUSB_PKG_CONFIG_NAME@
+LIBVER = @LIBVER@
 LIPO = @LIPO@
 LN_S = @LN_S@
 LTLIBOBJS = @LTLIBOBJS@
@@ -362,6 +418,7 @@ QWTPLOT3D_LIBS = @QWTPLOT3D_LIBS@
 QWT_CFLAGS = @QWT_CFLAGS@
 QWT_LIBS = @QWT_LIBS@
 RANLIB = @RANLIB@
+RELEASE = @RELEASE@
 RM_PROG = @RM_PROG@
 SDL_CFLAGS = @SDL_CFLAGS@
 SDL_CONFIG = @SDL_CONFIG@
@@ -374,17 +431,17 @@ SHELL = @SHELL@
 SHM_OPEN_LIBS = @SHM_OPEN_LIBS@
 SPU_GCC_PROG = @SPU_GCC_PROG@
 STRIP = @STRIP@
-SVN = @SVN@
-SVNDATE = @SVNDATE@
-SVNVERSION = @SVNVERSION@
 SWIG = @SWIG@
 SWIG_PYTHON_CPPFLAGS = @SWIG_PYTHON_CPPFLAGS@
 SWIG_PYTHON_LIB = @SWIG_PYTHON_LIB@
 SWIG_PYTHON_OPT = @SWIG_PYTHON_OPT@
+SYSCONFDIR = @SYSCONFDIR@
 USB_CFLAGS = @USB_CFLAGS@
 USB_CPPFLAGS = @USB_CPPFLAGS@
 USB_INCLUDEDIR = @USB_INCLUDEDIR@
+USB_INCLUDES = @USB_INCLUDES@
 USB_LIBS = @USB_LIBS@
+USE_LIBUSB1 = @USE_LIBUSB1@
 USRP2_INCLUDES = @USRP2_INCLUDES@
 USRP2_LA = @USRP2_LA@
 VERSION = @VERSION@
@@ -400,7 +457,6 @@ abs_top_srcdir = @abs_top_srcdir@
 ac_ct_CC = @ac_ct_CC@
 ac_ct_CXX = @ac_ct_CXX@
 ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
-ac_ct_F77 = @ac_ct_F77@
 acx_pthread_config = @acx_pthread_config@
 am__include = @am__include@
 am__leading_dot = @am__leading_dot@
@@ -452,6 +508,11 @@ gnuradio_examples_INCLUDES = @gnuradio_examples_INCLUDES@
 gnuradio_examples_LA = @gnuradio_examples_LA@
 gnuradio_examples_LDFLAG = @gnuradio_examples_LDFLAG@
 gnuradio_examples_LIBDIRPATH = @gnuradio_examples_LIBDIRPATH@
+gr_atsc_INCLUDEDIR = @gr_atsc_INCLUDEDIR@
+gr_atsc_INCLUDES = @gr_atsc_INCLUDES@
+gr_atsc_LA = @gr_atsc_LA@
+gr_atsc_LDFLAG = @gr_atsc_LDFLAG@
+gr_atsc_LIBDIRPATH = @gr_atsc_LIBDIRPATH@
 gr_audio_alsa_INCLUDEDIR = @gr_audio_alsa_INCLUDEDIR@
 gr_audio_alsa_INCLUDES = @gr_audio_alsa_INCLUDES@
 gr_audio_alsa_LA = @gr_audio_alsa_LA@
@@ -482,6 +543,11 @@ gr_audio_windows_INCLUDES = @gr_audio_windows_INCLUDES@
 gr_audio_windows_LA = @gr_audio_windows_LA@
 gr_audio_windows_LDFLAG = @gr_audio_windows_LDFLAG@
 gr_audio_windows_LIBDIRPATH = @gr_audio_windows_LIBDIRPATH@
+gr_comedi_INCLUDEDIR = @gr_comedi_INCLUDEDIR@
+gr_comedi_INCLUDES = @gr_comedi_INCLUDES@
+gr_comedi_LA = @gr_comedi_LA@
+gr_comedi_LDFLAG = @gr_comedi_LDFLAG@
+gr_comedi_LIBDIRPATH = @gr_comedi_LIBDIRPATH@
 gr_cvsd_vocoder_INCLUDEDIR = @gr_cvsd_vocoder_INCLUDEDIR@
 gr_cvsd_vocoder_INCLUDES = @gr_cvsd_vocoder_INCLUDES@
 gr_cvsd_vocoder_LA = @gr_cvsd_vocoder_LA@
@@ -503,6 +569,16 @@ gr_gsm_fr_vocoder_LA = @gr_gsm_fr_vocoder_LA@
 gr_gsm_fr_vocoder_LDFLAG = @gr_gsm_fr_vocoder_LDFLAG@
 gr_gsm_fr_vocoder_LIBDIRPATH = @gr_gsm_fr_vocoder_LIBDIRPATH@
 gr_libdir_suffix = @gr_libdir_suffix@
+gr_msdd6000_INCLUDEDIR = @gr_msdd6000_INCLUDEDIR@
+gr_msdd6000_INCLUDES = @gr_msdd6000_INCLUDES@
+gr_msdd6000_LA = @gr_msdd6000_LA@
+gr_msdd6000_LDFLAG = @gr_msdd6000_LDFLAG@
+gr_msdd6000_LIBDIRPATH = @gr_msdd6000_LIBDIRPATH@
+gr_noaa_INCLUDEDIR = @gr_noaa_INCLUDEDIR@
+gr_noaa_INCLUDES = @gr_noaa_INCLUDES@
+gr_noaa_LA = @gr_noaa_LA@
+gr_noaa_LDFLAG = @gr_noaa_LDFLAG@
+gr_noaa_LIBDIRPATH = @gr_noaa_LIBDIRPATH@
 gr_pager_INCLUDEDIR = @gr_pager_INCLUDEDIR@
 gr_pager_INCLUDES = @gr_pager_INCLUDES@
 gr_pager_LA = @gr_pager_LA@
@@ -585,26 +661,11 @@ localedir = @localedir@
 localstatedir = @localstatedir@
 lt_ECHO = @lt_ECHO@
 mandir = @mandir@
-mblock_INCLUDEDIR = @mblock_INCLUDEDIR@
-mblock_INCLUDES = @mblock_INCLUDES@
-mblock_LA = @mblock_LA@
-mblock_LDFLAG = @mblock_LDFLAG@
-mblock_LIBDIRPATH = @mblock_LIBDIRPATH@
 mkdir_p = @mkdir_p@
 oldincludedir = @oldincludedir@
-omnithread_INCLUDEDIR = @omnithread_INCLUDEDIR@
-omnithread_INCLUDES = @omnithread_INCLUDES@
-omnithread_LA = @omnithread_LA@
-omnithread_LDFLAG = @omnithread_LDFLAG@
-omnithread_LIBDIRPATH = @omnithread_LIBDIRPATH@
 pdfdir = @pdfdir@
 pkgpyexecdir = @pkgpyexecdir@
 pkgpythondir = @pkgpythondir@
-pmt_INCLUDEDIR = @pmt_INCLUDEDIR@
-pmt_INCLUDES = @pmt_INCLUDES@
-pmt_LA = @pmt_LA@
-pmt_LDFLAG = @pmt_LDFLAG@
-pmt_LIBDIRPATH = @pmt_LIBDIRPATH@
 prefix = @prefix@
 program_transform_name = @program_transform_name@
 psdir = @psdir@
@@ -635,7 +696,6 @@ usrp_INCLUDES = @usrp_INCLUDES@
 usrp_LA = @usrp_LA@
 usrp_LDFLAG = @usrp_LDFLAG@
 usrp_LIBDIRPATH = @usrp_LIBDIRPATH@
-usrp_darwin_omnithread_pc_requires = @usrp_darwin_omnithread_pc_requires@
 with_INCLUDES = @with_INCLUDES@
 with_LIBDIRPATH = @with_LIBDIRPATH@
 with_PYDIRPATH = @with_PYDIRPATH@
@@ -645,23 +705,26 @@ with_dirs = @with_dirs@
 AM_CFLAGS = @autoconf_default_CFLAGS@ @lf_CFLAGS@
 AM_CXXFLAGS = @autoconf_default_CXXFLAGS@ @lf_CXXFLAGS@
 
+# Sets ABI version in SONAME and appends -LIBVER to filename
+LTVERSIONFLAGS = -version-info 0:0:0 -release $(LIBVER)
+
 # includes
 grincludedir = $(includedir)/gnuradio
 
 # swig includes
-swigincludedir = $(grincludedir)/swig
+@PYTHON_TRUE@swigincludedir = $(grincludedir)/swig
 
 # Install the gnuradio stuff in the appropriate subdirectory
 # This usually ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio
-grpythondir = $(pythondir)/gnuradio
-grpyexecdir = $(pyexecdir)/gnuradio
+@PYTHON_TRUE@grpythondir = $(pythondir)/gnuradio
+@PYTHON_TRUE@grpyexecdir = $(pyexecdir)/gnuradio
 
 # Install the non-gnuradio usrp stuff in the appropriate subdirectory
 # This usually ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/usrpm
-usrppythondir = $(pythondir)/usrpm
-usrppyexecdir = $(pyexecdir)/usrpm
+@PYTHON_TRUE@usrppythondir = $(pythondir)/usrpm
+@PYTHON_TRUE@usrppyexecdir = $(pyexecdir)/usrpm
 
 # gcell includes
 gcellincludedir = $(includedir)/gcell
@@ -673,7 +736,7 @@ libspudir = $(libdir)spu
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
 STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
-       $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
+       $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
 
 
 # when including for compilation from pre-installed libraries and such,
@@ -681,10 +744,6 @@ STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
 WITH_INCLUDES = @with_INCLUDES@
 WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
 
-# How to link in the top-level omnithreads library from inside the tree
-OMNITHREAD_INCLUDES = @omnithread_INCLUDES@
-OMNITHREAD_LA = @omnithread_LA@
-
 # Where to find gnuradio include files in the current build tree
 # top_srcdir for original stuff, top_builddir for generated files
 GNURADIO_INCLUDES = @gnuradio_core_INCLUDES@
@@ -700,18 +759,6 @@ GRUEL_LA = @gruel_LA@
 USRP_INCLUDES = @usrp_INCLUDES@
 USRP_LA = @usrp_LA@
 
-# How to link in usrp-inband library from inside the tree
-USRP_INBAND_INCLUDES = @usrp_inband_INCLUDES@
-USRP_INBAND_LA = @usrp_inband_LA@
-
-# How to link the PMT library from inside the tree
-PMT_INCLUDES = @pmt_INCLUDES@
-PMT_LA = @pmt_LA@
-
-# How to link the mblock library from inside the tree
-MBLOCK_INCLUDES = @mblock_INCLUDES@
-MBLOCK_LA = @mblock_LA@
-
 # How to link the gcell library from inside the tree (the PPU part)
 GCELL_INCLUDES = @gcell_INCLUDES@
 GCELL_LA = @gcell_LA@
@@ -726,37 +773,51 @@ GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libto
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make
 RM = $(RM_PROG) -f
-RUN_GUILE = GUILE_LOAD_PATH="@abs_top_srcdir@/pmt/src/scheme:@abs_top_srcdir@/mblock/src/scheme" @GUILE@ -e main -s
-COMPILE_MBH = $(RUN_GUILE) $(top_srcdir)/mblock/src/scheme/gnuradio/compile-mbh.scm
+RUN_GUILE = GUILE_LOAD_PATH="@abs_top_srcdir@/gruel/src/scheme" @GUILE@ -e main -s
 
 # Base directory for example applications
 exampledir = $(datadir)/gnuradio/examples
-gr_docdir = $(docdir)-$(VERSION)
+gr_docdir = $(docdir)-$(DOCVER)
 
 # System configuration files
-gr_sysconfdir = $(sysconfdir)/$(PACKAGE)/conf.d
+gr_prefsdir = $(GR_PREFSDIR)
+
+# Data directory for grc block wrappers
+grc_blocksdir = $(pkgdatadir)/grc/blocks
 
 # Other common defines; use "+=" to add to these
 STAMPS = 
 MOSTLYCLEANFILES = $(BUILT_SOURCES) $(STAMPS) *.pyc *.pyo *~ *.tmp *.loT
-AM_CPPFLAGS = $(DEFINES) $(BOOST_CPPFLAGS) $(GRUEL_INCLUDES) $(WITH_INCLUDES)
+SUBDIRS = pmt msg
+AM_CPPFLAGS = $(DEFINES) $(BOOST_CPPFLAGS) $(CPPUNIT_INCLUDES) $(GRUEL_INCLUDES) $(WITH_INCLUDES)
 lib_LTLIBRARIES = libgruel.la
 
 # magic flags
-libgruel_la_LDFLAGS = $(NO_UNDEFINED) $(BOOST_LDFLAGS) -version-info 0:0:0
+libgruel_la_LDFLAGS = $(NO_UNDEFINED) $(BOOST_LDFLAGS) $(LTVERSIONFLAGS)
+
+# ----------------------------------------------------------------
+PMT_LIB = pmt/libpmt.la
+MSG_LIB = msg/libmsg.la
 
 # These are the source files that go into the gruel shared library
 libgruel_la_SOURCES = \
-       realtime.cc \
-       sys_pri.cc \
-       thread_body_wrapper.cc \
+       realtime.cc                     \
+       sys_pri.cc                      \
+       thread.cc                       \
+       thread_body_wrapper.cc          \
        thread_group.cc
 
 libgruel_la_LIBADD = \
-       $(BOOST_THREAD_LIB)
+       $(BOOST_THREAD_LIB)             \
+       $(PMT_LIB)                      \
+       $(MSG_LIB)                      \
+       -lstdc++
+
 
-noinst_HEADERS = 
-all: all-am
+# ----------------------------------------------------------------
+test_gruel_SOURCES = test_gruel.cc
+test_gruel_LDADD = pmt/libpmt-qa.la libgruel.la
+all: all-recursive
 
 .SUFFIXES:
 .SUFFIXES: .cc .lo .o .obj
@@ -824,6 +885,18 @@ clean-libLTLIBRARIES:
 libgruel.la: $(libgruel_la_OBJECTS) $(libgruel_la_DEPENDENCIES) 
        $(libgruel_la_LINK) -rpath $(libdir) $(libgruel_la_OBJECTS) $(libgruel_la_LIBADD) $(LIBS)
 
+clean-noinstPROGRAMS:
+       @list='$(noinst_PROGRAMS)'; test -n "$$list" || exit 0; \
+       echo " rm -f" $$list; \
+       rm -f $$list || exit $$?; \
+       test -n "$(EXEEXT)" || exit 0; \
+       list=`for p in $$list; do echo "$$p"; done | sed 's/$(EXEEXT)$$//'`; \
+       echo " rm -f" $$list; \
+       rm -f $$list
+test_gruel$(EXEEXT): $(test_gruel_OBJECTS) $(test_gruel_DEPENDENCIES) 
+       @rm -f test_gruel$(EXEEXT)
+       $(CXXLINK) $(test_gruel_OBJECTS) $(test_gruel_LDADD) $(LIBS)
+
 mostlyclean-compile:
        -rm -f *.$(OBJEXT)
 
@@ -832,6 +905,8 @@ distclean-compile:
 
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/realtime.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/sys_pri.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_gruel.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/thread.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/thread_body_wrapper.Plo@am__quote@
 @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/thread_group.Plo@am__quote@
 
@@ -862,6 +937,76 @@ mostlyclean-libtool:
 clean-libtool:
        -rm -rf .libs _libs
 
+# This directory's subdirectories are mostly independent; you can cd
+# into them and run `make' without going through this Makefile.
+# To change the values of `make' variables: instead of editing Makefiles,
+# (1) if the variable is set in `config.status', edit `config.status'
+#     (which will cause the Makefiles to be regenerated when you run `make');
+# (2) otherwise, pass the desired values on the `make' command line.
+$(RECURSIVE_TARGETS):
+       @fail= failcom='exit 1'; \
+       for f in x $$MAKEFLAGS; do \
+         case $$f in \
+           *=* | --[!k]*);; \
+           *k*) failcom='fail=yes';; \
+         esac; \
+       done; \
+       dot_seen=no; \
+       target=`echo $@ | sed s/-recursive//`; \
+       list='$(SUBDIRS)'; for subdir in $$list; do \
+         echo "Making $$target in $$subdir"; \
+         if test "$$subdir" = "."; then \
+           dot_seen=yes; \
+           local_target="$$target-am"; \
+         else \
+           local_target="$$target"; \
+         fi; \
+         ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
+         || eval $$failcom; \
+       done; \
+       if test "$$dot_seen" = "no"; then \
+         $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
+       fi; test -z "$$fail"
+
+$(RECURSIVE_CLEAN_TARGETS):
+       @fail= failcom='exit 1'; \
+       for f in x $$MAKEFLAGS; do \
+         case $$f in \
+           *=* | --[!k]*);; \
+           *k*) failcom='fail=yes';; \
+         esac; \
+       done; \
+       dot_seen=no; \
+       case "$@" in \
+         distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
+         *) list='$(SUBDIRS)' ;; \
+       esac; \
+       rev=''; for subdir in $$list; do \
+         if test "$$subdir" = "."; then :; else \
+           rev="$$subdir $$rev"; \
+         fi; \
+       done; \
+       rev="$$rev ."; \
+       target=`echo $@ | sed s/-recursive//`; \
+       for subdir in $$rev; do \
+         echo "Making $$target in $$subdir"; \
+         if test "$$subdir" = "."; then \
+           local_target="$$target-am"; \
+         else \
+           local_target="$$target"; \
+         fi; \
+         ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
+         || eval $$failcom; \
+       done && test -z "$$fail"
+tags-recursive:
+       list='$(SUBDIRS)'; for subdir in $$list; do \
+         test "$$subdir" = . || ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
+       done
+ctags-recursive:
+       list='$(SUBDIRS)'; for subdir in $$list; do \
+         test "$$subdir" = . || ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
+       done
+
 ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
        list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
        unique=`for i in $$list; do \
@@ -872,10 +1017,23 @@ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
        mkid -fID $$unique
 tags: TAGS
 
-TAGS:  $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
+TAGS: tags-recursive $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
                $(TAGS_FILES) $(LISP)
        set x; \
        here=`pwd`; \
+       if ($(ETAGS) --etags-include --version) >/dev/null 2>&1; then \
+         include_option=--etags-include; \
+         empty_fix=.; \
+       else \
+         include_option=--include; \
+         empty_fix=; \
+       fi; \
+       list='$(SUBDIRS)'; for subdir in $$list; do \
+         if test "$$subdir" = .; then :; else \
+           test ! -f $$subdir/TAGS || \
+             set "$$@" "$$include_option=$$here/$$subdir/TAGS"; \
+         fi; \
+       done; \
        list='$(SOURCES) $(HEADERS)  $(LISP) $(TAGS_FILES)'; \
        unique=`for i in $$list; do \
            if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
@@ -894,7 +1052,7 @@ TAGS:  $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
          fi; \
        fi
 ctags: CTAGS
-CTAGS:  $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
+CTAGS: ctags-recursive $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
                $(TAGS_FILES) $(LISP)
        list='$(SOURCES) $(HEADERS)  $(LISP) $(TAGS_FILES)'; \
        unique=`for i in $$list; do \
@@ -914,6 +1072,98 @@ GTAGS:
 distclean-tags:
        -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
 
+check-TESTS: $(TESTS)
+       @failed=0; all=0; xfail=0; xpass=0; skip=0; \
+       srcdir=$(srcdir); export srcdir; \
+       list=' $(TESTS) '; \
+       $(am__tty_colors); \
+       if test -n "$$list"; then \
+         for tst in $$list; do \
+           if test -f ./$$tst; then dir=./; \
+           elif test -f $$tst; then dir=; \
+           else dir="$(srcdir)/"; fi; \
+           if $(TESTS_ENVIRONMENT) $${dir}$$tst; then \
+             all=`expr $$all + 1`; \
+             case " $(XFAIL_TESTS) " in \
+             *[\ \     ]$$tst[\ \      ]*) \
+               xpass=`expr $$xpass + 1`; \
+               failed=`expr $$failed + 1`; \
+               col=$$red; res=XPASS; \
+             ;; \
+             *) \
+               col=$$grn; res=PASS; \
+             ;; \
+             esac; \
+           elif test $$? -ne 77; then \
+             all=`expr $$all + 1`; \
+             case " $(XFAIL_TESTS) " in \
+             *[\ \     ]$$tst[\ \      ]*) \
+               xfail=`expr $$xfail + 1`; \
+               col=$$lgn; res=XFAIL; \
+             ;; \
+             *) \
+               failed=`expr $$failed + 1`; \
+               col=$$red; res=FAIL; \
+             ;; \
+             esac; \
+           else \
+             skip=`expr $$skip + 1`; \
+             col=$$blu; res=SKIP; \
+           fi; \
+           echo "$${col}$$res$${std}: $$tst"; \
+         done; \
+         if test "$$all" -eq 1; then \
+           tests="test"; \
+           All=""; \
+         else \
+           tests="tests"; \
+           All="All "; \
+         fi; \
+         if test "$$failed" -eq 0; then \
+           if test "$$xfail" -eq 0; then \
+             banner="$$All$$all $$tests passed"; \
+           else \
+             if test "$$xfail" -eq 1; then failures=failure; else failures=failures; fi; \
+             banner="$$All$$all $$tests behaved as expected ($$xfail expected $$failures)"; \
+           fi; \
+         else \
+           if test "$$xpass" -eq 0; then \
+             banner="$$failed of $$all $$tests failed"; \
+           else \
+             if test "$$xpass" -eq 1; then passes=pass; else passes=passes; fi; \
+             banner="$$failed of $$all $$tests did not behave as expected ($$xpass unexpected $$passes)"; \
+           fi; \
+         fi; \
+         dashes="$$banner"; \
+         skipped=""; \
+         if test "$$skip" -ne 0; then \
+           if test "$$skip" -eq 1; then \
+             skipped="($$skip test was not run)"; \
+           else \
+             skipped="($$skip tests were not run)"; \
+           fi; \
+           test `echo "$$skipped" | wc -c` -le `echo "$$banner" | wc -c` || \
+             dashes="$$skipped"; \
+         fi; \
+         report=""; \
+         if test "$$failed" -ne 0 && test -n "$(PACKAGE_BUGREPORT)"; then \
+           report="Please report to $(PACKAGE_BUGREPORT)"; \
+           test `echo "$$report" | wc -c` -le `echo "$$banner" | wc -c` || \
+             dashes="$$report"; \
+         fi; \
+         dashes=`echo "$$dashes" | sed s/./=/g`; \
+         if test "$$failed" -eq 0; then \
+           echo "$$grn$$dashes"; \
+         else \
+           echo "$$red$$dashes"; \
+         fi; \
+         echo "$$banner"; \
+         test -z "$$skipped" || echo "$$skipped"; \
+         test -z "$$report" || echo "$$report"; \
+         echo "$$dashes$$std"; \
+         test "$$failed" -eq 0; \
+       else :; fi
+
 distdir: $(DISTFILES)
        @srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
        topsrcdirstrip=`echo "$(top_srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
@@ -944,25 +1194,55 @@ distdir: $(DISTFILES)
            || exit 1; \
          fi; \
        done
+       @list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
+         if test "$$subdir" = .; then :; else \
+           test -d "$(distdir)/$$subdir" \
+           || $(MKDIR_P) "$(distdir)/$$subdir" \
+           || exit 1; \
+         fi; \
+       done
+       @list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
+         if test "$$subdir" = .; then :; else \
+           dir1=$$subdir; dir2="$(distdir)/$$subdir"; \
+           $(am__relativize); \
+           new_distdir=$$reldir; \
+           dir1=$$subdir; dir2="$(top_distdir)"; \
+           $(am__relativize); \
+           new_top_distdir=$$reldir; \
+           echo " (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) top_distdir="$$new_top_distdir" distdir="$$new_distdir" \\"; \
+           echo "     am__remove_distdir=: am__skip_length_check=: am__skip_mode_fix=: distdir)"; \
+           ($(am__cd) $$subdir && \
+             $(MAKE) $(AM_MAKEFLAGS) \
+               top_distdir="$$new_top_distdir" \
+               distdir="$$new_distdir" \
+               am__remove_distdir=: \
+               am__skip_length_check=: \
+               am__skip_mode_fix=: \
+               distdir) \
+             || exit 1; \
+         fi; \
+       done
        $(MAKE) $(AM_MAKEFLAGS) \
          top_distdir="$(top_distdir)" distdir="$(distdir)" \
          dist-hook
 check-am: all-am
-check: check-am
-all-am: Makefile $(LTLIBRARIES) $(HEADERS)
-installdirs:
+       $(MAKE) $(AM_MAKEFLAGS) check-TESTS
+check: check-recursive
+all-am: Makefile $(LTLIBRARIES) $(PROGRAMS)
+installdirs: installdirs-recursive
+installdirs-am:
        for dir in "$(DESTDIR)$(libdir)"; do \
          test -z "$$dir" || $(MKDIR_P) "$$dir"; \
        done
-install: install-am
-install-exec: install-exec-am
-install-data: install-data-am
-uninstall: uninstall-am
+install: install-recursive
+install-exec: install-exec-recursive
+install-data: install-data-recursive
+uninstall: uninstall-recursive
 
 install-am: all-am
        @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
 
-installcheck: installcheck-am
+installcheck: installcheck-recursive
 install-strip:
        $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
          install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
@@ -980,92 +1260,96 @@ distclean-generic:
 maintainer-clean-generic:
        @echo "This command is intended for maintainers to use"
        @echo "it deletes files that may require special tools to rebuild."
-clean: clean-am
+clean: clean-recursive
 
 clean-am: clean-generic clean-libLTLIBRARIES clean-libtool \
-       mostlyclean-am
+       clean-noinstPROGRAMS mostlyclean-am
 
-distclean: distclean-am
+distclean: distclean-recursive
        -rm -rf ./$(DEPDIR)
        -rm -f Makefile
 distclean-am: clean-am distclean-compile distclean-generic \
        distclean-tags
 
-dvi: dvi-am
+dvi: dvi-recursive
 
 dvi-am:
 
-html: html-am
+html: html-recursive
 
 html-am:
 
-info: info-am
+info: info-recursive
 
 info-am:
 
 install-data-am:
 
-install-dvi: install-dvi-am
+install-dvi: install-dvi-recursive
 
 install-dvi-am:
 
 install-exec-am: install-libLTLIBRARIES
 
-install-html: install-html-am
+install-html: install-html-recursive
 
 install-html-am:
 
-install-info: install-info-am
+install-info: install-info-recursive
 
 install-info-am:
 
 install-man:
 
-install-pdf: install-pdf-am
+install-pdf: install-pdf-recursive
 
 install-pdf-am:
 
-install-ps: install-ps-am
+install-ps: install-ps-recursive
 
 install-ps-am:
 
 installcheck-am:
 
-maintainer-clean: maintainer-clean-am
+maintainer-clean: maintainer-clean-recursive
        -rm -rf ./$(DEPDIR)
        -rm -f Makefile
 maintainer-clean-am: distclean-am maintainer-clean-generic
 
-mostlyclean: mostlyclean-am
+mostlyclean: mostlyclean-recursive
 
 mostlyclean-am: mostlyclean-compile mostlyclean-generic \
        mostlyclean-libtool
 
-pdf: pdf-am
+pdf: pdf-recursive
 
 pdf-am:
 
-ps: ps-am
+ps: ps-recursive
 
 ps-am:
 
 uninstall-am: uninstall-libLTLIBRARIES
 
-.MAKE: install-am install-strip
-
-.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
-       clean-libLTLIBRARIES clean-libtool ctags dist-hook distclean \
-       distclean-compile distclean-generic distclean-libtool \
-       distclean-tags distdir dvi dvi-am html html-am info info-am \
-       install install-am install-data install-data-am install-dvi \
-       install-dvi-am install-exec install-exec-am install-html \
-       install-html-am install-info install-info-am \
-       install-libLTLIBRARIES install-man install-pdf install-pdf-am \
-       install-ps install-ps-am install-strip installcheck \
-       installcheck-am installdirs maintainer-clean \
+.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) check-am \
+       ctags-recursive install-am install-strip tags-recursive
+
+.PHONY: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) CTAGS GTAGS \
+       all all-am check check-TESTS check-am clean clean-generic \
+       clean-libLTLIBRARIES clean-libtool clean-noinstPROGRAMS ctags \
+       ctags-recursive dist-hook distclean distclean-compile \
+       distclean-generic distclean-libtool distclean-tags distdir dvi \
+       dvi-am html html-am info info-am install install-am \
+       install-data install-data-am install-dvi install-dvi-am \
+       install-exec install-exec-am install-html install-html-am \
+       install-info install-info-am install-libLTLIBRARIES \
+       install-man install-pdf install-pdf-am install-ps \
+       install-ps-am install-strip installcheck installcheck-am \
+       installdirs installdirs-am maintainer-clean \
        maintainer-clean-generic mostlyclean mostlyclean-compile \
        mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
-       tags uninstall uninstall-am uninstall-libLTLIBRARIES
+       tags tags-recursive uninstall uninstall-am \
+       uninstall-libLTLIBRARIES
 
 
 # Base directory for documentation (docdir undefined in autoconf < 1.60)