Imported Upstream version 3.0.3
[debian/gnuradio] / gr-trellis / src / lib / Makefile.in
index 13ff7d48a1666ff7de59d87118c5390f17896975..4d2b0ccb210b3fcd9f802262db4849e49630fbdb 100644 (file)
@@ -37,7 +37,7 @@
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -146,7 +146,9 @@ am__installdirs = "$(DESTDIR)$(ourlibdir)" "$(DESTDIR)$(ourpythondir)" \
 ourlibLTLIBRARIES_INSTALL = $(INSTALL)
 LTLIBRARIES = $(ourlib_LTLIBRARIES)
 am__DEPENDENCIES_1 =
-_trellis_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+am__DEPENDENCIES_2 =  \
+       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
+_trellis_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2)
 am__objects_1 = trellis_encoder_bb.lo trellis_encoder_bi.lo \
        trellis_encoder_bs.lo trellis_encoder_ii.lo \
        trellis_encoder_si.lo trellis_encoder_ss.lo \
@@ -416,25 +418,17 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    $(FFTW3F_CFLAGS)
 
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 
 # This is a dependency for many swig operations
 GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
+# How to link in the USRP library from inside the tree
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
-
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
@@ -555,7 +549,7 @@ _trellis_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 # c++ standard library
 _trellis_la_LIBADD = \
        $(PYTHON_LDFLAGS)               \
-       $(GNURADIO_CORE_LIBS)           \
+       $(GNURADIO_CORE_LA)             \
        -lstdc++