Make C++ shared libraries versioned
[debian/gnuradio] / gr-msdd6000 / src / Makefile.am
index b2bf22ab9f10173a713896d0009709b7520a47ce..f6dbd2fb816822e46c57582530649793b1141e7c 100644 (file)
@@ -28,13 +28,38 @@ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
 grinclude_HEADERS =                    \
        msdd_source_simple.h            \
        msdd_buffer_copy_behaviors.h    \
-       msdd6000.h
+       msdd6000.h                      \
+       msdd_rs_source_simple.h         \
+       msdd6000_rs.h
 
+lib_LTLIBRARIES = libgnuradio-msdd6000.la \
+       libgnuradio-msdd6000_rs.la
+
+libgnuradio_msdd6000_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
+libgnuradio_msdd6000_rs_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
+
+libgnuradio_msdd6000_la_SOURCES =      \
+       msdd_source_simple.cc           \
+       msdd6000.cc
+
+
+libgnuradio_msdd6000_rs_la_SOURCES =   \
+       msdd_rs_source_simple.cc                \
+       msdd6000_rs.cc
+
+libgnuradio_msdd6000_la_LIBADD =       \
+       $(GNURADIO_CORE_LA)
+
+libgnuradio_msdd6000_rs_la_LIBADD =    \
+       $(GNURADIO_CORE_LA)
+
+
+if PYTHON
 #################################
 # SWIG interface and library
 
 TOP_SWIG_IFILES =                      \
-       msdd.i
+       msdd.i msdd_rs.i
 
 # Install so that they end up available as:
 #   import gnuradio.msdd
@@ -43,14 +68,15 @@ TOP_SWIG_IFILES =                   \
 msdd_pythondir_category =              \
        gnuradio
 
-# additional sources for the SWIG-generated library
-msdd_la_swig_sources =                 \
-       msdd_source_simple.cc           \
-       msdd6000.cc
+msdd_rs_pythondir_category =   \
+       gnuradio
 
 # additional libraries for linking with the SWIG-generated library
 msdd_la_swig_libadd =                  \
-       $(GNURADIO_CORE_LA)
+       libgnuradio-msdd6000.la
+
+msdd_rs_la_swig_libadd =                       \
+       libgnuradio-msdd6000_rs.la
 
 include $(top_srcdir)/Makefile.swig
 
@@ -59,3 +85,4 @@ BUILT_SOURCES = $(swig_built_sources)
 
 # Do not distribute the output of SWIG
 no_dist_files = $(swig_built_sources)
+endif