howto: make versioned libraries
[debian/gnuradio] / gr-howto-write-a-block / Makefile.common
index c81bc780dcf4efc2ed61a369ef0a562baa745439..8423671a378f37c291971dd560f5ab24e5cdd282 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2009 Free Software Foundation, Inc.
+# Copyright 2004,2006,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # Boston, MA 02110-1301, USA.
 # 
 
+# The name of this "out-of-tree" module
+modname = howto
+
 # these flags are used when compiling non-SWIG-wrapper files
 # when going in to non-SWIG libraries
 AM_CXXFLAGS = @autoconf_default_CXXFLAGS@
 
+# Sets ABI version in SONAME and appends -LIBVER to filename
+LTVERSIONFLAGS = -version-info 0:0:0 -release $(LIBVER)
+
 # these flags are used when compiling any CXX file
 AM_CPPFLAGS = \
        $(STD_DEFINES_AND_INCLUDES) \
@@ -34,21 +40,22 @@ AM_CPPFLAGS = \
 # these are used by both SWIG and CXX
 STD_DEFINES_AND_INCLUDES = \
        $(DEFINES) \
+       -I$(abs_top_srcdir)/include \
        -I$(GNURADIO_CORE_INCLUDEDIR) \
        -I$(GNURADIO_CORE_INCLUDEDIR)/swig
 
 # includes
-grincludedir = $(includedir)/gnuradio
+modincludedir = $(includedir)/$(modname)
 
 # swig includes 
-swigincludedir = $(grincludedir)/swig
+swigincludedir = $(modincludedir)/swig
 
 # Install this stuff in the appropriate subdirectory
 # This usually ends up at:
-#   ${prefix}/lib/python${python_version}/site-packages/gnuradio
+#   ${prefix}/lib/python${python_version}/site-packages/$(modname)
 
-grpythondir = $(pythondir)/gnuradio
-grpyexecdir = $(pyexecdir)/gnuradio
+modpythondir = $(pythondir)/$(modname)
+modpyexecdir = $(pyexecdir)/$(modname)
 
 # Data directory for grc block wrappers
 grc_blocksdir = $(prefix)/share/gnuradio/grc/blocks