Imported Upstream version 3.0.3
[debian/gnuradio] / gr-gsm-fr-vocoder / src / lib / Makefile.in
index cc259c1287a281ceb42207db5197e7de20d70506..67990389e0bfc4cb54a3807907d8da0672f0d422 100644 (file)
@@ -37,7 +37,7 @@
 
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -145,8 +145,10 @@ am__installdirs = "$(DESTDIR)$(ourlibdir)" "$(DESTDIR)$(ourpythondir)" \
 ourlibLTLIBRARIES_INSTALL = $(INSTALL)
 LTLIBRARIES = $(ourlib_LTLIBRARIES)
 am__DEPENDENCIES_1 =
+am__DEPENDENCIES_2 =  \
+       $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 _gsm_full_rate_la_DEPENDENCIES = gsm/libgsm.la $(am__DEPENDENCIES_1) \
-       $(am__DEPENDENCIES_1)
+       $(am__DEPENDENCIES_2)
 am__gsm_full_rate_la_OBJECTS = gsm_fr_decode_ps.lo gsm_fr_encode_sp.lo \
        gsm_full_rate.lo
 _gsm_full_rate_la_OBJECTS = $(am__gsm_full_rate_la_OBJECTS)
@@ -414,25 +416,17 @@ GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
                    $(FFTW3F_CFLAGS)
 
 
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
 
 # This is a dependency for many swig operations
 GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
 
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
+# How to link in the USRP library from inside the tree
 USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
                -I$(top_srcdir)/usrp/firmware/include
 
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
-
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LIBS = -L$(top_builddir)/pmt/src/lib -lpmt
+USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
@@ -491,7 +485,7 @@ _gsm_full_rate_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 _gsm_full_rate_la_LIBADD = \
        gsm/libgsm.la           \
        $(PYTHON_LDFLAGS)       \
-       $(GNURADIO_CORE_LIBS)   \
+       $(GNURADIO_CORE_LA)     \
        -lstdc++