Imported Upstream version 3.2.2
[debian/gnuradio] / gr-gsm-fr-vocoder / src / lib / Makefile.am
index 857cd4d9c5090c0dc5c23bfab3d28b0c6cc988e4..0cf0fb0788fe67653f15cf72e89ea1fae324d6ad 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004,2005 Free Software Foundation, Inc.
+# Copyright 2004,2005,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -23,79 +23,39 @@ include $(top_srcdir)/Makefile.common
 
 SUBDIRS = gsm .
 
-# Install this stuff so that it ends up as the gnuradio.vocoder module
-# This usually ends up at:
-#   ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
-
-ourpythondir = $(grpythondir)/vocoder
-ourlibdir    = $(grpyexecdir)/vocoder
-
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
-
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES)
-
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
 
-ALL_IFILES =                           \
-       $(LOCAL_IFILES)                 \
-       $(NON_LOCAL_IFILES)             
-
-NON_LOCAL_IFILES =                     \
-       $(GNURADIO_I)
-
-
-LOCAL_IFILES =                                 \
-       $(top_srcdir)/gr-gsm-fr-vocoder/src/lib/gsm_full_rate.i                         
-
-# These files are built by SWIG.  The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
+# C/C++ headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS =                    \
+       gsm_fr_decode_ps.h              \
+       gsm_fr_encode_sp.h
 
-BUILT_SOURCES =                        \
-       gsm_full_rate.cc                \
-       gsm_full_rate.py                                
+# SWIG interface and library
 
-# This gets gsm_full_rate.py installed in the right place
-ourpython_PYTHON =                     \
-       __init__.py                     \
-       gsm_full_rate.py
+TOP_SWIG_IFILES =                      \
+       gsm_full_rate.i
 
-ourlib_LTLIBRARIES = _gsm_full_rate.la
+# Install so that they end up available as:
+#   import gnuradio.vocoder.gsm_full_rate
+# This ends up at:
+#   ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
+gsm_full_rate_pythondir_category =     \
+       gnuradio/vocoder
 
-# These are the source files that go into the shared library
-_gsm_full_rate_la_SOURCES =            \
+# additional sources for the SWIG-generated library
+gsm_full_rate_la_swig_sources =        \
        gsm_fr_decode_ps.cc             \
-       gsm_fr_encode_sp.cc             \
-       gsm_full_rate.cc                
-
-
-# magic flags
-_gsm_full_rate_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
-
-# link the library against the gsm library and the
-# c++ standard library
-_gsm_full_rate_la_LIBADD =     \
-       gsm/libgsm.la           \
-       $(PYTHON_LDFLAGS)       \
-       $(GNURADIO_CORE_LA)     \
-       -lstdc++                        
-
-gsm_full_rate.cc gsm_full_rate.py: gsm_full_rate.i $(ALL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module gsm_full_rate -o gsm_full_rate.cc $(LOCAL_IFILES)
-
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS =                    \
-       gsm_fr_decode_ps.h              \
-       gsm_fr_encode_sp.h              
-
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS =                  \
-       $(LOCAL_IFILES)
+       gsm_fr_encode_sp.cc
 
+# additional libraries for linking with the SWIG-generated library
+gsm_full_rate_la_swig_libadd =         \
+       $(GNURADIO_CORE_LA)             \
+       gsm/libgsm.la
 
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+include $(top_srcdir)/Makefile.swig
 
-# Don't distribute output of swig
-dist-hook:
-       @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
-       @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
 
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)