Imported Upstream version 3.2.2
[debian/gnuradio] / gnuradio-core / src / tests / Makefile.am
index e120ae3f9113a9b6c788b033ab650e296efed880..2bf7cb4e546fc84d034a823224378b0bb0c38b12 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001 Free Software Foundation, Inc.
+# Copyright 2001,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
 
 # list of programs run by "make check" and "make distcheck"
 
@@ -32,10 +32,12 @@ TESTS = test_all
 
 #Test program to test setting up buffers using gr_test which can be run manually
 EXTRA_DIST =                           \
-       test_buffers.py
+       test_buffers.py \
+       benchmark_dotprod
+
 
 noinst_PROGRAMS                =       \
-       benchmark_dotprod       \
+       benchmark_dotprod_fff   \
        benchmark_dotprod_fsf   \
        benchmark_dotprod_fcc   \
        benchmark_dotprod_scc   \
@@ -43,18 +45,25 @@ noinst_PROGRAMS             =       \
        benchmark_dotprod_ccf   \
        benchmark_nco           \
        benchmark_vco           \
+       test_all                \
        test_runtime            \
        test_general            \
-       test_all                \
        test_filter             \
        test_vmcircbuf
 
+#bin_PROGRAMS = \
+#      test_all
+
+
+noinst_SCRIPTS = \
+       benchmark_dotprod
+
 
 LIBGNURADIO =  $(GNURADIO_CORE_LA)
 LIBGNURADIOQA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core-qa.la $(LIBGNURADIO)
 
-benchmark_dotprod_SOURCES = benchmark_dotprod.cc
-benchmark_dotprod_LDADD   = $(LIBGNURADIO)
+benchmark_dotprod_fff_SOURCES = benchmark_dotprod_fff.cc
+benchmark_dotprod_fff_LDADD   = $(LIBGNURADIO)
 
 benchmark_dotprod_fsf_SOURCES = benchmark_dotprod_fsf.cc
 benchmark_dotprod_fsf_LDADD   = $(LIBGNURADIO)