Imported Upstream version 3.2.2
[debian/gnuradio] / gnuradio-core / src / lib / runtime / Makefile.am
index e097b12cc33bc64201845828acffe6dbd7e8afa2..af5e4980d68ec91813d9bc6ddde7f251b06fe81a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2003,2004 Free Software Foundation, Inc.
+# Copyright 2003,2004,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -21,7 +21,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(GRUEL_INCLUDES) $(WITH_INCLUDES)
 
 noinst_LTLIBRARIES = libruntime.la libruntime-qa.la
 
@@ -30,8 +30,14 @@ libruntime_la_LIBADD =               \
 
 
 libruntime_la_SOURCES =                        \
+       gr_basic_block.cc                       \
+       gr_flowgraph.cc                         \
+       gr_flat_flowgraph.cc                    \
        gr_block.cc                             \
        gr_block_detail.cc                      \
+       gr_block_executor.cc                    \
+       gr_hier_block2.cc                       \
+       gr_hier_block2_detail.cc                \
        gr_buffer.cc                            \
        gr_dispatcher.cc                        \
        gr_error_handler.cc                     \
@@ -43,8 +49,19 @@ libruntime_la_SOURCES =                      \
        gr_pagesize.cc                          \
        gr_preferences.cc                       \
        gr_realtime.cc                          \
+       gr_scheduler.cc                         \
+       gr_scheduler_sts.cc                     \
+       gr_scheduler_tpb.cc                     \
        gr_single_threaded_scheduler.cc         \
+       gr_sptr_magic.cc                        \
+       gr_sync_block.cc                        \
+       gr_sync_decimator.cc                    \
+       gr_sync_interpolator.cc                 \
        gr_tmp_path.cc                          \
+       gr_top_block.cc                         \
+       gr_top_block_impl.cc                    \
+       gr_tpb_detail.cc                        \
+       gr_tpb_thread_body.cc                   \
        gr_vmcircbuf.cc                         \
        gr_vmcircbuf_mmap_shm_open.cc           \
        gr_vmcircbuf_mmap_tmpfile.cc            \
@@ -54,14 +71,24 @@ libruntime_la_SOURCES =                     \
 
 libruntime_qa_la_SOURCES =                     \
        qa_gr_block.cc                          \
+       qa_gr_hier_block2.cc                    \
+       qa_gr_hier_block2_derived.cc            \
        qa_gr_buffer.cc                         \
+       qa_gr_flowgraph.cc                      \
+       qa_gr_top_block.cc                      \
        qa_gr_io_signature.cc                   \
        qa_gr_vmcircbuf.cc                      \
        qa_runtime.cc                           
 
 grinclude_HEADERS =                            \
+       gr_basic_block.h                        \
+       gr_flowgraph.h                          \
+       gr_flat_flowgraph.h                     \
        gr_block.h                              \
        gr_block_detail.h                       \
+       gr_block_executor.h                     \
+       gr_hier_block2.h                        \
+       gr_hier_block2_detail.h                 \
        gr_buffer.h                             \
        gr_complex.h                            \
        gr_dispatcher.h                         \
@@ -74,9 +101,20 @@ grinclude_HEADERS =                                 \
        gr_pagesize.h                           \
        gr_preferences.h                        \
        gr_realtime.h                           \
-       gr_runtime.h                            \
+       gr_runtime_types.h                      \
+       gr_scheduler.h                          \
+       gr_scheduler_sts.h                      \
+       gr_scheduler_tpb.h                      \
        gr_select_handler.h                     \
        gr_single_threaded_scheduler.h          \
+       gr_sptr_magic.h                         \
+       gr_sync_block.h                         \
+       gr_sync_decimator.h                     \
+       gr_sync_interpolator.h                  \
+       gr_top_block.h                          \
+       gr_top_block_impl.h                     \
+       gr_tpb_detail.h                         \
+       gr_tpb_thread_body.h                    \
        gr_timer.h                              \
        gr_tmp_path.h                           \
        gr_types.h                              \
@@ -88,14 +126,20 @@ noinst_HEADERS =                           \
        gr_vmcircbuf_sysv_shm.h                 \
        gr_vmcircbuf_createfilemapping.h        \
        qa_gr_block.h                           \
+       qa_gr_flowgraph.h                       \
+       qa_gr_hier_block2.h                     \
+       qa_gr_hier_block2_derived.h             \
        qa_gr_buffer.h                          \
        qa_gr_io_signature.h                    \
+       qa_gr_top_block.h                       \
        qa_gr_vmcircbuf.h                       \
        qa_runtime.h                            
 
 swiginclude_HEADERS =                  \
+       gr_basic_block.i                \
        gr_block.i                      \
        gr_block_detail.i               \
+       gr_hier_block2.i                \
        gr_buffer.i                     \
        gr_dispatcher.i                 \
        gr_error_handler.i              \
@@ -105,5 +149,8 @@ swiginclude_HEADERS =                       \
        gr_msg_queue.i                  \
        gr_realtime.i                   \
        gr_single_threaded_scheduler.i  \
-       gr_swig_block_magic.i           \
+       gr_sync_block.i                 \
+       gr_sync_decimator.i             \
+       gr_sync_interpolator.i          \
+       gr_top_block.i                  \
        runtime.i