Make C++ shared libraries versioned
[debian/gnuradio] / gnuradio-core / src / lib / Makefile.am
index 8046f1d2609689a561f184142c43dbd2a0dfdc31..86e3aa1f6c5b08b14931b9551f851232e494e66f 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2001,2004 Free Software Foundation, Inc.
+# Copyright 2001,2004,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -15,8 +15,8 @@
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
@@ -24,34 +24,49 @@ include $(top_srcdir)/Makefile.common
 ## Process this file with automake to produce Makefile.in
 
 # We've got to build . before swig
-SUBDIRS = missing runtime filter general g72x reed-solomon omnithread io . swig
+SUBDIRS = missing runtime filter viterbi general gengen g72x reed-solomon io hier .
+if PYTHON
+SUBDIRS += swig
+endif
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
 
 # generate libgnuradio-core.la from the convenience libraries in subdirs
 
-lib_LTLIBRARIES = libgnuradio-core.la libgnuradio-core-qa.la
+lib_LTLIBRARIES = libgnuradio-core.la
+noinst_LTLIBRARIES = libgnuradio-core-qa.la
 
 libgnuradio_core_la_SOURCES = bug_work_around_6.cc
-libgnuradio_core_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
+libgnuradio_core_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
 libgnuradio_core_qa_la_SOURCES = bug_work_around_6.cc
 libgnuradio_core_qa_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0 \
-                               $(LIBGNURADIO_CORE_EXTRA_LDFLAGS)
+                                $(LIBGNURADIO_CORE_EXTRA_LDFLAGS)
+
 
 libgnuradio_core_la_LIBADD  =          \
        filter/libfilter.la             \
        g72x/libccitt.la                \
+       viterbi/libviterbi.la           \
        general/libgeneral.la           \
+       gengen/libgengen.la             \
        io/libio.la                     \
        missing/libmissing.la           \
-       omnithread/libomnithread.la     \
        reed-solomon/librs.la           \
        runtime/libruntime.la           \
-       $(FFTW3F_LIBS)
+       hier/libhier.la                 \
+       $(GRUEL_LA)                     \
+       $(FFTW3F_LIBS)                  \
+       $(GSL_LIBS)                     \
+       $(CBLAS_LIBS)                   
 
 libgnuradio_core_qa_la_LIBADD  =       \
        filter/libfilter-qa.la          \
        general/libgeneral-qa.la        \
        runtime/libruntime-qa.la        \
-       missing/libmissing.la           \
        libgnuradio-core.la             \
        $(CPPUNIT_LIBS)                 
+
+bin_PROGRAMS = gnuradio-config-info
+gnuradio_config_info_SOURCES = gnuradio-config-info.cc
+gnuradio_config_info_LDADD = libgnuradio-core.la $(BOOST_PROGRAM_OPTIONS_LIB)