changes from running bootstrap and then make maintainer-clean
[debian/gnuradio] / debian / rules
index 42464ced9a130229e5e44f466d86b4086a00a92b..d6772c64bd7ca80f91acf722b91a67c9cb3ec082 100755 (executable)
@@ -8,19 +8,21 @@ export DH_OPTIONS
 
 export DH_PYCENTRAL=nomove
 
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp extract-stamp install-stamp
 
+       # Remove (possibly stale) pre-built Qt-generated moc files; they will
+       # be rebuilt using the current Qt moc.  Perhaps this should actually be
+       # part of 'make distclean' and these files not be distributed:
+       rm -f ./gr-qtgui/src/lib/*_moc.cc
+
        if [ -f Makefile ]; \
        then\
-               if [ -d .svn ]; \
-               then \
-                       $(MAKE) maintainer-clean; \
-               else \
-                       $(MAKE) distclean; \
-               fi; \
+               $(MAKE) maintainer-clean; \
        fi
 
        dh_clean
@@ -35,8 +37,9 @@ update:
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       [ -f ./configure ] || ./bootstrap
+       ./bootstrap
        ./configure \
+               --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr \
                --mandir=\$${prefix}/share/man \
                --infodir=\$${prefix}/share/info \
@@ -46,7 +49,7 @@ configure-stamp:
                --disable-gr-audio-osx \
                --disable-gr-audio-windows \
                --disable-gcell --disable-gr-gcell \
-               --disable-gr-comedi --disable-usrp2-firmware
+               --disable-gr-comedi --disable-usrp2-firmware 
        touch configure-stamp
 
 build: build-stamp
@@ -59,7 +62,8 @@ build-stamp: configure-stamp
 extract: extract-stamp
 extract-stamp: build-stamp debian/gen-install-files.sh
        dh_testdir
-       debian/gen-install-files.sh 
+       chmod +x debian/gen-install-files.sh dtools/bin/extract_install_filenames
+       debian/gen-install-files.sh
        touch $@
 
 install: install-stamp
@@ -79,12 +83,12 @@ install-stamp: extract-stamp debian/control
        done
 
        : # Deposit rule to allow group 'usrp' access to USRP hardware
-       install -m 0644 -D debian/libusrp.udev \
-               debian/tmp/etc/udev/rules.d/40-usrp.rules
+       install -m 0644 -D debian/libusrp0.udev \
+               debian/tmp/lib/udev/rules.d/40-usrp.rules
 
        : # Deposit rule to allow group 'usrp' access to USRP2 hardware
-       install -m 0644 -D debian/libusrp2.limits \
-               debian/tmp/etc/security/limits.d/libusrp2.limits
+       install -m 0644 -D debian/libusrp2-0.limits \
+               debian/tmp/etc/security/limits.d/libusrp2-0.limits
 
        : # Install custom grc.conf
        install -m 0644 -D debian/grc.conf \
@@ -94,6 +98,7 @@ install-stamp: extract-stamp debian/control
        touch $@
 
 
+
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep
 # in another 'make' thread.