stop using python-central as suggested by doko
[debian/gnuradio] / debian / control
index a7b33f0be2d1b5ab8b007ba5ab5713ffa6bee5d1..652355fcb3ecf6a714542d30187ba2efc1929a79 100644 (file)
@@ -7,9 +7,11 @@ Section: comm
 Priority: optional
 Maintainer: Bdale Garbee <bdale@gag.com>
 Build-Conflicts: automake1.8, automake1.9
-Build-Depends: automake, debhelper (>= 5), doxygen, ghostscript, guile-1.8, libasound2-dev, libaudio-dev, libblas-dev, libboost-date-time1.37-dev | libboost-date-time-dev, libboost-program-options-dev | libboost-program-options1.37-dev, libboost-thread-dev | libboost-thread1.37-dev, libcppunit-dev, libfftw3-dev, libfontconfig1-dev, libfreetype6-dev, libglib2.0-dev, libgsl0-dev, libjack-dev, libpng12-dev, libqt4-dev, libqt4-opengl-dev, libqwt5-qt4-dev, libqwtplot3d-qt4-dev, libsdl1.2-dev, libtool, libusb-dev, libwxgtk2.8-dev, libxext-dev, libxrender-dev, libxt-dev, pkg-config, portaudio19-dev, python-central, python-cheetah, python-dev, python-gtk2, python-lxml, python-numpy, python-qt4, python-qt4-dev, python-wxgtk2.8, sdcc, swig, texlive-latex-base, xdg-utils, xmlto
-Standards-Version: 3.8.3
+Build-Depends: automake, debhelper (>= 5), doxygen, ghostscript, guile-1.8, libasound2-dev, libaudio-dev, libblas-dev, libboost-dev, libboost-program-options-dev, libboost-thread-dev, libcppunit-dev, libfftw3-dev, libfontconfig1-dev, libfreetype6-dev, libglib2.0-dev, libgsl0-dev, libjack-dev, libpng12-dev, libqt4-dev, libqt4-opengl-dev, libqwt5-qt4-dev, libqwtplot3d-qt4-dev, libsdl1.2-dev, libtool, libusb-dev, libwxgtk2.8-dev, libxext-dev, libxrender-dev, libxt-dev, pkg-config, portaudio19-dev, python-cheetah, python-dev, python-gtk2, python-lxml, python-numpy, python-qt4, python-qt4-dev, python-wxgtk2.8, sdcc, swig, texlive-latex-base, xdg-utils, xmlto
+Standards-Version: 3.8.4
 XS-Python-Version: >=2.5
+Vcs-Git: git://git.gag.com/debian/gnuradio
+Vcs-Browser: http://git.gag.com/?p=debian/gnuradio
 
 ################################################################################
 # C++ auxiliary libraries                                                      #
@@ -18,9 +20,7 @@ XS-Python-Version: >=2.5
 Package: libgruel0
 Section: libs
 Architecture: any
-Depends: ${shlibs:Depends}
-Replaces: libpmt0
-Conflicts: libpmt0
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Description: GNU Radio Utility Etcetera Library
  This package implements a variety of low-level utility
  routines for GNU Radio.
@@ -28,9 +28,7 @@ Description: GNU Radio Utility Etcetera Library
 Package: libgruel-dev
 Section: libdevel
 Architecture: any
-Depends: libgruel0 (= ${binary:Version}), libboost-date-time1.37-dev | libboost-date-time-dev
-Replaces: libpmt-dev
-Conflicts: libpmt-dev
+Depends: libgruel0 (= ${binary:Version}), ${misc:Depends}
 Description: GNU Radio Utility Etcetera Library
  This package implements a variety of low-level utility
  routines for GNU Radio.
@@ -42,7 +40,7 @@ Section: libs
 Architecture: any
 Replaces: libgnuradio-omnithread0c2a
 Conflicts: libgnuradio-omnithread0c2a
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Description: GNU Radio Omnithreads Abstraction Library
  This package is a fork of the omniORB-4.0.1 threading library
  for use with GNU Radio.
@@ -52,13 +50,37 @@ Section: libdevel
 Architecture: any
 Replaces: libgnuradio-omnithread0-dev
 Conflicts: libgnuradio-omnithread0-dev
-Depends: libgromnithread0 (= ${binary:Version})
+Depends: libgromnithread0 (= ${binary:Version}), ${misc:Depends}
 Description: GNU Radio Omnithreads Abstraction Library
  This package is a fork of the omniORB-4.0.1 threading library
  for use with GNU Radio.
  .
  This package contains header files needed by developers.
 
+Package: libpmt0
+Section: libs
+Architecture: any
+Replaces: libpmt0c2a
+Conflicts: libpmt0c2a
+Depends: libgromnithread0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
+Description: GNU Radio Polymorphic Type Library
+ This package implements polymorphic types.  These are similar 
+ to lisp or Python data objects, and implement transparent
+ reference counting using the boost shared_ptr templates.
+
+Package: libpmt-dev
+Section: libdevel
+Architecture: any
+Replaces: libpmt0-dev
+Conflicts: libpmt0-dev
+Depends: libpmt0 (= ${binary:Version}), libgromnithread-dev (= ${binary:Version}), ${misc:Depends}
+Description: GNU Radio Polymorphic Type Library
+ This package implements polymorphic types.  These are similar 
+ to lisp or Python data objects, and implement transparent
+ reference counting using the boost shared_ptr templates.
+ .
+ This package contains header files needed by developers.
+
 ################################################################################
 # C++ M-Block library packages                                                 #
 ################################################################################
@@ -68,7 +90,7 @@ Section: libs
 Architecture: any
 Replaces: libmblock0c2a
 Conflicts: libmblock0c2a
-Depends: libpmt0 (= ${binary:Version}), libgromnithread0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: libpmt0 (= ${binary:Version}), libgromnithread0 (= ${binary:Version}), ${shlibs:Depends}, guile-1.8, ${misc:Depends}
 Description: GNU Radio Message Block Library 
  This package provides the GNU Radio message block library. 
 
@@ -77,7 +99,7 @@ Section: libdevel
 Architecture: any
 Replaces: libmblock0-dev
 Conflicts: libmblock0-dev
-Depends: libmblock0 (= ${binary:Version}), libgromnithread-dev (= ${binary:Version}), libgruel-dev (= ${binary:Version})
+Depends: libmblock0 (= ${binary:Version}), libgromnithread-dev (= ${binary:Version}), libpmt-dev (= ${binary:Version}), ${misc:Depends}
 Description: GNU Radio Message Block Library
  This package provides the GNU Radio message block library.
  .
@@ -90,7 +112,7 @@ Description: GNU Radio Message Block Library
 Package: libusrp0
 Section: comm
 Architecture: any
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, adduser, ${misc:Depends}
 Replaces: libusrp0c2a, usrp-firmware
 Conflicts: usrp-firmware
 Suggests: usrp-doc
@@ -109,7 +131,7 @@ Package: libusrp-dev
 Section: libdevel
 Architecture: any
 Replaces: libusrp0-dev
-Depends: libusrp0 (= ${binary:Version}), libusb-dev, libboost-thread1.37-dev | libboost-thread-dev
+Depends: libusrp0 (= ${binary:Version}), libusb-dev, libboost-thread-dev, ${misc:Depends}
 Description: Client side library for the USRP(1) hardware
  The Universal Software Radio Peripheral (USRP) is an USB-connected,
  low-cost and open board. It features four high-speed analog-to-digital
@@ -126,7 +148,7 @@ Description: Client side library for the USRP(1) hardware
 Package: libusrp2-0
 Section: comm
 Architecture: any
-Depends: libgruel0 (= ${binary:Version}), libgromnithread0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: libgruel0 (= ${binary:Version}), libgromnithread0 (= ${binary:Version}), ${shlibs:Depends}, adduser, ${misc:Depends}
 Description: Client side library for the USRP2 hardware
  The Universal Software Radio Peripheral 2 (USRP2) is a GbE-connected,
  low-cost and open board. It features two high-speed analog-to-digital
@@ -141,7 +163,7 @@ Description: Client side library for the USRP2 hardware
 Package: libusrp2-dev
 Section: libdevel
 Architecture: any
-Depends: libusrp2-0 (= ${binary:Version}), libboost-thread1.37-dev | libboost-thread-dev, libgromnithread-dev (= ${binary:Version}), libgruel-dev (= ${binary:Version})
+Depends: libusrp2-0 (= ${binary:Version}), libboost-thread-dev, libgromnithread-dev (= ${binary:Version}), libgruel-dev (= ${binary:Version}), ${misc:Depends}
 Description: Client side library for the USRP2 hardware
  The Universal Software Radio Peripheral 2 (USRP2) is a GbE-connected,
  low-cost and open board. It features two high-speed analog-to-digital
@@ -162,7 +184,7 @@ Description: Client side library for the USRP2 hardware
 Package: libgnuradio-core0
 Section: libs
 Architecture: any
-Depends: libgruel0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: libgruel0 (= ${binary:Version}), libgromnithread0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Conflicts:  libgnuradio-core0c2, libgnuradio-core0c2a
 Replaces:  libgnuradio-core0c2, libgnuradio-core0c2a
 Suggests: gnuradio-doc
@@ -174,7 +196,7 @@ Section: libdevel
 Architecture: any 
 Replaces: libgnuradio-core0-dev
 Conflicts: libgnuradio-core0-dev
-Depends: libgnuradio-core0 (= ${binary:Version}), libgruel-dev (= ${binary:Version}), libboost-thread1.37-dev | libboost-thread-dev, libboost-date-time1.37-dev | libboost-date-time-dev, libboost-program-options1.37-dev | libboost-program-options-dev, libgsl0-dev, libatlas-base-dev, libfftw3-dev, swig
+Depends: libgnuradio-core0 (= ${binary:Version}), libgruel-dev (= ${binary:Version}), libgromnithread-dev (= ${binary:Version}), libboost-thread-dev, libboost-date-time-dev, libgsl0-dev, libatlas-base-dev, libfftw3-dev, swig, ${misc:Depends}
 Description: The GNU Software Radio Core Library
  This package contains the core GNU Radio libraries.
  .
@@ -183,179 +205,41 @@ Description: The GNU Software Radio Core Library
 Package: libgnuradio-audio-alsa0
 Section: libs
 Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Description: GNU Radio C++ block for ALSA sound system
  This package contains the ALSA sound system driver for GNU Radio.
 
 Package: libgnuradio-audio-alsa-dev
 Section: libdevel
 Architecture: any
-Depends: libgnuradio-audio-alsa0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libasound2-dev
+Depends: libgnuradio-audio-alsa0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libasound2-dev, ${misc:Depends}
 Description: GNU Radio C++ block for ALSA sound system
  This package contains the ALSA sound system driver for GNU Radio.
  .
  This package contains header files needed by developers.
 
-Package: libgnuradio-audio-jack0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block for JACK sound system
- This package contains the JACK sound system driver for GNU Radio.
-
-Package: libgnuradio-audio-jack-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-audio-jack0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libjack-dev
-Description: GNU Radio C++ block for JACK sound system
- This package contains the JACK sound system driver for GNU Radio.
- .
- This package contains header files needed by developers.
-
-Package: libgnuradio-audio-oss0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block for OSS sound system
- This package contains the OSS sound system driver for GNU Radio.
-
-Package: libgnuradio-audio-oss-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-audio-oss0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version})
-Description: GNU Radio C++ block for OSS sound system
- This package contains the OSS sound system driver for GNU Radio.
- .
- This package contains header files needed by developers.
-
-Package: libgnuradio-audio-portaudio0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block for PORTAUDIO sound system
- This package contains the PORTAUDIO sound system driver for GNU Radio.
-
-Package: libgnuradio-audio-portaudio-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-audio-portaudio0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), portaudio19-dev
-Description: GNU Radio C++ block for PORTAUDIO sound system
- This package contains the PORTAUDIO sound system driver for GNU Radio.
- .
- This package contains header files needed by developers.
-
-Package: libgnuradio-cvsd-vocoder0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block implementing the CVSD vocoder
- This package provides an implementation of a CVSD vocoder for
- GNU Radio.
-
-Package: libgnuradio-cvsd-vocoder-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-cvsd-vocoder0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version})
-Description: GNU Radio C++ block implement the CVSD vocoder
- This package provides an implementation of a CVSD vocoder for
- GNU Radio.
- .
- This package contains header files needed by developers.
-
-Package: libgnuradio-gsm-fr-vocoder0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block implementing the GSM full rate vocoder
- This package provides an implementation of a GSM-FR vocoder for
- GNU Radio.
-
-Package: libgnuradio-gsm-fr-vocoder-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-gsm-fr-vocoder0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version})
-Description: GNU Radio C++ block implementing the GSM full rate vocoder
- This package provides an implementation of a GSM-FR vocoder for
- GNU Radio.
- .
- This package contains header files needed by developers.
-
-Package: libgnuradio-pager0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block implementing the FLEX one-way pager protocol
- This package provides an implementation of the FLEX one-way pager protocol
- for GNU Radio.
-
-Package: libgnuradio-pager-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-pager0  (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version})
-Description: GNU Radio C++ block implementing the FLEX one-way pager protocol
- This package provides an implementation of the FLEX one-way pager protocol
- for GNU Radio.
- .
- This package contains header files needed by developers.
-
 Package: libgnuradio-qtgui0
 Section: libs
 Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ blocks fro QT-based GUI applications
+Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
+Description: GNU Radio C++ blocks for QT-based GUI applications
  This package contains the C++ library for using GNU Radio inside
  QT-based GUI applications.
 
 Package: libgnuradio-qtgui-dev
 Section: libdevel
 Architecture: any
-Depends: libgnuradio-qtgui0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libqt4-dev, libqwtplot3d-qt4-dev
-Description: GNU Radio C++ blocks fro QT-based GUI applications
+Depends: libgnuradio-qtgui0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libqt4-dev, libqwtplot3d-qt4-dev, ${misc:Depends}
+Description: GNU Radio C++ blocks for QT-based GUI applications
  This package contains the C++ library for using GNU Radio inside
  QT-based GUI applications.
  .
  This package contains header files needed by developers.
 
-Package: libgnuradio-trellis0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block implementing trellis-coded modulation
- This package provides an implementation of tellis-coded modulation
- for GNU Radio.
-
-Package: libgnuradio-trellis-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-trellis0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version})
-Description: GNU Radio C++ block implementing trellis-coded modulation
- This package provides an implementation of trellis-coded modulation
- for GNU Radio.
- .
- This package contains header files needed by developers.
-
-Package: libgnuradio-video-sdl0
-Section: libs
-Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), ${shlibs:Depends}
-Description: GNU Radio C++ block implementing video-sdl-coded modulation
- This package provides an interface to the SDL rendering library
- for GNU Radio.
-
-Package: libgnuradio-video-sdl-dev
-Section: libdevel
-Architecture: any
-Depends: libgnuradio-video-sdl0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version})
-Description: GNU Radio C++ block implementing video-sdl-coded modulation
- This package provides an interface to the SDL rendering library
- for GNU Radio.
- .
- This package contains header files needed by developers.
-
 Package: libgnuradio-usrp0
 Section: libs
 Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), libusrp0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: libgnuradio-core0 (= ${binary:Version}), libusrp0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Description: GNU Radio C++ blocks for USRP(1) hardware
  This package contains the C++ API blocks for the Universal Software Radio
  Peripheral.
@@ -363,7 +247,7 @@ Description: GNU Radio C++ blocks for USRP(1) hardware
 Package: libgnuradio-usrp-dev
 Section: libdevel
 Architecture: any
-Depends: libgnuradio-usrp0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libusrp-dev (= ${binary:Version})
+Depends: libgnuradio-usrp0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libusrp-dev (= ${binary:Version}), ${misc:Depends}
 Description: GNU Radio C++ blocks for USRP(1) hardware
  This package contains the C++ API blocks for the Universal Software Radio
  Peripheral.
@@ -373,7 +257,7 @@ Description: GNU Radio C++ blocks for USRP(1) hardware
 Package: libgnuradio-usrp2-0
 Section: libs
 Architecture: any
-Depends: libgnuradio-core0 (= ${binary:Version}), libusrp2-0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: libgnuradio-core0 (= ${binary:Version}), libusrp2-0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Description: GNU Radio C++ blocks for USRP2 hardware
  This package contains the C++ API blocks for the Universal Software Radio
  Peripheral 2.
@@ -381,7 +265,7 @@ Description: GNU Radio C++ blocks for USRP2 hardware
 Package: libgnuradio-usrp2-dev
 Section: libdevel
 Architecture: any
-Depends: libgnuradio-usrp2-0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libusrp2-dev (= ${binary:Version})
+Depends: libgnuradio-usrp2-0 (= ${binary:Version}), libgnuradio-core-dev (= ${binary:Version}), libusrp2-dev (= ${binary:Version}), ${misc:Depends}
 Description: GNU Radio C++ blocks for USRP2 hardware
  This package contains the C++ API blocks for the Universal Software Radio
  Peripheral 2.
@@ -394,7 +278,7 @@ Description: GNU Radio C++ blocks for USRP2 hardware
 
 Package: python-usrp
 Architecture: any
-Depends: ${python:Depends}, libusrp0 (= ${binary:Version}), ${shlibs:Depends}
+Depends: ${python:Depends}, libusrp0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -408,8 +292,8 @@ Description: Python bindings for the USRP library
 
 Package: python-gnuradio-core
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-numpy
-Conflicts: python-gnuradio (< 3.2)
+Depends: ${python:Depends}, ${shlibs:Depends}, python-numpy, ${misc:Depends}
+Conflicts: python-gnuradio (<< 3.2)
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -419,8 +303,7 @@ Description: Python bindings for GNU Radio core library
 
 Package: python-gnuradio-wxgui
 Architecture: any
-Depends: ${python:Depends}, python-gnuradio-core (= ${binary:Version}), python-wxgtk2.8, python-opengl, python-numpy
-Conflicts: python-wxgtk2.6
+Depends: ${python:Depends}, python-gnuradio-core (= ${binary:Version}), python-wxgtk2.8, python-opengl, python-numpy, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -430,7 +313,7 @@ Description: GNU Radio Graphical Interface Routines based on wxPython
 
 Package: python-gnuradio-usrp
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, python-usrp
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, python-usrp, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -440,7 +323,7 @@ Description: Python bindings for GNU Radio USRP driver
 
 Package: python-gnuradio-usrp2
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -450,7 +333,7 @@ Description: Python bindings for GNU Radio USRP driver
 
 Package: python-gnuradio-audio-alsa
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, libgnuradio-audio-alsa0 (= ${binary:Version}), python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, libgnuradio-audio-alsa0 (= ${binary:Version}), python-gnuradio-core, ${misc:Depends}
 Section: python
 Provides: ${python:Provides}, python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
@@ -460,7 +343,7 @@ Description: Python bindings for GNU Radio ALSA audio driver
 
 Package: python-gnuradio-audio-portaudio
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}, python-gnuradio-audio
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -470,7 +353,7 @@ Description: GNU Radio Python PortAudio Driver
 
 Package: python-gnuradio-audio-jack
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Section: python
 Provides: ${python:Provides}, python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
@@ -480,7 +363,7 @@ Description: GNU Radio Python JACK Audio Driver
 
 Package: python-gnuradio-audio-oss
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Section: python
 Provides: ${python:Provides}, python-gnuradio-audio
 XB-Python-Version: ${python:Versions}
@@ -490,7 +373,7 @@ Description: GNU Radio Python OSS Audio Driver
 
 Package: python-gnuradio-cvsd-vocoder
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -500,7 +383,7 @@ Description: GNU Radio CVSD Vocoder
 
 Package: python-gnuradio-gsm-fr-vocoder
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -510,7 +393,7 @@ Description: GNU Radio GSM Full-Rate Vocoder
 
 Package: python-gnuradio-qtgui
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, libgnuradio-qtgui0 (= ${binary:Version}), python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, libgnuradio-qtgui0 (= ${binary:Version}), python-gnuradio-core, ${misc:Depends}
 Section: python
 Provides: ${python:Provides}
 XB-Python-Version: ${python:Versions}
@@ -520,7 +403,7 @@ Description: Python bindings for GNU Radio ALSA audio driver
 
 Package: python-gnuradio-trellis
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -530,7 +413,7 @@ Description: GNU Radio Trellis-Coded Modulation library
 
 Package: python-gnuradio-video-sdl
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}
 Section: python
 XB-Python-Version: ${python:Versions}
@@ -544,7 +427,7 @@ Description: GNU Radio SDL Interface Library
 
 Package: gnuradio-utils
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, python-gnuradio-usrp2, python-gnuradio-wxgui, python-matplotlib, python-tk, python-scipy
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, python-gnuradio-usrp2, python-gnuradio-wxgui, python-matplotlib, python-tk, python-scipy, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -553,7 +436,7 @@ Description: GNU Radio Utilities
 
 Package: gnuradio-examples
 Architecture: any
-Depends: ${python:Depends}, python-gnuradio-core
+Depends: ${python:Depends}, python-gnuradio-core, ${misc:Depends}
 Provides: ${python:Provides}
 Recommends: python-gnuradio-wxgui, python-gnuradio
 Section: comm
@@ -563,7 +446,7 @@ Description: GNU Radio Example Programs
 
 Package: gnuradio-pager
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -574,7 +457,7 @@ Package: gnuradio-sounder
 Architecture: any
 Replaces: gnuradio-sounder-firmware
 Conflicts: gnuradio-sounder-firmware
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -585,7 +468,7 @@ Package: gnuradio-gpio
 Architecture: any
 Replaces: gnuradio-gpio-firmware
 Conflicts: gnuradio-gpio-firmware
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -596,7 +479,7 @@ Package: gnuradio-radar-mono
 Architecture: any
 Replaces: gnuradio-radar-mono-firmware
 Conflicts: gnuradio-radar-mono-firmware
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -605,7 +488,7 @@ Description: GNU Radio Monostatic Radar Application
 
 Package: gnuradio-radio-astronomy
 Architecture: any
-Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, python-gnuradio-wxgui
+Depends: ${python:Depends}, ${shlibs:Depends}, python-gnuradio-usrp, python-gnuradio-wxgui, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -614,7 +497,7 @@ Description: GNU Radio Radio Astronomy Applications
 
 Package: gnuradio-companion
 Architecture: any
-Depends: ${python:Depends}, gnuradio, gnuradio-doc, usrp-doc, python-lxml, python-cheetah, python-gtk2
+Depends: ${python:Depends}, gnuradio, gnuradio-doc, usrp-doc, python-lxml, python-cheetah, python-gtk2, ${misc:Depends}
 Provides: ${python:Provides}
 Section: comm
 XB-Python-Version: ${python:Versions}
@@ -628,6 +511,7 @@ Description: The GNU Radio Companion
 Package: gnuradio-doc
 Section: doc
 Architecture: all
+Depends: ${misc:Depends}
 Description: Software Defined Radio
  This package contains the documentation for the GNU Radio software
  defined radio system.
@@ -635,6 +519,7 @@ Description: Software Defined Radio
 Package: usrp-doc
 Section: doc
 Architecture: all
+Depends: ${misc:Depends}
 Description: Software Defined Radio
  This package contains the documentation for the Universal Software Radio
  Peripheral (USRP) hardware and interface library.
@@ -646,8 +531,8 @@ Description: Software Defined Radio
 Package: libgnuradio
 Section: libs
 Architecture: all
-Depends: libgnuradio-core0
-Recommends: libgnuradio-audio-alsa0, libgnuradio-cvsd-vocoder0, libgnuradio-gsm-fr-vocoder0, libgnuradio-pager0, libgnuradio-qtqui0, libgnuradio-trellis0, libgnuradio-usrp0, libgnuradio-usrp20, libgnuradio-video-sdl0
+Depends: libgnuradio-core0, ${misc:Depends}
+Recommends: libgnuradio-audio-alsa0, libgnuradio-qtqui, libgnuradio-usrp0, libgnuradio-usrp2-0
 Description: GNU Radio C++ API libraries
  This is a virtual package that depends, recommends, or suggests all of the
  binary packages that make up the GNU Radio C++ API.  For development headers,
@@ -656,8 +541,8 @@ Description: GNU Radio C++ API libraries
 Package: libgnuradio-dev
 Section: libdevel
 Architecture: all
-Depends: libgnuradio0 (= ${binary:Version}), libgnuradio-core-dev
-Recommends: libgnuradio-audio-alsa-dev, libgnuradio-cvsd-vocoder-dev, libgnuradio-gsm-fr-vocoder-dev, libgnuradio-pager-dev, libgnuradio-qtgui-dev, libgnuradio-trellis-dev, libgnuradio-usrp-dev, libgnuradio-usrp2-dev, libgnuradio-video-sdl-dev
+Depends: libgnuradio (= ${binary:Version}), libgnuradio-core-dev, ${misc:Depends}
+Recommends: libgnuradio-audio-alsa-dev, libgnuradio-qtgui-dev, libgnuradio-usrp-dev, libgnuradio-usrp2-dev,
 Suggests: gnuradio-doc, usrp-doc
 Replaces: gnuradio-dev
 Description: Development headers for GNU Radio C++ development
@@ -668,7 +553,7 @@ Description: Development headers for GNU Radio C++ development
 Package: python-gnuradio
 Section: python
 Architecture: all
-Depends: python-gnuradio-core
+Depends: python-gnuradio-core, ${misc:Depends}
 Recommends: python-gnuradio-wxgui, python-gnuradio-audio-alsa | python-gnuradio-audio, python-gnuradio-cvsd-vocoder, python-gnuradio-gsm-fr-vocoder, python-gnuradio-qtgui, python-gnuradio-trellis, python-gnuradio-video-sdl, python-gnuradio-usrp, python-gnuradio-usrp2
 Provides: ${python:Provides}
 XB-Python-Version: ${python:Versions}
@@ -679,7 +564,7 @@ Description: Python Libraries for GNU Radio Components
 Package: gnuradio-apps
 Section: comm
 Architecture: all
-Depends: gnuradio-gpio, gnuradio-pager, gnuradio-sounder, gnuradio-radio-astronomy, gnuradio-radar-mono
+Depends: gnuradio-gpio, gnuradio-pager, gnuradio-sounder, gnuradio-radio-astronomy, gnuradio-radar-mono, ${misc:Depends}
 Description: The GNU Software Radio Toolkit - applications
  This is a virtual package that depends on top-level GNU Radio application
  packages.
@@ -687,6 +572,7 @@ Description: The GNU Software Radio Toolkit - applications
 Package: gnuradio
 Section: comm
 Architecture: all
+Depends: ${misc:Depends}
 Recommends: libgnuradio, libgnuradio-dev, gnuradio-doc, python-gnuradio, gnuradio-utils, gnuradio-examples, gnuradio-apps
 Description: The GNU Software Radio Toolkit
  This is a virtual package that installs the entire GNU Radio and USRP software