Fixing constellation zoomer's label.
[debian/gnuradio] / configure.ac
index de32033e3058791fdea92db85032e40f179d20aa..3ba5bb387d1a86a980f7f8d7f6973153be22b458 100644 (file)
@@ -26,7 +26,10 @@ AC_CANONICAL_BUILD
 AC_CANONICAL_HOST
 AC_CANONICAL_TARGET
 
-AM_INIT_AUTOMAKE(gnuradio,3.2svn)
+GR_VERSION
+dnl ustar required to have pathnames > 99 chars
+_AM_SET_OPTION([tar-ustar])
+AM_INIT_AUTOMAKE(gnuradio,$RELEASE)
 
 DEFINES=""
 AC_SUBST(DEFINES)
@@ -126,6 +129,20 @@ GR_FORTRAN
 GR_NO_UNDEFINED                dnl do we need the -no-undefined linker flag
 GR_SCRIPTING
 
+# Allow user to choose whether to generate SWIG/Python 
+# Default is enabled
+AC_ARG_ENABLE([python],
+  [AS_HELP_STRING([--enable-python],
+    [generate SWIG/Python components (default is yes)])],
+  [case "${enableval}" in
+     yes) enable_python=yes ;;
+     no) enable_python=no ;;
+     *) AC_MSG_ERROR([bad value ${enableval} for --enable-python]) ;;
+   esac],
+  [enable_python=yes]
+)
+AM_CONDITIONAL([PYTHON], [test x$enable_python = xyes])
+
 AC_CHECK_PROG([XMLTO],[xmlto],[yes],[])
 AM_CONDITIONAL([HAS_XMLTO], [test x$XMLTO = xyes])
 
@@ -269,9 +286,24 @@ dnl AX_BOOST_TEST_EXEC_MONITOR
 dnl AX_BOOST_UNIT_TEST_FRAMEWORK
 dnl AX_BOOST_WSERIALIZATION
 
+BUILD_DATE=`date -R -u`
+AC_SUBST(BUILD_DATE)
+
+dnl SYSCONFDIR substitution
+if test "${sysconfdir}" == "\${prefix}/etc" ; then
+   if test "${prefix}" == "NONE" ; then
+      SYSCONFDIR=["$ac_default_prefix/etc"]
+   else
+      SYSCONFDIR=["${prefix}/etc"]
+   fi
+else
+   SYSCONFDIR=[${sysconfdir}]
+fi
+AC_SUBST(SYSCONFDIR)
 
-dnl If this is being done from a subversion tree, create variables
-GR_SUBVERSION
+dnl System configuration files
+GR_PREFSDIR=[$SYSCONFDIR/${PACKAGE}/conf.d]
+AC_SUBST(GR_PREFSDIR)
 
 dnl Component specific configuration
 dnl The order of the GR_ macros determines the order of compilation
@@ -300,12 +332,13 @@ GRC_GRUEL                       dnl must come first
 GRC_OMNITHREAD                 dnl must come before gnuradio-core and mblock
 GRC_GCELL
 GRC_GNURADIO_CORE
-GRC_PMT
-GRC_MBLOCK                     dnl this must come after GRC_PMT
+GRC_MBLOCK                     dnl this must come after GRC_GRUEL
 GRC_USRP
 GRC_USRP2
+GRC_VRT
 GRC_GR_USRP                    dnl this must come after GRC_USRP
 GRC_GR_USRP2
+dnl GRC_GR_VRT
 GRC_GR_GCELL                   dnl this must come after GRC_GCELL and GRC_GNURADIO_CORE
 GRC_GR_MSDD6000        
 GRC_GR_AUDIO_ALSA
@@ -319,6 +352,7 @@ GRC_GR_COMEDI
 GRC_GR_CVSD_VOCODER
 GRC_GR_GPIO
 GRC_GR_GSM_FR_VOCODER
+GRC_GR_NOAA
 GRC_GR_PAGER
 GRC_GR_RADAR_MONO
 GRC_GR_RADIO_ASTRONOMY
@@ -327,7 +361,7 @@ GRC_GR_VIDEO_SDL
 GRC_GR_WXGUI
 GRC_GR_QTGUI
 GRC_GR_SOUNDER                 dnl this must come after GRC_USRP
-GRC_GR_UTILS                    dnl this must come after GRC_GR_WXGUI
+GRC_GR_UTILS                   dnl this must come after GRC_GR_WXGUI
 GRC_GNURADIO_EXAMPLES          dnl must come after all GRC_GR_*
 GRC_GRC
 GRC_DOCS                       dnl must be last
@@ -402,3 +436,5 @@ if test "$with_dirs" != ""; then
     echo These components will not be built.
     echo
 fi
+
+echo Configured GNU Radio release $RELEASE for build.