Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_video_sdl.m4
index 405feb0ea2016dba01e6e3f1550683874ec66f94..774f7250c8b0d69dae57c9af69363b24283174d3 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -20,20 +20,28 @@ dnl Boston, MA 02110-1301, USA.
 AC_DEFUN([GRC_GR_VIDEO_SDL],[
     GRC_ENABLE([gr-video-sdl])
 
+    dnl Don't do gr-video-sdl if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-video-sdl, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-video-sdl if the SDL library is unavailable.
+       PKG_CHECK_MODULES(SDL, sdl >= 1.2.0, [],
+          [SDL_VERSION=1.2.0
+           AM_PATH_SDL($SDL_VERSION, [], [
+             passed=no;AC_MSG_RESULT([gr-video-sdl requires library sdl, not found or failed test.])])])
+    fi
+
     AC_CONFIG_FILES([ \
-       gr-video-sdl/Makefile \
-       gr-video-sdl/src/Makefile \
-       gr-video-sdl/src/run_tests \
+        gr-video-sdl/Makefile \
+        gr-video-sdl/src/Makefile \
+        gr-video-sdl/src/run_tests \
     ])
-    
-    passed=yes
-    SDL_VERSION=1.2.0
-    AM_PATH_SDL($SDL_VERSION,[],
-        [passed=no;AC_MSG_RESULT([gr-video-sdl requires library sdl, not found or failed test.])])
 
-    GRC_BUILD_CONDITIONAL([gr-video-sdl],[
-       AC_SUBST(SDL_CFLAGS)
-       AC_SUBST(SDL_LIBS)
+    GRC_BUILD_CONDITIONAL(gr-video-sdl,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_sdl], [chmod +x gr-video-sdl/src/run_tests])
     ])