Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_radio_astronomy.m4
index 724ff8a65823c5ee9c2374ea73a4b768b240f2cb..0affe5d7856b380a81263b2ec9b3a030689c5246 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -18,18 +18,20 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_RADIO_ASTRONOMY],[
-    GRC_ENABLE([gr-radio-astronomy])
+    GRC_ENABLE(gr-radio-astronomy)
+
+    dnl Don't do gr-radio-astronomy if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-radio-astronomy, gnuradio-core)
 
     AC_CONFIG_FILES([\
-       gr-radio-astronomy/Makefile \
-       gr-radio-astronomy/src/Makefile \
-       gr-radio-astronomy/src/lib/Makefile \
-       gr-radio-astronomy/src/python/Makefile \
-       gr-radio-astronomy/src/python/run_tests \
+        gr-radio-astronomy/Makefile \
+        gr-radio-astronomy/src/Makefile \
+        gr-radio-astronomy/src/lib/Makefile \
+        gr-radio-astronomy/src/python/Makefile \
+        gr-radio-astronomy/src/python/run_tests \
     ])
 
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-radio-astronomy],[
+    GRC_BUILD_CONDITIONAL(gr-radio-astronomy,[
         dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_astronomy], [chmod +x gr-radio-astronomy/src/python/run_tests])
     ])