Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_audio_windows.m4
index 320c5d315ee5990fe720d9645b4f9aaaad60b72e..bb6244163c17eb6eb0fc78faa93cbefb7c82d1bd 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -18,21 +18,38 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_WINDOWS],[
-    GRC_ENABLE([gr-audio-windows])
+    GRC_ENABLE(gr-audio-windows)
+
+    dnl Don't do gr-audio-windows if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-windows, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        case "$host_os" in
+          cygwin*|win*|mingw*)
+            dnl Don't do gr-audio-windows if the 'winmm' library isn't available.
+            AC_HAVE_LIBRARY(winmm, [],
+                [passed=no;AC_MSG_RESULT([gr-audio-windows requires library winmm, not found.])])
+            ;;
+          *)
+            AC_MSG_RESULT([gr-audio-windows will build on a Windows Unix environment only.])
+          passed=no
+          ;;
+        esac
+    fi
 
     AC_CONFIG_FILES([ \
-       gr-audio-windows/Makefile \
-       gr-audio-windows/src/Makefile \
-       gr-audio-windows/src/run_tests \
+        gr-audio-windows/Makefile \
+        gr-audio-windows/src/Makefile \
+        gr-audio-windows/src/run_tests \
     ])
 
-    passed=yes
-    AC_HAVE_LIBRARY(winmm,[],
-        [passed=no;AC_MSG_RESULT([gr-audio-windows requires library winmm, not found.])])
-
-    GRC_BUILD_CONDITIONAL([gr-audio-windows],[
+    GRC_BUILD_CONDITIONAL(gr-audio-windows,[
        WINAUDIO_LIBS=-lwinmm
-       AC_SUBST(WINAUDIO_LIBS)
+        AC_SUBST(WINAUDIO_LIBS)
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_audio_windows], [chmod +x gr-audio-windows/src/run_tests])
     ])