Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_audio_portaudio.m4
index 31ab07aab7be8beb9419fcaf4c2ae33b3ae591e0..b2f27f2c80f54f4d2ffb9107988138e1886ca148 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -18,20 +18,28 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_PORTAUDIO],[
-    GRC_ENABLE([gr-audio-portaudio])
+    GRC_ENABLE(gr-audio-portaudio)
+
+    dnl Don't do gr-audio-portaudio if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-portaudio, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-audio-portaudio if the 'portaudio' library is unavailable.
+        PKG_CHECK_MODULES(PORTAUDIO, portaudio-2.0 >= 19,[],
+            [passed=no;AC_MSG_RESULT([gr-audio-portaudio requires package portaudio, not found.])])
+    fi
 
     AC_CONFIG_FILES([ \
-       gr-audio-portaudio/Makefile \
-       gr-audio-portaudio/src/Makefile \
-       gr-audio-portaudio/src/run_tests \
+        gr-audio-portaudio/Makefile \
+        gr-audio-portaudio/src/Makefile \
+        gr-audio-portaudio/src/run_tests \
     ])
 
-    passed=yes
-    PKG_CHECK_MODULES(PORTAUDIO, portaudio-2.0 >= 19,[],
-        [passed=no;AC_MSG_RESULT([gr-audio-portaudio requires package portaudio, not found.])])
-
-    GRC_BUILD_CONDITIONAL([gr-audio-portaudio],[
-       AC_SUBST(PORTAUDIO_LIBS)
+    GRC_BUILD_CONDITIONAL(gr-audio-portaudio,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_portaudio], [chmod +x gr-audio-portaudio/src/run_tests])
     ])