Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_audio_oss.m4
index c6d260c20be3b0d732edb448b6dc87f510450c72..6fd4577a8bad0ffa378fec1c7d6d592896162e44 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -18,31 +18,44 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_OSS],[
-    GRC_ENABLE([gr-audio-oss])    
+    GRC_ENABLE(gr-audio-oss)    
 
-    AC_CONFIG_FILES([ \
-       gr-audio-oss/Makefile \
-       gr-audio-oss/src/Makefile \
-       gr-audio-oss/src/run_tests \
-    ])
+    dnl Don't do gr-audio-oss if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-oss, gnuradio-core)
 
-    passed=yes
-    case $target in
-       *-*-netbsd*)
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Make sure the correct library and/or headers are available.
+        case $host_os in
+         netbsd*)
            AC_HAVE_LIBRARY(ossaudio,[],
                [passed=no;AC_MSG_RESULT([gr-audio-oss requires library ossaudio, not found.])])
-           if test x$passed != xno; then
+           if test $passed != no; then
                OSS_LIBS=-lossaudio
+               AC_SUBST(OSS_LIBS)
                AC_MSG_RESULT([Using OSS library $OSS_LIBS])
            fi
            ;;
-       *)
+          darwin*)
+           dnl OSX / Darwin can't use OSS
+           passed=no
+            ;;
+         *)
            AC_CHECK_HEADER(sys/soundcard.h,[],
                [passed=no;AC_MSG_RESULT([gr-audio-oss requires sys/soundcard.h, not found.])])
-    esac
+        esac
+    fi
+
+    AC_CONFIG_FILES([ \
+        gr-audio-oss/Makefile \
+        gr-audio-oss/src/Makefile \
+        gr-audio-oss/src/run_tests \
+    ])
 
-    GRC_BUILD_CONDITIONAL([gr-audio-oss],[
-       AC_SUBST(OSS_LIBS)
+    GRC_BUILD_CONDITIONAL(gr-audio-oss,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_oss], [chmod +x gr-audio-oss/src/run_tests])
     ])