Imported Upstream version 3.2.2
[debian/gnuradio] / config / grc_gr_audio_alsa.m4
index dad8c21b7e18a546ca5344069cf990d533f1cfde..9c653c1c255da8b8b302ea841efb826ceb18eaad 100644 (file)
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2008 Free Software Foundation, Inc.
 dnl 
 dnl This file is part of GNU Radio
 dnl 
@@ -18,20 +18,29 @@ dnl the Free Software Foundation, Inc., 51 Franklin Street,
 dnl Boston, MA 02110-1301, USA.
 
 AC_DEFUN([GRC_GR_AUDIO_ALSA],[
-    GRC_ENABLE([gr-audio-alsa])
+    GRC_ENABLE(gr-audio-alsa)
+
+    dnl Don't do gr-audio-alsa if gnuradio-core skipped
+    GRC_CHECK_DEPENDENCY(gr-audio-alsa, gnuradio-core)
+
+    dnl If execution gets to here, $passed will be:
+    dnl   with : if the --with code didn't error out
+    dnl   yes  : if the --enable code passed muster and all dependencies are met
+    dnl   no   : otherwise
+    if test $passed = yes; then
+        dnl Don't do gr-audio-alsa if the 'alsa' package is not installed.
+        PKG_CHECK_MODULES(ALSA, alsa >= 0.9,[],
+            [passed=no;AC_MSG_RESULT([gr-audio-alsa requires package alsa, not found.])])
+    fi
 
     AC_CONFIG_FILES([ \
-       gr-audio-alsa/Makefile \
-       gr-audio-alsa/src/Makefile \
-       gr-audio-alsa/src/run_tests \
+        gr-audio-alsa/Makefile \
+       gr-audio-alsa/gr-audio-alsa.pc \
+        gr-audio-alsa/src/Makefile \
+        gr-audio-alsa/src/run_tests \
     ])
 
-    passed=yes
-    PKG_CHECK_MODULES(ALSA, alsa >= 0.9,[],
-        [passed=no;AC_MSG_RESULT([gr-audio-alsa requires package alsa, not found.])])
-
-    GRC_BUILD_CONDITIONAL([gr-audio-alsa],[
-       AC_SUBST(ALSA_LIBS)
+    GRC_BUILD_CONDITIONAL(gr-audio-alsa,[
        dnl run_tests is created from run_tests.in.  Make it executable.
         AC_CONFIG_COMMANDS([run_tests_alsa], [chmod +x gr-audio-alsa/src/run_tests])
     ])