libvrt: remove from 3.3 API.
[debian/gnuradio] / config / Makefile.am
index 53d80708d8792a3df95c785ccab2e2704bc52751..4dc7216f1424491c2ef4883ccd456f07dc10c4f4 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2001,2006 Free Software Foundation, Inc.
+# Copyright 2001,2006,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -15,8 +15,8 @@
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
@@ -26,13 +26,30 @@ m4datadir = $(datadir)/aclocal
 
 # List your m4 macros here
 m4macros = \
+       acx_cblas.m4 \
        acx_pthread.m4 \
+       ax_boost_base.m4 \
+       ax_boost_date_time.m4 \
+       ax_boost_filesystem.m4 \
+       ax_boost_iostreams.m4 \
+       ax_boost_program_options.m4 \
+       ax_boost_python.m4 \
+       ax_boost_regex.m4 \
+       ax_boost_serialization.m4 \
+       ax_boost_signals.m4 \
+       ax_boost_system.m4 \
+       ax_boost_test_exec_monitor.m4 \
+       ax_boost_thread.m4 \
+       ax_boost_unit_test_framework.m4 \
+       ax_boost_wserialization.m4 \
        bnv_have_qt.m4 \
        cppunit.m4 \
-       gr_as.m4 \
-       gr_boost.m4 \
+       grc_build.m4 \
+       grc_docs.m4 \
+       grc_gcell.m4 \
        grc_gnuradio_core.m4 \
        grc_gnuradio_examples.m4 \
+       grc_grc.m4 \
        grc_gr_atsc.m4 \
        grc_gr_audio_alsa.m4 \
        grc_gr_audio_jack.m4 \
@@ -41,34 +58,43 @@ m4macros = \
        grc_gr_audio_portaudio.m4 \
        grc_gr_audio_windows.m4 \
        grc_gr_comedi.m4 \
-       grc_gr_error_correcting_codes.m4 \
+       grc_gr_gcell.m4 \
+       grc_gr_gpio.m4 \
        grc_gr_gsm_fr_vocoder.m4 \
-       grc_gr_radar.m4 \
+       grc_gr_noaa.m4 \
+       grc_gr_radar_mono.m4 \
        grc_gr_radio_astronomy.m4 \
+       grc_gr_sounder.m4 \
        grc_gr_trellis.m4 \
        grc_gr_usrp.m4 \
        grc_gr_video_sdl.m4 \
        grc_gr_wxgui.m4 \
+       grc_gruel.m4 \
        gr_check_createfilemapping.m4 \
        gr_check_mc4020.m4 \
        gr_check_shm_open.m4 \
        gr_check_usrp.m4 \
-       grc_pmt.m4 \
        grc_usrp.m4 \
+       grc_usrp2.m4 \
+       grc_gr_msdd6000.m4 \
        gr_doxygen.m4 \
        gr_fortran.m4 \
+       gr_gcell.m4 \
+       gr_git.m4 \
        gr_gprof.m4 \
+       gr_lib64.m4 \
        gr_libgnuradio_core_extra_ldflags.m4 \
        gr_no_undefined.m4 \
-       gr_omnithread.m4 \
        gr_pwin32.m4 \
        gr_python.m4 \
        gr_require_mc4020.m4 \
        gr_scripting.m4 \
        gr_set_md_cpu.m4 \
+       gr_standalone.m4 \
+       gr_subversion.m4 \
        gr_swig.m4 \
        gr_sysv_shm.m4 \
-       gr_x86_64.m4 \
+       gr_version.m4 \
        lf_cc.m4 \
        lf_cxx.m4 \
        lf_warnings.m4 \