libvrt: remove from 3.3 API.
[debian/gnuradio] / Makefile.common
index aa126222984adbb687375b6c3a1313b831c2ef7f..aafe85fe791d3bc5909544ece85e76598cda11b8 100644 (file)
@@ -1,12 +1,12 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
+AM_CFLAGS = @autoconf_default_CFLAGS@ @lf_CFLAGS@
+AM_CXXFLAGS = @autoconf_default_CXXFLAGS@ @lf_CXXFLAGS@
+
 # includes
-# FIXME: are these used anymore?
-grincludedir   = $(includedir)/gnuradio
+grincludedir = $(includedir)/gnuradio
 
-# swig includes 
-# FIXME: are these used anymore?
+if PYTHON
+# swig includes
 swigincludedir = $(grincludedir)/swig
 
-# Install this stuff in the appropriate subdirectory
+# Install the gnuradio stuff in the appropriate subdirectory
 # This usually ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio
 
 grpythondir = $(pythondir)/gnuradio
 grpyexecdir = $(pyexecdir)/gnuradio
 
-# swig flags
-SWIGPYTHONFLAGS = -fvirtual -python -modern
+# Install the non-gnuradio usrp stuff in the appropriate subdirectory
+# This usually ends up at:
+#   ${prefix}/lib/python${python_version}/site-packages/usrpm
 
-# Where to find gnuradio include files in the current build tree
-GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/general \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/filter \
-                    -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/io \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/omnithread \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/swig \
-                    -I$(top_builddir)/gnuradio-core/src/lib/swig \
-                   $(FFTW3F_CFLAGS)
-
-# These used to be set in PKGCONFIG but now point to the current
-# build tree.
-GNURADIO_CORE_LIBS = -L$(top_builddir)/gnuradio-core/src/lib \
-                     -lgnuradio-core -lfftw3f -lm
-
-GNURADIO_I = $(top_builddir)/gnuradio-core/src/lib/swig/gnuradio.i
-
-# The below used to be set in PKGCONFIG but now point to the current
-# build tree.
-USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
-               -I$(top_srcdir)/usrp/firmware/include
-
-USRP_LIBS = -L$(top_builddir)/usrp/host/lib \
-           -lusrp
+usrppythondir = $(pythondir)/usrpm
+usrppyexecdir = $(pyexecdir)/usrpm
+endif
+
+# gcell includes
+gcellincludedir = $(includedir)/gcell
+gcellspuincludedir = $(includedir)/gcell/spu
+
+# Cell spu libs
+libspudir = $(libdir)spu
 
 # This used to be set in configure.ac but is now defined here for all 
 # Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
+       $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
+
+# when including for compilation from pre-installed libraries and such,
+# need to make sure those are put last on the compile command
+WITH_INCLUDES = @with_INCLUDES@
+WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
+
+# Where to find gnuradio include files in the current build tree
+# top_srcdir for original stuff, top_builddir for generated files
+GNURADIO_INCLUDES = @gnuradio_core_INCLUDES@
+
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = @gnuradio_core_LA@
+
+# How to link in the USRP library from inside the tree
+GRUEL_INCLUDES = @gruel_INCLUDES@
+GRUEL_LA = @gruel_LA@
+
+# How to link in the USRP library from inside the tree
+USRP_INCLUDES = @usrp_INCLUDES@
+USRP_LA = @usrp_LA@
+
+# How to link the gcell library from inside the tree (the PPU part)
+GCELL_INCLUDES = @gcell_INCLUDES@
+GCELL_LA = @gcell_LA@
+
+# How to link the gcell library from inside the tree (the SPU part)
+GCELL_SPU_INCLUDES = @gcell_spu_INCLUDES@
+GCELL_SPU_LA = @gcell_spu_LA@
+
+# libtool aware wrapper for ppu-embedspu
+GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libtool
+
+# Fix for BSD make not defining $(RM).  We define it now in configure.ac
+# using AM_PATH_PROG, but now here have to add a -f to be like GNU make
+RM=$(RM_PROG) -f
+
+RUN_GUILE = GUILE_LOAD_PATH="@abs_top_srcdir@/gruel/src/scheme" @GUILE@ -e main -s
+
+# Base directory for example applications
+exampledir = $(datadir)/gnuradio/examples
+
+# Base directory for documentation (docdir undefined in autoconf < 1.60)
+docdir ?= $(datadir)/doc/$(PACKAGE)
+gr_docdir = $(docdir)-$(DOCVER)
+
+# System configuration files
+gr_prefsdir = $(GR_PREFSDIR)
+
+# Data directory for grc block wrappers
+grc_blocksdir = $(pkgdatadir)/grc/blocks
+
+# Other common defines; use "+=" to add to these
+STAMPS =
+MOSTLYCLEANFILES = $(BUILT_SOURCES) $(STAMPS) *.pyc *.pyo *~ *.tmp *.loT
+
+# Don't distribute the files defined in the variable 'no_dist_files'
+dist-hook:
+       @for file in $(no_dist_files); do \
+               echo $(RM) $(distdir)/$$file; \
+               $(RM) $(distdir)/$$file; \
+       done;