Fixing benchmark program to work with original dbpsk/dqpsk modulations again (and...
[debian/gnuradio] / Makefile.common
index 2976e36dcd7b420f89240df7a19febc742ed2c6b..64891345ba778b99600d6b7e2620b6beb9df2068 100644 (file)
@@ -1,6 +1,6 @@
 # -*- Makefile -*-
 #
-# Copyright 2004,2006,2007 Free Software Foundation, Inc.
+# Copyright 2004,2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # Boston, MA 02110-1301, USA.
 # 
 
-AM_CXXFLAGS = @autoconf_default_CXXFLAGS@
+AM_CFLAGS = @autoconf_default_CFLAGS@ @lf_CFLAGS@
+AM_CXXFLAGS = @autoconf_default_CXXFLAGS@ @lf_CXXFLAGS@
 
 # includes
-grincludedir   = $(includedir)/gnuradio
+grincludedir = $(includedir)/gnuradio
 
-# swig includes 
+if PYTHON
+# swig includes
 swigincludedir = $(grincludedir)/swig
 
 # Install the gnuradio stuff in the appropriate subdirectory
@@ -41,61 +43,86 @@ grpyexecdir = $(pyexecdir)/gnuradio
 
 usrppythondir = $(pythondir)/usrpm
 usrppyexecdir = $(pyexecdir)/usrpm
+endif
 
+# gcell includes
+gcellincludedir = $(includedir)/gcell
+gcellspuincludedir = $(includedir)/gcell/spu
 
-# swig flags
-SWIGPYTHONFLAGS = -fvirtual -python -modern
+# Cell spu libs
+libspudir = $(libdir)spu
 
-# Where to find gnuradio include files in the current build tree
-# top_srcdir for original stuff, top_builddir for generated files
-GNURADIO_INCLUDES = -I$(top_srcdir)/gnuradio-core/src/lib/runtime \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/general \
-                   -I$(top_builddir)/gnuradio-core/src/lib/general \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/gengen \
-                   -I$(top_builddir)/gnuradio-core/src/lib/gengen \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/filter \
-                   -I$(top_builddir)/gnuradio-core/src/lib/filter \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/reed-solomon \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/io \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/g72x \
-                   -I$(top_srcdir)/gnuradio-core/src/lib/swig \
-                   -I$(top_builddir)/gnuradio-core/src/lib/swig \
-                   $(FFTW3F_CFLAGS)
+# This used to be set in configure.ac but is now defined here for all 
+# Makefiles when this fragment is included.
+STD_DEFINES_AND_INCLUDES = $(DEFINES) $(BOOST_CPPFLAGS) \
+       $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(GRUEL_INCLUDES)
+
+# when including for compilation from pre-installed libraries and such,
+# need to make sure those are put last on the compile command
+WITH_INCLUDES = @with_INCLUDES@
+WITH_SWIG_INCLUDES = @with_SWIG_INCLUDES@
 
 # How to link in the top-level omnithreads library from inside the tree
-OMNITHREAD_INCLUDES = -I$(top_srcdir)/omnithread
-OMNITHREAD_LA = $(top_builddir)/omnithread/libgromnithread.la
+OMNITHREAD_INCLUDES = @omnithread_INCLUDES@
+OMNITHREAD_LA = @omnithread_LA@
 
-# How to link in GNU Radio core library from inside the tree
-GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
+# Where to find gnuradio include files in the current build tree
+# top_srcdir for original stuff, top_builddir for generated files
+GNURADIO_INCLUDES = @gnuradio_core_INCLUDES@
 
-# This is a dependency for many swig operations
-GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+# How to link in GNU Radio core library from inside the tree
+GNURADIO_CORE_LA = @gnuradio_core_LA@
 
 # How to link in the USRP library from inside the tree
-USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib/legacy \
-               -I$(top_srcdir)/usrp/host/lib/inband \
-               -I$(top_srcdir)/usrp/firmware/include
-USRP_LA = $(top_builddir)/usrp/host/lib/legacy/libusrp.la
+GRUEL_INCLUDES = @gruel_INCLUDES@
+GRUEL_LA = @gruel_LA@
 
-# How to link the PMT library from inside the tree
-PMT_INCLUDES = -I$(top_srcdir)/pmt/src/lib
-PMT_LA = $(top_builddir)/pmt/src/lib/libpmt.la
+# How to link in the USRP library from inside the tree
+USRP_INCLUDES = @usrp_INCLUDES@
+USRP_LA = @usrp_LA@
 
 # How to link the mblock library from inside the tree
-MBLOCK_INCLUDES = -I$(top_srcdir)/mblock/src/lib
-MBLOCK_LA = $(top_builddir)/mblock/src/lib/libmblock.la
+MBLOCK_INCLUDES = @mblock_INCLUDES@
+MBLOCK_LA = @mblock_LA@
 
-# This used to be set in configure.ac but is now defined here for all 
-# Makefiles when this fragment is included.
-STD_DEFINES_AND_INCLUDES=$(DEFINES) $(OMNITHREAD_INCLUDES) $(GNURADIO_INCLUDES) $(BOOST_CFLAGS)
+# How to link the gcell library from inside the tree (the PPU part)
+GCELL_INCLUDES = @gcell_INCLUDES@
+GCELL_LA = @gcell_LA@
+
+# How to link the gcell library from inside the tree (the SPU part)
+GCELL_SPU_INCLUDES = @gcell_spu_INCLUDES@
+GCELL_SPU_LA = @gcell_spu_LA@
+
+# libtool aware wrapper for ppu-embedspu
+GCELL_EMBEDSPU_LIBTOOL = @abs_top_srcdir@/gcell/lib/runtime/gcell-embedspu-libtool
 
 # Fix for BSD make not defining $(RM).  We define it now in configure.ac
 # using AM_PATH_PROG, but now here have to add a -f to be like GNU make
 RM=$(RM_PROG) -f
 
-RUN_GUILE = GUILE_LOAD_PATH="@abs_top_srcdir@/pmt/src/scheme:@abs_top_srcdir@/mblock/src/scheme" @GUILE@ -e main -s
+RUN_GUILE = GUILE_LOAD_PATH="@abs_top_srcdir@/gruel/src/scheme:@abs_top_srcdir@/mblock/src/scheme" @GUILE@ -e main -s
 COMPILE_MBH = $(RUN_GUILE) $(top_srcdir)/mblock/src/scheme/gnuradio/compile-mbh.scm
 
 # Base directory for example applications
 exampledir = $(datadir)/gnuradio/examples
+
+# Base directory for documentation (docdir undefined in autoconf < 1.60)
+docdir ?= $(datadir)/doc/$(PACKAGE)
+gr_docdir = $(docdir)-$(DOCVER)
+
+# System configuration files
+gr_prefsdir = $(GR_PREFSDIR)
+
+# Data directory for grc block wrappers
+grc_blocksdir = $(pkgdatadir)/grc/blocks
+
+# Other common defines; use "+=" to add to these
+STAMPS =
+MOSTLYCLEANFILES = $(BUILT_SOURCES) $(STAMPS) *.pyc *.pyo *~ *.tmp *.loT
+
+# Don't distribute the files defined in the variable 'no_dist_files'
+dist-hook:
+       @for file in $(no_dist_files); do \
+               echo $(RM) $(distdir)/$$file; \
+               $(RM) $(distdir)/$$file; \
+       done;