Simple code cleanup.
[debian/gnuradio] / Makefile.am
index e9dde45f1b327b6abdf1d8a12e6c37454361342e..084fb5dc16312c88c7efa134495fbe787b562676 100644 (file)
@@ -28,7 +28,26 @@ EXTRA_DIST = \
        configure \
        configure-cell-cross \
        config.h.in \
-       run_tests.sh.in
+       run_tests.sh.in \
+       Makefile.swig \
+       Makefile.swig.gen.t \
+       Makefile.par.gen \
+       Makefile.gen.gen \
+       version.sh
 
 SUBDIRS = @build_dirs@
 DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+DISTCLEANFILES = gnuradio*.tar.gz
+
+if PYTHON
+
+export pythondir
+
+install-data-hook:
+       @if ! python -c "import gnuradio" > /dev/null 2>&1; then\
+               printf "\n*** Post-Install Message ***\
+               \nWarning: python could not find the gnuradio module.\
+               \nMake sure that $${pythondir} is in your PYTHONPATH\n\n";\
+       fi
+
+endif