Move initialization of select timeout
[debian/gnuradio] / Makefile.am
index e8328c263963e6e5b043138246b751af6484cb9e..084fb5dc16312c88c7efa134495fbe787b562676 100644 (file)
@@ -33,7 +33,21 @@ EXTRA_DIST = \
        Makefile.swig.gen.t \
        Makefile.par.gen \
        Makefile.gen.gen \
-       debian/changelog
+       version.sh
 
 SUBDIRS = @build_dirs@
 DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+DISTCLEANFILES = gnuradio*.tar.gz
+
+if PYTHON
+
+export pythondir
+
+install-data-hook:
+       @if ! python -c "import gnuradio" > /dev/null 2>&1; then\
+               printf "\n*** Post-Install Message ***\
+               \nWarning: python could not find the gnuradio module.\
+               \nMake sure that $${pythondir} is in your PYTHONPATH\n\n";\
+       fi
+
+endif