Fix erroneous file modes
[debian/gnuradio] / Makefile.am
index bd8ea006e31239672a56a0602b2eb3397a419fb9..084fb5dc16312c88c7efa134495fbe787b562676 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2001,2006 Free Software Foundation, Inc.
+# Copyright 2001,2006,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -26,9 +26,28 @@ include $(top_srcdir)/Makefile.common
 EXTRA_DIST = \
        bootstrap \
        configure \
+       configure-cell-cross \
        config.h.in \
        run_tests.sh.in \
-       README.hacking
+       Makefile.swig \
+       Makefile.swig.gen.t \
+       Makefile.par.gen \
+       Makefile.gen.gen \
+       version.sh
 
 SUBDIRS = @build_dirs@
-DIST_SUBDIRS = @build_dirs@ @skipped_dirs@
+DIST_SUBDIRS = @build_dirs@ @skipped_dirs@ @with_dirs@
+DISTCLEANFILES = gnuradio*.tar.gz
+
+if PYTHON
+
+export pythondir
+
+install-data-hook:
+       @if ! python -c "import gnuradio" > /dev/null 2>&1; then\
+               printf "\n*** Post-Install Message ***\
+               \nWarning: python could not find the gnuradio module.\
+               \nMake sure that $${pythondir} is in your PYTHONPATH\n\n";\
+       fi
+
+endif