upstream fix for dumping files with leading zeros correctly
authorBdale Garbee <bdale@gag.com>
Wed, 4 May 2011 15:56:58 +0000 (09:56 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 4 May 2011 15:56:58 +0000 (09:56 -0600)
debian/changelog
dump/traverse.c

index f194b77d4b3b337a13a9cf96990d9031b3492aa5..fc65f924859f2cb546af69ce7f3eb1da9fa8856c 100644 (file)
@@ -1,8 +1,10 @@
 dump (0.4b43-2) UNRELEASED; urgency=low
 
+  * fix from upstream for problem dumping files with leading zeros correctly,
+    closes: #614068
   * add Vcs entries to the control file
 
- -- Bdale Garbee <bdale@gag.com>  Thu, 11 Nov 2010 18:01:46 -0700
+ -- Bdale Garbee <bdale@gag.com>  Wed, 04 May 2011 09:56:42 -0600
 
 dump (0.4b43-1) unstable; urgency=low
 
index 6ed1d287f3d572cbb7ec7f08cc4538ba9f36bc9e..7450765263b16bf1ca7237cf70b4bc5780040192 100644 (file)
@@ -992,7 +992,7 @@ dumpino(struct dinode *dp, dump_ino_t ino, int metaonly)
        bc.buf = (int *)malloc (bc.max * sizeof (int));
        bc.cnt = 0;
        bc.ino = ino;
-       bc.next_block = NDADDR;
+       bc.next_block = 0;
 
        ext2fs_block_iterate2(fs, (ext2_ino_t)ino, BLOCK_FLAG_DATA_ONLY, NULL, dumponeblock, (void *)&bc);
        /* deal with holes at the end of the inode */