Fixes ticket 17.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 8 Aug 2006 01:09:07 +0000 (01:09 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 8 Aug 2006 01:09:07 +0000 (01:09 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3221 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_gr_wxgui.m4

index 2713f9b0801afe0d262a1c1124bdaf7422e750a4..f48fb2ab7dd3c36ba62c8177ebfdf8b660be52eb 100644 (file)
@@ -20,16 +20,15 @@ dnl Boston, MA 02111-1307, USA.
 AC_DEFUN([GRC_GR_WXGUI],[
     AC_CONFIG_SRCDIR([gr-wxgui/src/python/stdgui.py])
 
-    # FIXME: Should we actually check for wxPython, even though
-    # this is a runtime requirement, not a compile/install time one?
-    #
-    # This is logged as ticket 17
-    
     AC_CONFIG_FILES([ \
          gr-wxgui/Makefile \
          gr-wxgui/src/Makefile \
          gr-wxgui/src/python/Makefile \
     ])
 
-    subdirs="$subdirs gr-wxgui"
+    if python -c 'import wx'; then
+       subdirs="$subdirs gr-wxgui"
+    else
+       failed="$failed gr-wxgui"
+    fi
 ])