believed to have fixed ticket:7
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 5 Aug 2006 03:03:37 +0000 (03:03 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Sat, 5 Aug 2006 03:03:37 +0000 (03:03 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3163 221aa14e-8319-0410-a670-987f0aec2ac5

configure.ac
gr-radar/src/lib/sim-airplane.cc

index 68e8837c5ce0a22e4e77fb8af9d360d1970f5059..810282a37ff37948e16546a39fc0d6258418ddd3 100644 (file)
@@ -90,6 +90,8 @@ AC_CHECK_LIB(m, sincosf,[AC_DEFINE([HAVE_SINCOSF],[1],[Define to 1 if your syste
 AC_CHECK_LIB(m, sinf, [AC_DEFINE([HAVE_SINF],[1],[Define to 1 if your system has `sinf'.])])
 AC_CHECK_LIB(m, cosf, [AC_DEFINE([HAVE_COSF],[1],[Define to 1 if your system has `cosf'.])])
 AC_CHECK_LIB(m, trunc, [AC_DEFINE([HAVE_TRUNC],[1],[Define to 1 if your system has `trunc'.])])
+AC_CHECK_LIB(m, exp10, [AC_DEFINE([HAVE_EXP10],[1],[Define to 1 if your system has 'exp10'.])])
+
 AH_BOTTOM([
 #ifndef HAVE_TRUNC
 #include <math.h>
@@ -98,6 +100,14 @@ inline static double trunc(double x)
   return x >= 0 ? floor(x) : ceil(x);
 }
 #endif
+
+#ifndef HAVE_EXP10
+#include <math.h>
+inline static double exp10(double x)
+{
+  return pow(10.0, x);
+}
+#endif
 ])
 
 GR_CHECK_SHM_OPEN
index 9b27ff009761c1c1ccdc65cb238801a2002e0997..99ee9cca6ca40ee9837605dba9ed9cb22f7f38be 100644 (file)
@@ -24,6 +24,9 @@
 #define _GNU_SOURCE
 #endif
 
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
 #include <iostream>
 #include <string>
 #include <fstream>