changes to build on windows / cygwin
authorU-CERVELO\ttsou <ttsou@CERVELO.(none)>
Fri, 11 Sep 2009 19:35:28 +0000 (15:35 -0400)
committerttsou <ttsou@vt.edu>
Wed, 16 Sep 2009 21:08:52 +0000 (17:08 -0400)
usrp/host/lib/Makefile.am
usrp/host/lib/fusb.cc
usrp/host/lib/fusb.h
usrp/host/lib/fusb_sysconfig_win32.cc
usrp/host/lib/fusb_win32.cc
usrp/host/lib/usrp_basic_common.cc
usrp/host/lib/usrp_basic_libusb.cc

index 4dd47595e942ba56e4c26d483473855998b46d92..7c5dc25a5c8d1573f82f001e817145598f80273f 100644 (file)
@@ -74,7 +74,10 @@ darwin_CODE =                                \
 
 win32_CODE =                           \
        fusb_win32.cc                   \
-       fusb_sysconfig_win32.cc         
+       fusb_sysconfig_win32.cc         \
+       usrp_prims_libusb.cc            \
+       usrp_basic_libusb.cc
+
 
 linux_CODE =                           \
        fusb_linux.cc                   \
index ce4bb7aa9a9ce2c9793add0e1281d159aadd06af..0bd9ded59e6d0397801fcf3e2bcc865c2340e7fb 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
+//#ifdef HAVE_CONFIG_H
+//#include "config.h"
+//#endif
 
 #include <fusb.h>
 
index 00bdffcc017a98631b4f553fa198e2a853b85733..341e570a431a92b676163e5176ab7c54ffb0dea2 100644 (file)
@@ -65,7 +65,7 @@ public:
                                        int block_size = 0, int nblocks = 0) = 0;
   
   // ACCESSORS
-  libusb_device_handle *get_libusb_device_handle () const { return d_udh; }
+  libusb_device_handle *get_usb_dev_handle () const { return d_udh; }
 };
 
 
index 16eaaa645d4e2b7b704019bc223f1458135d5aa4..a0d1405431ffdb9fe337807ea5871bad5074eecb 100644 (file)
@@ -27,7 +27,7 @@ static const int MAX_BLOCK_SIZE = 64 * 1024;          // Windows kernel hard limit
 static const int FUSB_BUFFER_SIZE = 2 * (1L << 20);    // 2 MB
        
 fusb_devhandle *
-fusb_sysconfig::make_devhandle (usb_dev_handle *udh)
+fusb_sysconfig::make_devhandle (usb_dev_handle *udh, libusb_context *ctx)
 {
   return new fusb_devhandle_win32 (udh);
 }
index 8900576d93b7d4a8b1777992f4c8f1bac40e13fa..7b11bb9198f2ab2ee2be92ef5d8976ae1da48bd9 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
+//#ifdef HAVE_CONFIG_H
+//#include "config.h"
+//#endif
 
 #include <fusb_win32.h>
 #include <usb.h>
index 79e5b07ec12fe4f78348dc783490ffd522c74a2f..ad1eca56d254e300e6de05677d93e84d058548af 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
+//#ifdef HAVE_CONFIG_H
+//#include "config.h"
+//#endif
 
 #include "usrp/usrp_basic.h"
 #include "usrp/usrp_prims.h"
index c788cc054764b1fddd9d6a3a7b7c836ae3acfc5a..c4842cac92ba540e71ef6cb0fc62c9c34cde62a9 100644 (file)
@@ -20,9 +20,9 @@
  * Boston, MA 02110-1301, USA.
  */
 
-#ifdef HAVE_CONFIG_H
-#include "config.h"
-#endif
+//#ifdef HAVE_CONFIG_H
+//#include "config.h"
+//#endif
 
 #include <usrp/usrp_basic.h>
 #include "usrp/usrp_prims.h"