fixed ticket #65
authoranastas <anastas@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 14 Sep 2006 15:09:03 +0000 (15:09 +0000)
committeranastas <anastas@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 14 Sep 2006 15:09:03 +0000 (15:09 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3540 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_gnuradio_examples.m4
gnuradio-examples/python/channel-coding/Makefile.am
gnuradio-examples/python/channel-coding/README
gnuradio-examples/python/channel-coding/fsm_files/Makefile.am [new file with mode: 0644]
gr-trellis/doc/Makefile.am
gr-trellis/doc/test_viterbi_equalization1.py.xml

index 6ab8e899e4ced40af41c01515dc6c21fad6a3a3e..910da5877c1d340f0174535696e22c1a60b7f958 100644 (file)
@@ -25,6 +25,7 @@ AC_DEFUN([GRC_GNURADIO_EXAMPLES],[
         gnuradio-examples/python/Makefile \
         gnuradio-examples/python/audio/Makefile \
         gnuradio-examples/python/channel-coding/Makefile \
+        gnuradio-examples/python/channel-coding/fsm_files/Makefile \
         gnuradio-examples/python/digital_voice/Makefile \
         gnuradio-examples/python/gmsk2/Makefile \
         gnuradio-examples/python/mc4020/Makefile \
index aa24e7070e9fc6f2da42372d945b12c44fc6c09e..0000ba08b075ce83fbf0ecb614af429ba6784a3e 100644 (file)
@@ -24,8 +24,18 @@ EXTRA_DIST =                 \
        fsm_utils.py            \
        test_tcm.py             \
        test_tcm1.py            \
+       test_tcm2.py            \
        test_tcm_parallel.py    \
        test_tcm_combined.py    \
-       test_sccc_hard.py
+       test_sccc_hard.py       \
+       test_sccc_soft.py       \
+       test_sccc_turbo.py      \
+       test_viterbi_equalization1.py   \
+       test_viterbi_equalization.py    \
+       test_turbo_equalization.py      \
+       test_turbo_equalization1.py     \
+       test_turbo_equalization2.py     
+
+SUBDIRS = fsm_files
 
 MOSTLYCLEANFILES = *.pyc
index 7f25b697bc38a31430cf4bdcab75a86599303ad6..13968304a307cf4ec967743fbd049fba5beaa367 100644 (file)
@@ -20,6 +20,8 @@ If you just want to see what these programs do, run each of the following:
 
 ./test_viterbi_equalization.py  12.0 100
 ./test_viterbi_equalization1.py 12.0 100
+./test_turbo_equalization1.py fsm_files/awgn1o2_4.fsm 8.0 100
+./test_turbo_equalization2.py fsm_files/awgn1o2_4.fsm 8.0 100
 
 
 In your terminal you will see something like this:
diff --git a/gnuradio-examples/python/channel-coding/fsm_files/Makefile.am b/gnuradio-examples/python/channel-coding/fsm_files/Makefile.am
new file mode 100644 (file)
index 0000000..953752a
--- /dev/null
@@ -0,0 +1,37 @@
+#
+# Copyright 2004 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+EXTRA_DIST =                   \
+       awgn1o2_128.fsm         \
+       awgn1o2_16.fsm          \
+       awgn1o2_4.fsm           \
+       awgn1o2_8.fsm           \
+       awgn2o3_16.fsm          \
+       awgn2o3_4.fsm           \
+       awgn2o3_4_msb.fsm       \
+       awgn2o3_4_msbG.fsm      \
+       awgn2o3_8.fsm           \
+       awgn2o4_4.fsm           \
+       disconnected.fsm        \
+       rep3.fsm                \
+       rep5.fsm                \
+       simple.fsm              
+
index 21cd57106c2e971c94245ad57afe772e92395573..e042a159571992390f63fd7d63df0e849aa6ff8d 100644 (file)
@@ -34,7 +34,9 @@ EXTRA_DIST = \
     gr-trellis.xml \
     make_numbered_listing.py \
     test_tcm.py \
-    test_tcm.py.xml
+    test_tcm.py.xml \
+    test_viterbi_equalization1.py \
+    test_viterbi_equalization1.py.xml
 
 BUILT_XML_FILES =                      
 
@@ -61,4 +63,4 @@ uninstall-local:
        $(RM) -fr $(DESTDIR)$(docdir)/html
 
 clean-local:
-       $(RM) -fr $(HTML_FILES) *~
\ No newline at end of file
+       $(RM) -fr $(HTML_FILES) *~
index cb13772fcca8288c549176d93c3b364de74fd9e4..4ea83be9937dd2b96096913c425990e77a918de8 100644 (file)
@@ -35,7 +35,7 @@
  33      # RX
  34      skip = gr.skiphead(gr.sizeof_float, L) # skip the first L samples since you know they are coming from the L zero symbols
  35      #metrics = trellis.metrics_f(f.O(),dimensionality,tot_constellation,trellis.TRELLIS_EUCLIDEAN) # data preprocessing to generate metrics for Viterbi
- 36      #va = trellis.viterbi_s(f,K+L,-1,0) # Put -1 if the Initial/Final states are not set.
+ 36      #va = trellis.viterbi_s(f,K+L,0,0) # Put -1 if the Initial/Final states are not set.
  37      va = trellis.viterbi_combined_s(f,K+L,0,0,dimensionality,tot_constellation,trellis.TRELLIS_EUCLIDEAN) # using viterbi_combined_s instead of metrics_f/viterbi_s allows larger packet lengths because metrics_f is complaining for not being able to allocate large buffers. This is due to the large f.O() in this application...
  38      dst = gr.vector_sink_s()
  39