Removing ifs to clean up build system. Make no longer rebuilds gr-qtgui if no changes...
authorTom <trondeau@vt.edu>
Wed, 14 Oct 2009 02:46:51 +0000 (22:46 -0400)
committerTom <trondeau@vt.edu>
Wed, 14 Oct 2009 02:46:51 +0000 (22:46 -0400)
config/grc_gr_qtgui.m4
gr-qtgui/src/lib/Makefile.am

index d9700776cae2fc994f2e954ff06093fafdc632e9..84514d7ce9ad9f18091cc8f66201a336489737f1 100644 (file)
@@ -86,12 +86,6 @@ AC_DEFUN([GRC_GR_QTGUI],[
        AC_SUBST(QT_UIC_EXEC)
     fi
 
-    if test "$passed" = "no"; then
-        AM_CONDITIONAL(BUILD_QT, false)
-    else
-       AM_CONDITIONAL(BUILD_QT, true)
-    fi
-
     AC_CONFIG_FILES([ \
         gr-qtgui/Makefile \
         gr-qtgui/src/Makefile \
index b6c8f3f4d0a0e611a72aefe8ea0054102282ea3a..6c90c31f0f946687b15ceb65ae79d721de794ec6 100644 (file)
@@ -26,7 +26,6 @@ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
 
 # Only include these files in the build if qtgui passes configure checks
 # This is mostly to help make distcheck pass
-if BUILD_QT
 QMAKE_SOURCES =                                \
        spectrumdisplayform_moc.cc              \
        FrequencyDisplayPlot_moc.cc             \
@@ -35,7 +34,6 @@ QMAKE_SOURCES =                               \
        Waterfall3DDisplayPlot_moc.cc           \
        ConstellationDisplayPlot_moc.cc         \
        spectrumdisplayform_ui.h
-endif
 
 EXTRA_DIST = spectrumdisplayform.ui
 
@@ -77,19 +75,11 @@ grinclude_HEADERS =                 \
        qtgui_sink_c.h                  \
        qtgui_sink_f.h
 
-if BUILD_QT
 %_moc.cc : %.h
        $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@
 
 %_ui.h : %.ui
        $(QT_UIC_EXEC) $< -o $@
-else
-%_moc.cc : %.h
-       touch $@
-
-%_ui.h : %.ui
-       touch $@
-endif
 
 # magic flags
 libgnuradio_qtgui_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0