Better fix for broken AC_PROG_F77 macro
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 4 Sep 2009 00:12:40 +0000 (17:12 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Fri, 4 Sep 2009 00:12:40 +0000 (17:12 -0700)
* Move AC_PROG_CC into GR_FORTRAN macro definition

config/gr_fortran.m4
configure.ac

index b5b0470f45c2ce78cb525490bf56d32b0548f140..a558b2f7e3f00eaecddd39bc5248a0ece883c543 100644 (file)
@@ -28,5 +28,6 @@ AC_DEFUN([GR_FORTRAN],[
     then
         AC_PROG_F77
         AC_F77_LIBRARY_LDFLAGS
+       AC_PROG_CC dnl bux fix to restore $ac_ext
     fi
 ])
index 4b90b723cff4664f21d02b904d68011e6783d56f..2bb37935e9a4cb1ef10b664c6a1463f13368a064 100644 (file)
@@ -125,7 +125,6 @@ AC_ENABLE_SHARED    dnl do build shared libraries
 AC_DISABLE_STATIC      dnl don't build static libraries
 m4_ifdef([LT_INIT],[LT_INIT],[AC_PROG_LIBTOOL])
 GR_FORTRAN
-AC_PROG_CC             dnl ensure $ac_ext set correctly after Fortran test
 
 GR_NO_UNDEFINED                dnl do we need the -no-undefined linker flag
 GR_SCRIPTING