Changes so that OSX's FUSB will use gr's omnithreads instead of pthreads.
authormichaelld <michaelld@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 17 Aug 2007 20:34:21 +0000 (20:34 +0000)
committermichaelld <michaelld@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 17 Aug 2007 20:34:21 +0000 (20:34 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6149 221aa14e-8319-0410-a670-987f0aec2ac5

usrp/host/lib/legacy/Makefile.am
usrp/host/lib/legacy/fusb_darwin.cc
usrp/host/lib/legacy/mld_threads.h

index 4917449a273841b8182bee5cc99c97fa5f91b432..3dd10bf1cdc5846da33d36d1ff8470ab4e930942 100644 (file)
@@ -20,7 +20,7 @@
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES = $(USRP_INCLUDES)
+INCLUDES = $(USRP_INCLUDES) $(OMNITHREAD_INCLUDES)
 
 lib_LTLIBRARIES = libusrp.la
 
index c6127e26e68fafa65be22f695b88a5d9b96199e7..61fe2257960092da86fffa0bd2654f17bda64d26 100644 (file)
@@ -26,7 +26,7 @@
 
 // tell mld_threads to NOT use omni_threads,
 // but rather Darwin's pthreads
-#undef _USE_OMNI_THREADS_
+#define _USE_OMNI_THREADS_
 
 #include <usb.h>
 #include "fusb.h"
index 1653e83ebda4b8894f06c9709ad98caaa76ce625..6e60e8837eb5a65ad894765d2244b34d11a43b79 100644 (file)
@@ -27,8 +27,9 @@
 
 /* classes which allow for either pthreads or omni_threads */
 
+#define __macos__
 #ifdef _USE_OMNI_THREADS_
-#include <gnuradio/omnithread.h>
+#include <omnithread.h>
 #else
 #include <pthread.h>
 #endif