now reads h/w rev from eeprom. f/w app set_hw_rev sets it
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 10 Sep 2008 23:50:19 +0000 (23:50 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Wed, 10 Sep 2008 23:50:19 +0000 (23:50 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@9554 221aa14e-8319-0410-a670-987f0aec2ac5

usrp2/firmware/apps/Makefile.am
usrp2/firmware/apps/app_common_v2.c
usrp2/firmware/apps/set_hw_rev.c [new file with mode: 0644]
usrp2/firmware/lib/u2_init.c
usrp2/firmware/lib/u2_init.h

index 092dd94414a40520fe5f9cf2b5d76a8f8b6da64f..c538c6e95297a81fc70d36bb2c91a8bdd3a8d0c6 100644 (file)
@@ -33,6 +33,7 @@ noinst_PROGRAMS = \
        rcv_eth_packets \
        rx_only_v2 \
        read_dbids \
+       set_hw_rev \
        test1 \
        test_db_spi \
        test_i2c \
index 4dc254f8555ee383a3e534579c2acfb1de4ca982..e267401a96ea3b5385ff541726d528d926249cd0 100644 (file)
@@ -28,6 +28,7 @@
 #include "print_rmon_regs.h"
 #include "db.h"
 #include "clocks.h"
+#include "u2_init.h"
 #include <string.h>
 
 volatile bool link_is_up = false;      // eth handler sets this
@@ -117,7 +118,7 @@ op_id_cmd(const op_generic_t *p,
   r->len = sizeof(op_id_reply_t);
   r->rid = p->rid;
   r->addr = *ethernet_mac_addr();
-  r->hw_rev = 0x0000;  // FIXME
+  r->hw_rev = (u2_hw_rev_major << 8) | u2_hw_rev_minor;
   // r->fpga_md5sum = ;        // FIXME
   // r->sw_md5sum = ;  // FIXME
 
diff --git a/usrp2/firmware/apps/set_hw_rev.c b/usrp2/firmware/apps/set_hw_rev.c
new file mode 100644 (file)
index 0000000..0d7adbd
--- /dev/null
@@ -0,0 +1,43 @@
+/* -*- c++ -*- */
+/*
+ * Copyright 2008 Free Software Foundation, Inc.
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 3 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program.  If not, see <http://www.gnu.org/licenses/>.
+ */
+#include <u2_init.h>
+#include <nonstdio.h>
+#include <i2c.h>
+#include <usrp2_i2c_addr.h>
+
+#define HW_REV_MAJOR 0
+#define HW_REV_MINOR 3
+
+int
+main(void)
+{
+  u2_init();
+
+  putstr("\nset_hw_rev\n");
+
+  bool ok = true;
+  unsigned char maj = HW_REV_MAJOR;
+  unsigned char min = HW_REV_MINOR;
+  ok = eeprom_write(I2C_ADDR_MBOARD, MBOARD_REV_MSB, &maj, 1);
+  ok &= eeprom_write(I2C_ADDR_MBOARD, MBOARD_REV_LSB, &min, 1);
+
+  if (ok)
+    printf("OK: set h/w rev to %d.%d\n", HW_REV_MAJOR, HW_REV_MINOR);
+  else
+    printf("FAILED to set h/w rev to %d.%d\n", HW_REV_MAJOR, HW_REV_MINOR);
+}
index cb4b679c497b2b821df270ceba71c69e6b092733..8ecba349765f42f9a70bbe3be528860e3c7bb0b5 100644 (file)
 #include "ad9777.h"
 #include "clocks.h"
 #include "db.h"
+#include "usrp2_i2c_addr.h"
 
 //#include "nonstdio.h"
 
+unsigned char u2_hw_rev_major;
+unsigned char u2_hw_rev_minor;
+
+static inline void
+get_hw_rev(void)
+{
+  bool ok = eeprom_read(I2C_ADDR_MBOARD, MBOARD_REV_LSB, &u2_hw_rev_minor, 1);
+  ok &= eeprom_read(I2C_ADDR_MBOARD, MBOARD_REV_MSB, &u2_hw_rev_major, 1);
+}
+
+
 /*
  * We ought to arrange for this to be called before main, but for now,
  * we require that the user's main call u2_init as the first thing...
@@ -85,6 +97,8 @@ u2_init(void)
   lsdac_init();            // low-speed DACs
   db_init();       // daughterboard init
   
+  get_hw_rev();
+
   hal_enable_ints();
 
   // flash all leds to let us know board is alive
index 901e61250e606a6daac4ea8b286845582cbc6ba2..91654dac838237a7d908f31f7ef9e0954866a51d 100644 (file)
@@ -18,6 +18,9 @@
 #ifndef INCLUDED_U2_INIT_H
 #define INCLUDED_U2_INIT_H
 
+extern unsigned char u2_hw_rev_major;
+extern unsigned char u2_hw_rev_minor;
+
 /*!
  * one-time init
  */