Exporting qt-based examples to installed examples folder and fixed a minor issue...
authortrondeau <trondeau@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 18 Jun 2009 12:12:56 +0000 (12:12 +0000)
committertrondeau <trondeau@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 18 Jun 2009 12:12:56 +0000 (12:12 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11231 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-examples/python/digital/Makefile.am
gnuradio-examples/python/digital/benchmark_qt_loopback.py
gnuradio-examples/python/digital/qt_digital_window.py [new file with mode: 0644]

index 04457c6fc0819f87d5e1ec1dab91ee1c94fc6e85..95992a1693882fc4ae41bc37c25b2ad0d5a39e87 100644 (file)
@@ -37,6 +37,10 @@ dist_ourdata_SCRIPTS =               \
        benchmark_tx.py         \
        benchmark_qt_rx.py      \
        benchmark_qt_loopback.py\
+       qt_digital_window.ui    \
+       qt_digital_window.py    \
+       qt_rx_window.ui         \
+       qt_rx_window.py         \
        gen_whitener.py         \
        rx_voice.py             \
        run_length.py           \
index 0936b42bbb3b9e55aa787c578a7372336f4cd014..3fd76fdf95f29cb90012709290eaa8465ff03bbd 100755 (executable)
@@ -235,7 +235,7 @@ class my_top_block(gr.top_block):
                                            -1/2, 1/2,
                                            "Rx", True, True, False, True, True)
 
-                self.snk_tx.set_frequency_axis(0, 80)
+                self.snk_tx.set_frequency_axis(-80, 0)
                 self.snk_rx.set_frequency_axis(-60, 20)
             
                 # Connect to the QT sinks
diff --git a/gnuradio-examples/python/digital/qt_digital_window.py b/gnuradio-examples/python/digital/qt_digital_window.py
new file mode 100644 (file)
index 0000000..5e88859
--- /dev/null
@@ -0,0 +1,142 @@
+# -*- coding: utf-8 -*-
+
+# Form implementation generated from reading ui file 'qt_digital_window.ui'
+#
+# Created: Thu Jun 18 08:08:38 2009
+#      by: PyQt4 UI code generator 4.4.3
+#
+# WARNING! All changes made in this file will be lost!
+
+from PyQt4 import QtCore, QtGui
+
+class Ui_DigitalWindow(object):
+    def setupUi(self, DigitalWindow):
+        DigitalWindow.setObjectName("DigitalWindow")
+        DigitalWindow.resize(1236, 739)
+        self.centralwidget = QtGui.QWidget(DigitalWindow)
+        self.centralwidget.setObjectName("centralwidget")
+        self.closeButton = QtGui.QPushButton(self.centralwidget)
+        self.closeButton.setGeometry(QtCore.QRect(1120, 640, 101, 31))
+        self.closeButton.setObjectName("closeButton")
+        self.sinkFrame = QtGui.QFrame(self.centralwidget)
+        self.sinkFrame.setGeometry(QtCore.QRect(10, 10, 1221, 501))
+        self.sinkFrame.setFrameShape(QtGui.QFrame.StyledPanel)
+        self.sinkFrame.setFrameShadow(QtGui.QFrame.Raised)
+        self.sinkFrame.setObjectName("sinkFrame")
+        self.horizontalLayoutWidget = QtGui.QWidget(self.sinkFrame)
+        self.horizontalLayoutWidget.setGeometry(QtCore.QRect(10, 10, 1201, 481))
+        self.horizontalLayoutWidget.setObjectName("horizontalLayoutWidget")
+        self.sinkLayout = QtGui.QHBoxLayout(self.horizontalLayoutWidget)
+        self.sinkLayout.setObjectName("sinkLayout")
+        self.channelModeBox = QtGui.QGroupBox(self.centralwidget)
+        self.channelModeBox.setGeometry(QtCore.QRect(290, 520, 291, 161))
+        self.channelModeBox.setObjectName("channelModeBox")
+        self.timeLabel = QtGui.QLabel(self.channelModeBox)
+        self.timeLabel.setGeometry(QtCore.QRect(10, 90, 101, 17))
+        self.timeLabel.setObjectName("timeLabel")
+        self.timeEdit = QtGui.QLineEdit(self.channelModeBox)
+        self.timeEdit.setGeometry(QtCore.QRect(160, 90, 113, 23))
+        self.timeEdit.setObjectName("timeEdit")
+        self.snrEdit = QtGui.QLineEdit(self.channelModeBox)
+        self.snrEdit.setGeometry(QtCore.QRect(160, 30, 113, 23))
+        self.snrEdit.setObjectName("snrEdit")
+        self.snrLabel = QtGui.QLabel(self.channelModeBox)
+        self.snrLabel.setGeometry(QtCore.QRect(10, 30, 111, 20))
+        self.snrLabel.setObjectName("snrLabel")
+        self.freqEdit = QtGui.QLineEdit(self.channelModeBox)
+        self.freqEdit.setGeometry(QtCore.QRect(160, 60, 113, 23))
+        self.freqEdit.setObjectName("freqEdit")
+        self.freqLabel = QtGui.QLabel(self.channelModeBox)
+        self.freqLabel.setGeometry(QtCore.QRect(10, 60, 141, 17))
+        self.freqLabel.setObjectName("freqLabel")
+        self.rxBox = QtGui.QGroupBox(self.centralwidget)
+        self.rxBox.setGeometry(QtCore.QRect(590, 520, 251, 161))
+        self.rxBox.setObjectName("rxBox")
+        self.gainMuEdit = QtGui.QLineEdit(self.rxBox)
+        self.gainMuEdit.setGeometry(QtCore.QRect(120, 30, 113, 23))
+        self.gainMuEdit.setObjectName("gainMuEdit")
+        self.gainMuLabel = QtGui.QLabel(self.rxBox)
+        self.gainMuLabel.setGeometry(QtCore.QRect(10, 30, 111, 20))
+        self.gainMuLabel.setObjectName("gainMuLabel")
+        self.alphaEdit = QtGui.QLineEdit(self.rxBox)
+        self.alphaEdit.setGeometry(QtCore.QRect(120, 60, 113, 23))
+        self.alphaEdit.setObjectName("alphaEdit")
+        self.alphaLabel = QtGui.QLabel(self.rxBox)
+        self.alphaLabel.setGeometry(QtCore.QRect(10, 60, 111, 20))
+        self.alphaLabel.setObjectName("alphaLabel")
+        self.sysBox = QtGui.QGroupBox(self.centralwidget)
+        self.sysBox.setGeometry(QtCore.QRect(20, 520, 261, 161))
+        self.sysBox.setObjectName("sysBox")
+        self.sampleRateEdit = QtGui.QLineEdit(self.sysBox)
+        self.sampleRateEdit.setGeometry(QtCore.QRect(140, 30, 113, 23))
+        self.sampleRateEdit.setObjectName("sampleRateEdit")
+        self.sampleRateLabel = QtGui.QLabel(self.sysBox)
+        self.sampleRateLabel.setGeometry(QtCore.QRect(10, 30, 121, 20))
+        self.sampleRateLabel.setObjectName("sampleRateLabel")
+        self.pauseButton = QtGui.QPushButton(self.centralwidget)
+        self.pauseButton.setGeometry(QtCore.QRect(1120, 520, 101, 31))
+        self.pauseButton.setObjectName("pauseButton")
+        self.rxBox_2 = QtGui.QGroupBox(self.centralwidget)
+        self.rxBox_2.setGeometry(QtCore.QRect(850, 520, 251, 161))
+        self.rxBox_2.setObjectName("rxBox_2")
+        self.pktsRcvdEdit = QtGui.QLineEdit(self.rxBox_2)
+        self.pktsRcvdEdit.setGeometry(QtCore.QRect(120, 30, 113, 23))
+        self.pktsRcvdEdit.setObjectName("pktsRcvdEdit")
+        self.pktsRcvdLabel = QtGui.QLabel(self.rxBox_2)
+        self.pktsRcvdLabel.setGeometry(QtCore.QRect(10, 30, 111, 20))
+        self.pktsRcvdLabel.setObjectName("pktsRcvdLabel")
+        self.pktsCorrectEdit = QtGui.QLineEdit(self.rxBox_2)
+        self.pktsCorrectEdit.setGeometry(QtCore.QRect(120, 60, 113, 23))
+        self.pktsCorrectEdit.setObjectName("pktsCorrectEdit")
+        self.pktsCorrectLabel = QtGui.QLabel(self.rxBox_2)
+        self.pktsCorrectLabel.setGeometry(QtCore.QRect(10, 60, 111, 20))
+        self.pktsCorrectLabel.setObjectName("pktsCorrectLabel")
+        self.perLabel = QtGui.QLabel(self.rxBox_2)
+        self.perLabel.setGeometry(QtCore.QRect(10, 90, 111, 20))
+        self.perLabel.setObjectName("perLabel")
+        self.perEdit = QtGui.QLineEdit(self.rxBox_2)
+        self.perEdit.setGeometry(QtCore.QRect(120, 90, 113, 23))
+        self.perEdit.setObjectName("perEdit")
+        DigitalWindow.setCentralWidget(self.centralwidget)
+        self.menubar = QtGui.QMenuBar(DigitalWindow)
+        self.menubar.setGeometry(QtCore.QRect(0, 0, 1236, 25))
+        self.menubar.setObjectName("menubar")
+        self.menuFile = QtGui.QMenu(self.menubar)
+        self.menuFile.setObjectName("menuFile")
+        DigitalWindow.setMenuBar(self.menubar)
+        self.statusbar = QtGui.QStatusBar(DigitalWindow)
+        self.statusbar.setObjectName("statusbar")
+        DigitalWindow.setStatusBar(self.statusbar)
+        self.actionExit = QtGui.QAction(DigitalWindow)
+        self.actionExit.setObjectName("actionExit")
+        self.menuFile.addAction(self.actionExit)
+        self.menubar.addAction(self.menuFile.menuAction())
+
+        self.retranslateUi(DigitalWindow)
+        QtCore.QObject.connect(self.closeButton, QtCore.SIGNAL("clicked()"), DigitalWindow.close)
+        QtCore.QObject.connect(self.actionExit, QtCore.SIGNAL("triggered()"), DigitalWindow.close)
+        QtCore.QMetaObject.connectSlotsByName(DigitalWindow)
+        DigitalWindow.setTabOrder(self.closeButton, self.snrEdit)
+        DigitalWindow.setTabOrder(self.snrEdit, self.freqEdit)
+        DigitalWindow.setTabOrder(self.freqEdit, self.timeEdit)
+
+    def retranslateUi(self, DigitalWindow):
+        DigitalWindow.setWindowTitle(QtGui.QApplication.translate("DigitalWindow", "MainWindow", None, QtGui.QApplication.UnicodeUTF8))
+        self.closeButton.setText(QtGui.QApplication.translate("DigitalWindow", "Close", None, QtGui.QApplication.UnicodeUTF8))
+        self.channelModeBox.setTitle(QtGui.QApplication.translate("DigitalWindow", "Channel Model Parameters", None, QtGui.QApplication.UnicodeUTF8))
+        self.timeLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Timing Offset", None, QtGui.QApplication.UnicodeUTF8))
+        self.snrLabel.setText(QtGui.QApplication.translate("DigitalWindow", "SNR (dB)", None, QtGui.QApplication.UnicodeUTF8))
+        self.freqLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Frequency Offset (Hz)", None, QtGui.QApplication.UnicodeUTF8))
+        self.rxBox.setTitle(QtGui.QApplication.translate("DigitalWindow", "Receiver Parameters", None, QtGui.QApplication.UnicodeUTF8))
+        self.gainMuLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Gain mu", None, QtGui.QApplication.UnicodeUTF8))
+        self.alphaLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Alpha", None, QtGui.QApplication.UnicodeUTF8))
+        self.sysBox.setTitle(QtGui.QApplication.translate("DigitalWindow", "System Parameters", None, QtGui.QApplication.UnicodeUTF8))
+        self.sampleRateLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Sample Rate (sps)", None, QtGui.QApplication.UnicodeUTF8))
+        self.pauseButton.setText(QtGui.QApplication.translate("DigitalWindow", "Pause", None, QtGui.QApplication.UnicodeUTF8))
+        self.rxBox_2.setTitle(QtGui.QApplication.translate("DigitalWindow", "Received Packet Info", None, QtGui.QApplication.UnicodeUTF8))
+        self.pktsRcvdLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Packets Rcvd.", None, QtGui.QApplication.UnicodeUTF8))
+        self.pktsCorrectLabel.setText(QtGui.QApplication.translate("DigitalWindow", "Packets Correct", None, QtGui.QApplication.UnicodeUTF8))
+        self.perLabel.setText(QtGui.QApplication.translate("DigitalWindow", "PER", None, QtGui.QApplication.UnicodeUTF8))
+        self.menuFile.setTitle(QtGui.QApplication.translate("DigitalWindow", "&File", None, QtGui.QApplication.UnicodeUTF8))
+        self.actionExit.setText(QtGui.QApplication.translate("DigitalWindow", "E&xit", None, QtGui.QApplication.UnicodeUTF8))
+