fix two long-standing bugs in packaging
authorBdale Garbee <bdale@gag.com>
Wed, 15 Jul 2009 07:10:33 +0000 (01:10 -0600)
committerBdale Garbee <bdale@gag.com>
Wed, 15 Jul 2009 07:10:33 +0000 (01:10 -0600)
debian/changelog
debian/sudo-ldap.postinst
debian/sudo.postinst

index bbd1665452a55baa1c2d46d49ba6bea41591c44a..570548235d52c290afb1a05c83fd7856c684fabd 100644 (file)
@@ -1,6 +1,8 @@
 sudo (1.7.2-1) UNRELEASED; urgency=low
 
   * new upstream version, closes: #537103
+  * improve initial sudoers commented-out example, closes: #536220
+  * fix update-rc.d call to create correct sudo-ldap link, closes: #387880
 
  -- Bdale Garbee <bdale@gag.com>  Wed, 15 Jul 2009 00:52:27 -0600
 
index b89a8a533ec651bb3797882bd6738aeef8c7c418..d7184d5171bd63e1335eb8ad1e218a36a3563179 100644 (file)
@@ -23,7 +23,7 @@ if ( ! -f "/etc/sudoers") {
          "# Uncomment to allow members of group sudo to not need a password\n",
          "# (Note that later entries override this, so you might need to move\n",
           "# it further down)\n",
-         "# %sudo ALL=NOPASSWD: ALL\n";
+         "# %sudo ALL=(ALL) NOPASSWD: ALL\n";
        close SUDOERS;
 
 }
@@ -32,10 +32,10 @@ if ( ! -f "/etc/sudoers") {
 system ('chown root:root /etc/sudoers');
 system ('chmod 440 /etc/sudoers');
 
-# must do a remove first to un-do the "bad" links created by previous version
+# do a remove first to un-do "bad" links created by previous versions
 system ('update-rc.d -f sudo remove >/dev/null 2>&1');
 
-system ('update-rc.d sudo start 75 S . >/dev/null');
+system ('update-rc.d sudo-ldap start 75 S . >/dev/null');
 
 # make sure we have a sudo group
 
index 2229c83598147e87584f2aabf3385dc76eda2774..1494ccd8f570d173b0821d59fcc1e4bf2c15b996 100644 (file)
@@ -23,7 +23,7 @@ if ( ! -f "/etc/sudoers") {
          "# Uncomment to allow members of group sudo to not need a password\n",
          "# (Note that later entries override this, so you might need to move\n",
           "# it further down)\n",
-         "# %sudo ALL=NOPASSWD: ALL\n";
+         "# %sudo ALL=(ALL) NOPASSWD: ALL\n";
        close SUDOERS;
 
 }