Fix to restore ability to run 'make distcheck' from a VPATH
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Sun, 4 Oct 2009 01:38:35 +0000 (18:38 -0700)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Sun, 4 Oct 2009 01:38:35 +0000 (18:38 -0700)
gr-qtgui/src/lib/Makefile.am

index 290af1dd3792526c06815854f919b270fd4815c6..b6c8f3f4d0a0e611a72aefe8ea0054102282ea3a 100644 (file)
@@ -79,7 +79,7 @@ grinclude_HEADERS =                   \
 
 if BUILD_QT
 %_moc.cc : %.h
-       $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB $< -o $@
+       $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@
 
 %_ui.h : %.ui
        $(QT_UIC_EXEC) $< -o $@