Search for rm, and substitute it. Avoids assumption that make
authorgdt <gdt@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 23 Oct 2006 14:58:05 +0000 (14:58 +0000)
committergdt <gdt@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 23 Oct 2006 14:58:05 +0000 (14:58 +0000)
predefines RM (BSD make does not).

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3835 221aa14e-8319-0410-a670-987f0aec2ac5

gr-howto-write-a-block/Makefile.common
gr-howto-write-a-block/configure.ac
gr-howto-write-a-block/doc/Makefile.am

index 31a31232a782b122e40b58abf631407468c49617..0160c354a2ec66b44b4a5a553c9690974d56bc68 100644 (file)
@@ -36,3 +36,8 @@ grpyexecdir = $(pyexecdir)/gnuradio
 # swig flags
 SWIGPYTHONFLAGS = -fvirtual -python -modern
 SWIGGRFLAGS = -I$(GNURADIO_CORE_INCLUDEDIR)/swig -I$(GNURADIO_CORE_INCLUDEDIR)
+
+# Don't assume that make predefines $(RM), because BSD make does
+# not. We define it now in configure.ac using AM_PATH_PROG, but now
+# here have to add a -f to be like GNU make.
+RM=$(RM_PROG) -f
index 7035599d5309d5c6077985467028460b106332bf..9cf72f09301acb24bfb25fabd300bed1fe652ffb 100644 (file)
@@ -36,6 +36,7 @@ GR_PROG_AS
 AC_PROG_LN_S
 AC_PROG_MAKE_SET
 AC_PROG_INSTALL
+AC_PATH_PROG([RM_PROG], [rm])
 
 AC_LIBTOOL_WIN32_DLL
 AC_ENABLE_SHARED       dnl do build shared libraries
index 07e6f5961356725f5975c7517677bc9159b56ba4..5ca6a5a394f41fb8297ebfcfb1377141f2bb2e8f 100644 (file)
@@ -72,7 +72,7 @@ howto_square2_ff.h.xml: $(top_srcdir)/src/lib/howto_square2_ff.h make_numbered_l
 # ----------------------------------------------------------------
 
 clean:
-       -rm -f $(TARGETS) $(BUILT_XML_FILES)
+       -${RM} -f $(TARGETS) $(BUILT_XML_FILES)
 
 %.html : %.xml
        xmlto html-nochunks $<