Rename dialtone -> dial_tone in examples.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 18 Dec 2006 04:43:36 +0000 (04:43 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Mon, 18 Dec 2006 04:43:36 +0000 (04:43 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4127 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-examples/c++/Makefile.am
gnuradio-examples/c++/dial_tone/Makefile.am [new file with mode: 0644]
gnuradio-examples/c++/dial_tone/dial_tone.cc [new file with mode: 0644]
gnuradio-examples/c++/dial_tone/dial_tone.h [new file with mode: 0644]
gnuradio-examples/c++/dial_tone/main.cc [new file with mode: 0644]
gnuradio-examples/c++/dialtone/Makefile.am [deleted file]
gnuradio-examples/c++/dialtone/dialtone.cc [deleted file]
gnuradio-examples/c++/dialtone/dialtone.h [deleted file]
gnuradio-examples/c++/dialtone/main.cc [deleted file]

index f25bbaa8f611b447437b1fefec751e368ede0c3c..4630d6933fb5582be3a195ecb7931884da5de6b8 100644 (file)
@@ -22,6 +22,6 @@
 include $(top_srcdir)/Makefile.common
 
 SUBDIRS = \
-    dialtone \
+    dial_tone \
     hier
 
diff --git a/gnuradio-examples/c++/dial_tone/Makefile.am b/gnuradio-examples/c++/dial_tone/Makefile.am
new file mode 100644 (file)
index 0000000..7bc8c50
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright 2006 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+include $(top_srcdir)/Makefile.common
+
+# For compiling within the GNU Radio build tree
+INCLUDES=$(STD_DEFINES_AND_INCLUDES) \
+         -I$(top_srcdir)/gr-audio-alsa/src 
+
+GR_AUDIO_ALSA_LIBS=$(top_builddir)/gr-audio-alsa/src/libgr_audio_alsa.la
+
+# For compiling outside the tree, these are the usual
+# INCLUDES = -I/usr/local/include -I/usr/local/include/gnuradio
+# GNURADIO_CORE_LIBS = -lgnuradio-core
+# GR_AUDIO_ALSA_LIBS = -lgr_audio_alsa
+
+noinst_PROGRAMS = dial_tone
+    
+noinst_HEADERS = \
+    dial_tone.h
+        
+dial_tone_SOURCES = \
+    dial_tone.cc          \
+    main.cc
+
+dial_tone_LDADD = \
+    $(GNURADIO_CORE_LIBS) \
+    $(GR_AUDIO_ALSA_LIBS)
+
+MOSTLYCLEANFILES = *~
diff --git a/gnuradio-examples/c++/dial_tone/dial_tone.cc b/gnuradio-examples/c++/dial_tone/dial_tone.cc
new file mode 100644 (file)
index 0000000..ecd46cd
--- /dev/null
@@ -0,0 +1,45 @@
+/*
+ * Copyright 2006 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#include <dial_tone.h>
+#include <gr_io_signature.h>
+#include <gr_sig_source_f.h>
+#include <audio_alsa_sink.h>
+
+// Shared pointer constructor
+dial_tone_sptr make_dial_tone()
+{
+    return dial_tone_sptr(new dial_tone());
+}
+
+// Hierarchical block constructor, with no inputs or outputs
+dial_tone::dial_tone() : 
+gr_hier_block2("dial_tone",
+              gr_make_io_signature(0,0,0),
+              gr_make_io_signature(0,0,0))
+{
+    define_component("source0", gr_make_sig_source_f(48000, GR_SIN_WAVE, 350, 0.1));
+    define_component("source1", gr_make_sig_source_f(48000, GR_SIN_WAVE, 440, 0.1));
+    define_component("sink", audio_alsa_make_sink(48000));
+
+    connect("source0", 0, "sink", 0);
+    connect("source1", 0, "sink", 1);    
+}
diff --git a/gnuradio-examples/c++/dial_tone/dial_tone.h b/gnuradio-examples/c++/dial_tone/dial_tone.h
new file mode 100644 (file)
index 0000000..0cd27a0
--- /dev/null
@@ -0,0 +1,33 @@
+/*
+ * Copyright 2006 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+#include <gr_hier_block2.h>
+
+class dial_tone;
+typedef boost::shared_ptr<dial_tone> dial_tone_sptr;
+dial_tone_sptr make_dial_tone();
+
+class dial_tone : public gr_hier_block2
+{
+private:
+    dial_tone();
+    friend dial_tone_sptr make_dial_tone();
+};
diff --git a/gnuradio-examples/c++/dial_tone/main.cc b/gnuradio-examples/c++/dial_tone/main.cc
new file mode 100644 (file)
index 0000000..1fcfa15
--- /dev/null
@@ -0,0 +1,38 @@
+/*
+ * Copyright 2006 Free Software Foundation, Inc.
+ * 
+ * This file is part of GNU Radio
+ * 
+ * GNU Radio is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2, or (at your option)
+ * any later version.
+ * 
+ * GNU Radio is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with GNU Radio; see the file COPYING.  If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street,
+ * Boston, MA 02110-1301, USA.
+ */
+
+// GNU Radio C++ application
+//
+// Instantiate a top block
+// Instantiate a runtime, passing it the top block
+// Tell the runtime to go...
+
+#include <dial_tone.h>
+#include <gr_runtime.h>
+
+int main()
+{
+    dial_tone_sptr top_block = make_dial_tone();
+    gr_runtime_sptr runtime = gr_make_runtime(top_block);
+
+    runtime->run();   
+    return 0;
+}
diff --git a/gnuradio-examples/c++/dialtone/Makefile.am b/gnuradio-examples/c++/dialtone/Makefile.am
deleted file mode 100644 (file)
index 35e8073..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright 2006 Free Software Foundation, Inc.
-# 
-# This file is part of GNU Radio
-# 
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
-# 
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-# 
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-# 
-
-include $(top_srcdir)/Makefile.common
-
-# For compiling within the GNU Radio build tree
-INCLUDES=$(STD_DEFINES_AND_INCLUDES) \
-         -I$(top_srcdir)/gr-audio-alsa/src 
-
-GR_AUDIO_ALSA_LIBS=$(top_builddir)/gr-audio-alsa/src/libgr_audio_alsa.la
-
-# For compiling outside the tree, these are the usual
-# INCLUDES = -I/usr/local/include -I/usr/local/include/gnuradio
-# GNURADIO_CORE_LIBS = -lgnuradio-core
-# GR_AUDIO_ALSA_LIBS = -lgr_audio_alsa
-
-noinst_PROGRAMS = dialtone
-    
-noinst_HEADERS = \
-    dialtone.h
-        
-dialtone_SOURCES = \
-    dialtone.cc           \
-    main.cc
-
-dialtone_LDADD = \
-    $(GNURADIO_CORE_LIBS) \
-    $(GR_AUDIO_ALSA_LIBS)
-
-MOSTLYCLEANFILES = *~
diff --git a/gnuradio-examples/c++/dialtone/dialtone.cc b/gnuradio-examples/c++/dialtone/dialtone.cc
deleted file mode 100644 (file)
index 0debb28..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-/*
- * Copyright 2006 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#include <dialtone.h>
-#include <gr_io_signature.h>
-#include <gr_sig_source_f.h>
-#include <audio_alsa_sink.h>
-
-// Shared pointer constructor
-dialtone_sptr make_dialtone()
-{
-    return dialtone_sptr(new dialtone());
-}
-
-// Hierarchical block constructor, with no inputs or outputs
-dialtone::dialtone() : 
-gr_hier_block2("dialtone",
-              gr_make_io_signature(0,0,0),
-              gr_make_io_signature(0,0,0))
-{
-    define_component("source0", gr_make_sig_source_f(48000, GR_SIN_WAVE, 350, 0.1));
-    define_component("source1", gr_make_sig_source_f(48000, GR_SIN_WAVE, 440, 0.1));
-    define_component("sink", audio_alsa_make_sink(48000));
-
-    connect("source0", 0, "sink", 0);
-    connect("source1", 0, "sink", 1);    
-}
diff --git a/gnuradio-examples/c++/dialtone/dialtone.h b/gnuradio-examples/c++/dialtone/dialtone.h
deleted file mode 100644 (file)
index 2beb46c..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-/*
- * Copyright 2006 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-#include <gr_hier_block2.h>
-
-class dialtone;
-typedef boost::shared_ptr<dialtone> dialtone_sptr;
-dialtone_sptr make_dialtone();
-
-class dialtone : public gr_hier_block2
-{
-private:
-    dialtone();
-    friend dialtone_sptr make_dialtone();
-};
diff --git a/gnuradio-examples/c++/dialtone/main.cc b/gnuradio-examples/c++/dialtone/main.cc
deleted file mode 100644 (file)
index beefac3..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-/*
- * Copyright 2006 Free Software Foundation, Inc.
- * 
- * This file is part of GNU Radio
- * 
- * GNU Radio is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2, or (at your option)
- * any later version.
- * 
- * GNU Radio is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with GNU Radio; see the file COPYING.  If not, write to
- * the Free Software Foundation, Inc., 51 Franklin Street,
- * Boston, MA 02110-1301, USA.
- */
-
-// GNU Radio C++ application
-//
-// Instantiate a top block
-// Instantiate a runtime, passing it the top block
-// Tell the runtime to go...
-
-#include <dialtone.h>
-#include <gr_runtime.h>
-
-int main()
-{
-    dialtone_sptr top_block = make_dialtone();
-    gr_runtime_sptr runtime = gr_make_runtime(top_block);
-
-    runtime->run();   
-    return 0;
-}