Cruft removal.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 12 Oct 2007 03:54:50 +0000 (03:54 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Fri, 12 Oct 2007 03:54:50 +0000 (03:54 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6621 221aa14e-8319-0410-a670-987f0aec2ac5

config/Makefile.am
config/grc_ezdop.m4 [deleted file]
config/grc_gr_error_correcting_codes.m4 [deleted file]
config/grc_gr_ezdop.m4 [deleted file]
config/grc_gr_rdf.m4 [deleted file]

index 458a81a7d81939817d2ae910d0f0382972eb95ff..be85ce7c8c1f396ddc3e3a6632e018c33b5b231f 100644 (file)
@@ -41,11 +41,9 @@ m4macros = \
        grc_gr_audio_portaudio.m4 \
        grc_gr_audio_windows.m4 \
        grc_gr_comedi.m4 \
-       grc_gr_error_correcting_codes.m4 \
        grc_gr_gsm_fr_vocoder.m4 \
        grc_gr_radar_mono.m4 \
        grc_gr_radio_astronomy.m4 \
-       grc_gr_rdf.m4 \
        grc_gr_sounder.m4 \
        grc_gr_trellis.m4 \
        grc_gr_usrp.m4 \
diff --git a/config/grc_ezdop.m4 b/config/grc_ezdop.m4
deleted file mode 100644 (file)
index 17ae2fd..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
-dnl 
-dnl This file is part of GNU Radio
-dnl 
-dnl GNU Radio is free software; you can redistribute it and/or modify
-dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 3, or (at your option)
-dnl any later version.
-dnl 
-dnl GNU Radio is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-dnl GNU General Public License for more details.
-dnl 
-dnl You should have received a copy of the GNU General Public License
-dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street,
-dnl Boston, MA 02110-1301, USA.
-
-AC_DEFUN([GRC_EZDOP],[
-    GRC_ENABLE([ezdop])
-
-    AC_CONFIG_FILES([ \
-       ezdop/Makefile \
-       ezdop/ezdop.pc \
-       ezdop/src/Makefile \
-       ezdop/src/firmware/Makefile \
-       ezdop/src/host/Makefile \
-       ezdop/src/host/avrdude/Makefile \
-       ezdop/src/host/ezdop/Makefile \
-       ezdop/src/host/tests/Makefile \
-    ])
-
-    passed=yes
-
-    # See ticket:96 in trac
-    AM_PROG_CC_C_O
-
-    # Firmware build requires Atmel AVR microcontroller port of GCC
-    AC_PATH_PROG([AVRGCC], [avr-gcc -v], [no])
-    if test x$AVRGCC = xno; then
-       passed=no
-       AC_MSG_RESULT([ezdop requires avr-gcc, not found.])
-    fi
-    
-    # ...and binutils
-    AC_PATH_PROG([AVROBJCOPY], [avr-objcopy], [no])
-    if test x$AVROBJCOPY = xno; then
-       passed=no
-       AC_MSG_RESULT([ezdop requires avr binutils, not found.])
-    fi
-    
-    # ...and standard library (test not working yet)
-    #AC_CHECK_HEADERS([avr/io.h],[],
-    #   [passed=no;AC_MSG_RESULT([ezdop requires avr glibc, not found.])])
-
-    # Device access is via libftdi
-    AC_LANG_PUSH(C)
-    AC_CHECK_HEADERS([ftdi.h],[],
-        [passed=no;AC_MSG_RESULT([ezdop requires ftdi.h, not found.])])
-    save_LIBS="$LIBS"
-    AC_SEARCH_LIBS([ftdi_init], [ftdi],[FTDI_LIBS="$LIBS"],
-        [passed=no;AC_MSG_RESULT([ezdop requires libftdi, not found.])])
-    LIBS="$save_LIBS"
-    AC_LANG_POP
-
-    GRC_BUILD_CONDITIONAL([ezdop],[
-       EZDOP_INCLUDES='-I$(top_srcdir)/ezdop/src/host/ezdop/ -I$(top_srcdir)/ezdop/src/firmware/'
-       EZDOP_LIBS='-lezdop'
-       AC_SUBST(FTDI_LIBS)
-       AC_SUBST(EZDOP_INCLUDES)
-       AC_SUBST(EZDOP_LIBS)
-       AC_SUBST(AVRGCC)
-       AC_SUBST(AVROBJCOPY)
-    ])
-])
diff --git a/config/grc_gr_error_correcting_codes.m4 b/config/grc_gr_error_correcting_codes.m4
deleted file mode 100644 (file)
index 93ee4b8..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
-dnl 
-dnl This file is part of GNU Radio
-dnl 
-dnl GNU Radio is free software; you can redistribute it and/or modify
-dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 3, or (at your option)
-dnl any later version.
-dnl 
-dnl GNU Radio is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-dnl GNU General Public License for more details.
-dnl 
-dnl You should have received a copy of the GNU General Public License
-dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street,
-dnl Boston, MA 02110-1301, USA.
-
-AC_DEFUN([GRC_GR_ERROR_CORRECTING_CODES],[
-    GRC_ENABLE([gr-error-correcting-codes])
-
-    AC_CONFIG_FILES([\
-       gr-error-correcting-codes/Makefile \
-       gr-error-correcting-codes/src/Makefile \
-       gr-error-correcting-codes/src/lib/Makefile \
-       gr-error-correcting-codes/src/lib/libecc/Makefile \
-       gr-error-correcting-codes/src/lib/libecc/mld/Makefile \
-       gr-error-correcting-codes/src/lib/libecc/tests/Makefile \
-       gr-error-correcting-codes/src/python/Makefile \
-       gr-error-correcting-codes/src/python/run_tests \
-    ])
-
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-error-correcting-codes],[
-        dnl run_tests is created from run_tests.in.  Make it executable.
-        AC_CONFIG_COMMANDS([run_tests_error_correcting_codes], [chmod +x gr-error-correcting-codes/src/python/run_tests])
-    ])
-])
diff --git a/config/grc_gr_ezdop.m4 b/config/grc_gr_ezdop.m4
deleted file mode 100644 (file)
index d2bb881..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
-dnl 
-dnl This file is part of GNU Radio
-dnl 
-dnl GNU Radio is free software; you can redistribute it and/or modify
-dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 3, or (at your option)
-dnl any later version.
-dnl 
-dnl GNU Radio is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-dnl GNU General Public License for more details.
-dnl 
-dnl You should have received a copy of the GNU General Public License
-dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street,
-dnl Boston, MA 02110-1301, USA.
-
-AC_DEFUN([GRC_GR_EZDOP],[
-    GRC_ENABLE([gr-ezdop])
-
-    AC_CONFIG_FILES([ \
-       gr-ezdop/Makefile \
-       gr-ezdop/src/Makefile \
-       gr-ezdop/src/lib/Makefile \
-       gr-ezdop/src/python/Makefile \
-       gr-ezdop/src/python/run_tests \
-    ])
-
-    passed=yes
-    # Don't do gr-ezdop if ezdop failed
-    # There *has* to be a better way to check if a value is in a string
-    for dir in $skipped_dirs
-    do
-       if test $dir = ezdop; then
-           passed=no
-       fi
-    done
-
-    GRC_BUILD_CONDITIONAL([gr-ezdop],[
-       dnl run_tests is created from run_tests.in.  Make it executable.
-       AC_CONFIG_COMMANDS([run_tests_ezdop], [chmod +x gr-ezdop/src/python/run_tests])
-    ])
-])
diff --git a/config/grc_gr_rdf.m4 b/config/grc_gr_rdf.m4
deleted file mode 100644 (file)
index 0b099e3..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006 Free Software Foundation, Inc.
-dnl 
-dnl This file is part of GNU Radio
-dnl 
-dnl GNU Radio is free software; you can redistribute it and/or modify
-dnl it under the terms of the GNU General Public License as published by
-dnl the Free Software Foundation; either version 3, or (at your option)
-dnl any later version.
-dnl 
-dnl GNU Radio is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-dnl GNU General Public License for more details.
-dnl 
-dnl You should have received a copy of the GNU General Public License
-dnl along with GNU Radio; see the file COPYING.  If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street,
-dnl Boston, MA 02110-1301, USA.
-
-AC_DEFUN([GRC_GR_RDF],[
-    GRC_ENABLE([gr-rdf])
-
-    AC_CONFIG_FILES([\
-       gr-rdf/Makefile \
-       gr-rdf/src/Makefile \
-       gr-rdf/src/lib/Makefile \
-       gr-rdf/src/python/Makefile \
-    ])
-
-    passed=yes
-    GRC_BUILD_CONDITIONAL([gr-rdf],[
-        dnl run_tests is created from run_tests.in.  Make it executable.
-        dnl AC_CONFIG_COMMANDS([run_tests_rdf], [chmod +x gr-rdf/src/python/run_tests])
-    ])
-])