Misc. gnuradio-core build system minor cleanup.
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 3 Aug 2006 14:04:22 +0000 (14:04 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 3 Aug 2006 14:04:22 +0000 (14:04 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3124 221aa14e-8319-0410-a670-987f0aec2ac5

TODO.build [new file with mode: 0644]
gnuradio-core/Makefile.am
gnuradio-core/doc/Makefile.am
gnuradio-core/src/lib/Makefile.am

diff --git a/TODO.build b/TODO.build
new file mode 100644 (file)
index 0000000..4c62b87
--- /dev/null
@@ -0,0 +1,45 @@
+Overall:
+
+* VPATH builds fail, starting with usrp.
+
+* Change a Makefile.am in a subdir, must manually go back up and re-run
+configure. Otherwise it gets run somehow incorrectly.
+
+* Fix overuse of LIBS vs. LIBADD, LDADD, or LDFLAGS, allong with xxx_
+
+* Make dist and distcheck have not been tested.
+
+dtools:
+
+* No checking or testing done in this directory.
+
+gnuradio-core:
+
+* NEWS, README, and TODO are stale.
+
+gnuradio-core/doc:
+
+* Make hasn't been tested yet in this directory.
+
+gnuradio-core/src/gen_interpolator_taps:
+
+* Make hasn't been tested yet in this directory.
+
+gnuradio-core/src/lib/filter:
+
+* README is stale.
+
+gnuradio-core/src/lib/general:
+
+* README is stale.
+
+gnuradio-core/src/lib/tests:
+
+* Cleanup libgnuradio-core variable, try to refer to something in
+Makefile.common 
+
+gnuradio-core/src/lib/utils:
+
+* Not all *.m files are referenced in Makefile.am for distribution. Is
+this correct?
+
index b4b619b8b754b8337ee61a5428d92503e3b32db3..846c5999486f9a37219fcc873278d2c54639b631 100644 (file)
@@ -29,8 +29,5 @@ EXTRA_DIST =                          \
 
 SUBDIRS = src doc
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = gnuradio-core.pc
-
 etcdir = $(sysconfdir)/gnuradio/conf.d
 etc_DATA = gnuradio-core.conf
index 562b36654c954c733a52f33e4e7a646928963b8d..40c910d720e2e2376b432053f97e7687339a5ef3 100644 (file)
@@ -54,7 +54,7 @@ prep:
 
 install-data-local:
        $(mkinstalldirs) $(DESTDIR)$(docdir)
-       @for i in $(top_srcdir)/README $(top_srcdir)/README.hacking $(top_srcdir)/ChangeLog; do \
+       @for i in $(top_srcdir)/gnuradio-core/README $(top_srcdir)/gnuradio-core/README.hacking $(top_srcdir)/gnuradio-core/ChangeLog; do \
                echo "$(INSTALL_DATA) $$i $(DESTDIR)$(docdir)"; \
                $(INSTALL_DATA) $$i $(DESTDIR)$(docdir); \
        done
index 2b31b3fcefe75efc03677c33bd42e1ec7fb543b9..7d37a4e35dab2a4e5bc80106103ceab602c5f510 100644 (file)
@@ -25,7 +25,7 @@ include $(top_srcdir)/Makefile.common
 
 # We've got to build . before swig
 # FIXME add atsc back
-SUBDIRS =      missing runtime filter general g72x reed-solomon omnithread io . swig
+SUBDIRS = missing runtime filter general g72x reed-solomon omnithread io . swig
 
 # generate libgnuradio-core.la from the convenience libraries in subdirs
 
@@ -59,4 +59,3 @@ libgnuradio_core_qa_la_LIBADD  =      \
        missing/libmissing.la           \
        libgnuradio-core.la             \
        $(CPPUNIT_LIBS)                 
-